aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2020-12-28 20:56:38 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2020-12-28 20:56:38 +0000
commit027d323fb46e63398cc684f8ecef05140ec56077 (patch)
tree884a34221f7a57b98eee694c102fa2127f171e43 /net
parenta58865159f8136e024ea2ee6bd7209630809d50b (diff)
downloadports-027d323fb46e63398cc684f8ecef05140ec56077.tar.gz
ports-027d323fb46e63398cc684f8ecef05140ec56077.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/scapy/Makefile22
1 files changed, 3 insertions, 19 deletions
diff --git a/net/scapy/Makefile b/net/scapy/Makefile
index b2c97c89adfe..022ae0173de6 100644
--- a/net/scapy/Makefile
+++ b/net/scapy/Makefile
@@ -17,6 +17,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}libdnet>0:net/py-libdnet@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pypcap>0:net/py-pypcap@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}cryptography>0:security/py-cryptography@${PY_FLAVOR}
+USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
@@ -35,6 +36,7 @@ SOX_DESC= Support for VoIP
GRAPH_RUN_DEPENDS= ${LOCALBASE}/bin/MagickCore-config:graphics/ImageMagick6 \
${LOCALBASE}/bin/dot:graphics/graphviz
+IPYTHON_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ipython>0:devel/ipython@${PY_FLAVOR}
NMAP_RUN_DEPENDS= ${LOCALBASE}/share/nmap/nmap-os-db:security/nmap
MANUF_RUN_DEPENDS= ${LOCALBASE}/share/wireshark/manuf:net/wireshark
MATPLOT_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}matplotlib>0:math/py-matplotlib@${PY_FLAVOR}
@@ -44,24 +46,6 @@ PYX_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyx>0:graphics/py-pyx@${PY_FLAVOR}
QUESO_BASE_RUN_DEPENDS= ${LOCALBASE}/etc/queso.conf.sample:net/queso
SOX_RUN_DEPENDS= ${LOCALBASE}/bin/sox:audio/sox
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MPYX}
-USES+= python:3.4+
-.else
-USES+= python
-.endif
-
-.include <bsd.port.pre.mk>
-
-.if ${PORT_OPTIONS:MIPYTHON}
-.if ${FLAVOR:Mpy27}
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}ipython5>0:devel/ipython5@${PY_FLAVOR}
-.else
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}ipython>0:devel/ipython@${PY_FLAVOR}
-.endif
-.endif
-
post-patch:
@${REINPLACE_CMD} "s,share/man/man1,man/man1," ${WRKSRC}/setup.py
@${REINPLACE_CMD} "s,pdflatex,pdftex," ${WRKSRC}/scapy/extlib.py
@@ -72,4 +56,4 @@ post-patch:
@${REINPLACE_CMD} 's|"use" in line|"use" in line or "nhop" in line|' \
${WRKSRC}/scapy/arch/unix.py
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>