aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2006-02-19 22:40:17 +0000
committerAaron Dalton <aaron@FreeBSD.org>2006-02-19 22:40:17 +0000
commitba89fa56f93376c0731ea54d7f33d44fbbb5c0f3 (patch)
treef341336f658eb3d22ddad7d916326d747d788be3 /net
parent55b05955baa2d0dd0cbe5c429f2d1a088cc26abe (diff)
downloadports-ba89fa56f93376c0731ea54d7f33d44fbbb5c0f3.tar.gz
ports-ba89fa56f93376c0731ea54d7f33d44fbbb5c0f3.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-EPP-Proxy/Makefile35
-rw-r--r--net/p5-Net-EPP-Proxy/distinfo3
-rw-r--r--net/p5-Net-EPP-Proxy/pkg-descr19
-rw-r--r--net/p5-Net-EPP-Proxy/pkg-plist7
5 files changed, 65 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 42088f899f04..191f83e4cd37 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -399,6 +399,7 @@
SUBDIR += p5-Net-Divert
SUBDIR += p5-Net-EPP-Client
SUBDIR += p5-Net-EPP-Frame
+ SUBDIR += p5-Net-EPP-Proxy
SUBDIR += p5-Net-Finger
SUBDIR += p5-Net-Gnats
SUBDIR += p5-Net-Google
diff --git a/net/p5-Net-EPP-Proxy/Makefile b/net/p5-Net-EPP-Proxy/Makefile
new file mode 100644
index 000000000000..d21af0841be6
--- /dev/null
+++ b/net/p5-Net-EPP-Proxy/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: Net-EPP-Proxy
+# Date created: 19 Feb 2006
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-EPP-Proxy
+PORTVERSION= 0.01
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= A proxy server for the EPP protocol
+
+BUILD_DEPENDS= ${SITE_PERL}/Net/Server.pm:${PORTSDIR}/net/p5-Net-Server \
+ ${SITE_PERL}/Net/EPP/Frame.pm:${PORTSDIR}/net/p5-Net-EPP-Frame \
+ ${SITE_PERL}/Net/EPP/Client.pm:${PORTSDIR}/net/p5-Net-EPP-Client \
+ ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes \
+ ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
+RUN_DEPENDS+= ${BUILD_DEPENDS}
+
+MAN3= Net::EPP::Proxy.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl5.6
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/p5-Net-EPP-Proxy/distinfo b/net/p5-Net-EPP-Proxy/distinfo
new file mode 100644
index 000000000000..4d7013f463a8
--- /dev/null
+++ b/net/p5-Net-EPP-Proxy/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-EPP-Proxy-0.01.tar.gz) = 54dbcd6c8bff1c813aa6cbb1cab2ee86
+SHA256 (Net-EPP-Proxy-0.01.tar.gz) = 9a36fb1db30e1c52448fd98008b828a3ea0f18ff972bcf54eb281b32c9e9f53b
+SIZE (Net-EPP-Proxy-0.01.tar.gz) = 10426
diff --git a/net/p5-Net-EPP-Proxy/pkg-descr b/net/p5-Net-EPP-Proxy/pkg-descr
new file mode 100644
index 000000000000..8750c9268f9a
--- /dev/null
+++ b/net/p5-Net-EPP-Proxy/pkg-descr
@@ -0,0 +1,19 @@
+EPP is the Extensible Provisioning Protocol. EPP (defined in RFC 3730) is
+an application layer client-server protocol for the provisioning and
+management of objects stored in a shared central repository. Specified in
+XML, the protocol defines generic object management operations and an
+extensible framework that maps protocol operations to objects. As of
+writing, its only well-developed application is the provisioning of
+Internet domain names, hosts, and related contact details.
+
+RFC 3734 defines a TCP based transport model for EPP, and this module
+implements a proxy server for this model. You can use it to construct a
+daemon that maintains a single connection to the EPP server that can be
+used by many local clients, thereby reducing the overhead for each
+transaction.
+
+Net::EPP::Proxy is based on the Net::Server framework and
+Net::EPP::Client, which it uses to communicate with the server.
+
+WWW: http://search.cpan.org/dist/Net-EPP-Proxy
+Author: Gavin Brown <epp@centralnic.com>
diff --git a/net/p5-Net-EPP-Proxy/pkg-plist b/net/p5-Net-EPP-Proxy/pkg-plist
new file mode 100644
index 000000000000..1f365deba223
--- /dev/null
+++ b/net/p5-Net-EPP-Proxy/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Net/EPP/Proxy.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/EPP/Proxy/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/EPP/Proxy
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/EPP
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/Net/EPP
+@dirrmtry %%SITE_PERL%%/Net