aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2022-06-09 20:25:43 +0000
committerCy Schubert <cy@FreeBSD.org>2022-06-20 15:12:00 +0000
commitc4cbed89d034e74ce03561d313ccedd9c576a7cf (patch)
treee24e5bd523acfe1aa498cfa80b9dc06f96d5ff2a /net
parent1e7f4b2c9e382cc3b3fe39f178481d4468ca465b (diff)
downloadports-c4cbed89d034e74ce03561d313ccedd9c576a7cf.tar.gz
ports-c4cbed89d034e74ce03561d313ccedd9c576a7cf.zip
*/*: FreeBSD's WPA does support IBSS mode
FreeBSD's WPA does support IBSS mode. Remove the hack that forces ADHOC mode when IBSS is requested. (cherry picked from commit b8477825c2dc42f6c595697a36f593c71f39fbad)
Diffstat (limited to 'net')
-rw-r--r--net/hostapd-devel/Makefile1
-rw-r--r--net/hostapd-devel/files/patch-src_drivers_driver__bsd.c39
-rw-r--r--net/hostapd/Makefile2
-rw-r--r--net/hostapd/files/patch-src_drivers_driver__bsd.c39
4 files changed, 2 insertions, 79 deletions
diff --git a/net/hostapd-devel/Makefile b/net/hostapd-devel/Makefile
index f477d805c3be..c5d7efdc0c3a 100644
--- a/net/hostapd-devel/Makefile
+++ b/net/hostapd-devel/Makefile
@@ -2,6 +2,7 @@
PORTNAME= hostapd
PORTVERSION= ${COMMIT_DATE}
+PORTREVISION= 1
CATEGORIES= net
PKGNAMESUFFIX= -devel
diff --git a/net/hostapd-devel/files/patch-src_drivers_driver__bsd.c b/net/hostapd-devel/files/patch-src_drivers_driver__bsd.c
deleted file mode 100644
index 9a37a1de0174..000000000000
--- a/net/hostapd-devel/files/patch-src_drivers_driver__bsd.c
+++ /dev/null
@@ -1,39 +0,0 @@
---- src/drivers/driver_bsd.c.orig 2021-06-02 14:11:18.000000000 -0700
-+++ src/drivers/driver_bsd.c 2021-06-13 23:11:15.089256000 -0700
-@@ -853,14 +853,18 @@
- drv = bsd_get_drvindex(global, ifm->ifm_index);
- if (drv == NULL)
- return;
-- if ((ifm->ifm_flags & IFF_UP) == 0 &&
-- (drv->flags & IFF_UP) != 0) {
-+ if (((ifm->ifm_flags & IFF_UP) == 0 ||
-+ (ifm->ifm_flags & IFF_RUNNING) == 0) &&
-+ (drv->flags & IFF_UP) != 0 &&
-+ (drv->flags & IFF_RUNNING) != 0) {
- wpa_printf(MSG_DEBUG, "RTM_IFINFO: Interface '%s' DOWN",
- drv->ifname);
- wpa_supplicant_event(drv->ctx, EVENT_INTERFACE_DISABLED,
- NULL);
- } else if ((ifm->ifm_flags & IFF_UP) != 0 &&
-- (drv->flags & IFF_UP) == 0) {
-+ (ifm->ifm_flags & IFF_RUNNING) != 0 &&
-+ ((drv->flags & IFF_UP) == 0 ||
-+ (drv->flags & IFF_RUNNING) == 0)) {
- wpa_printf(MSG_DEBUG, "RTM_IFINFO: Interface '%s' UP",
- drv->ifname);
- wpa_supplicant_event(drv->ctx, EVENT_INTERFACE_ENABLED,
-@@ -1220,7 +1224,14 @@
- mode = 0 /* STA */;
- break;
- case IEEE80211_MODE_IBSS:
-+ /*
-+ * Ref bin/203086 - FreeBSD's net80211 currently uses
-+ * IFM_IEEE80211_ADHOC.
-+ */
-+#if 0
- mode = IFM_IEEE80211_IBSS;
-+#endif
-+ mode = IFM_IEEE80211_ADHOC;
- break;
- case IEEE80211_MODE_AP:
- mode = IFM_IEEE80211_HOSTAP;
diff --git a/net/hostapd/Makefile b/net/hostapd/Makefile
index 26b97a5fd502..dbdbe8cda9be 100644
--- a/net/hostapd/Makefile
+++ b/net/hostapd/Makefile
@@ -2,7 +2,7 @@
PORTNAME= hostapd
PORTVERSION= 2.10
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= https://w1.fi/releases/
diff --git a/net/hostapd/files/patch-src_drivers_driver__bsd.c b/net/hostapd/files/patch-src_drivers_driver__bsd.c
deleted file mode 100644
index 9a37a1de0174..000000000000
--- a/net/hostapd/files/patch-src_drivers_driver__bsd.c
+++ /dev/null
@@ -1,39 +0,0 @@
---- src/drivers/driver_bsd.c.orig 2021-06-02 14:11:18.000000000 -0700
-+++ src/drivers/driver_bsd.c 2021-06-13 23:11:15.089256000 -0700
-@@ -853,14 +853,18 @@
- drv = bsd_get_drvindex(global, ifm->ifm_index);
- if (drv == NULL)
- return;
-- if ((ifm->ifm_flags & IFF_UP) == 0 &&
-- (drv->flags & IFF_UP) != 0) {
-+ if (((ifm->ifm_flags & IFF_UP) == 0 ||
-+ (ifm->ifm_flags & IFF_RUNNING) == 0) &&
-+ (drv->flags & IFF_UP) != 0 &&
-+ (drv->flags & IFF_RUNNING) != 0) {
- wpa_printf(MSG_DEBUG, "RTM_IFINFO: Interface '%s' DOWN",
- drv->ifname);
- wpa_supplicant_event(drv->ctx, EVENT_INTERFACE_DISABLED,
- NULL);
- } else if ((ifm->ifm_flags & IFF_UP) != 0 &&
-- (drv->flags & IFF_UP) == 0) {
-+ (ifm->ifm_flags & IFF_RUNNING) != 0 &&
-+ ((drv->flags & IFF_UP) == 0 ||
-+ (drv->flags & IFF_RUNNING) == 0)) {
- wpa_printf(MSG_DEBUG, "RTM_IFINFO: Interface '%s' UP",
- drv->ifname);
- wpa_supplicant_event(drv->ctx, EVENT_INTERFACE_ENABLED,
-@@ -1220,7 +1224,14 @@
- mode = 0 /* STA */;
- break;
- case IEEE80211_MODE_IBSS:
-+ /*
-+ * Ref bin/203086 - FreeBSD's net80211 currently uses
-+ * IFM_IEEE80211_ADHOC.
-+ */
-+#if 0
- mode = IFM_IEEE80211_IBSS;
-+#endif
-+ mode = IFM_IEEE80211_ADHOC;
- break;
- case IEEE80211_MODE_AP:
- mode = IFM_IEEE80211_HOSTAP;