aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-04-03 21:59:18 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-04-03 21:59:18 +0000
commit3f2ebc150851cbbc6f23703bc2c05886fc799ac0 (patch)
tree9fda0573fddad987f331256b2a1292733c32b4ac /net
parentecb2ab72346b45aa4a270ae5a1c8f845b921d87c (diff)
downloadports-3f2ebc150851cbbc6f23703bc2c05886fc799ac0.tar.gz
ports-3f2ebc150851cbbc6f23703bc2c05886fc799ac0.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/py-simplesoap/Makefile23
-rw-r--r--net/py-simplesoap/distinfo2
-rw-r--r--net/py-simplesoap/pkg-descr21
4 files changed, 47 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 04107c7d1282..49325ee5ac89 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -934,6 +934,7 @@
SUBDIR += py-qt4-network
SUBDIR += py-radix
SUBDIR += py-s3cmd
+ SUBDIR += py-simplesoap
SUBDIR += py-smb
SUBDIR += py-smbpasswd
SUBDIR += py-soappy
diff --git a/net/py-simplesoap/Makefile b/net/py-simplesoap/Makefile
new file mode 100644
index 000000000000..22a846ab0132
--- /dev/null
+++ b/net/py-simplesoap/Makefile
@@ -0,0 +1,23 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= simplesoap
+PORTVERSION= 1.10
+CATEGORIES= net www python
+MASTER_SITES= GOOGLE_CODE
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= PySimpleSOAP-${PORTVERSION}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Python Simple SOAP Library
+
+LICENSE= LGPL3
+
+PYDISTUTILS_AUTOPLIST= yes
+USE_PYDISTUTILS=yes
+USE_PYTHON= yes
+USES= zip
+
+PROJECTHOST= py${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/net/py-simplesoap/distinfo b/net/py-simplesoap/distinfo
new file mode 100644
index 000000000000..461428eac607
--- /dev/null
+++ b/net/py-simplesoap/distinfo
@@ -0,0 +1,2 @@
+SHA256 (PySimpleSOAP-1.10.zip) = 421000ec686c92e396beb6bd5c3765e9602aa8b336f86503d930a01a47bc6d94
+SIZE (PySimpleSOAP-1.10.zip) = 29106
diff --git a/net/py-simplesoap/pkg-descr b/net/py-simplesoap/pkg-descr
new file mode 100644
index 000000000000..d098f88eeb9b
--- /dev/null
+++ b/net/py-simplesoap/pkg-descr
@@ -0,0 +1,21 @@
+PySimpleSOAP (Python Simple SOAP) library for client and server webservices
+interfaces, aimed to be as small and easy as possible, supporting most common
+functionality. Initially it was inspired by PHP Soap Extension (mimicking it
+functionality, simplicity and ease of use), with many advanced features added.
+
+Goals:
+- Simple: less than 200LOC client/server concrete implementation for easy
+ maintainability and enhancments.
+- Flexible: adapted to several SOAP dialects (Java Axis, .Net, JBoss), with the
+ posibility of fine-tuning XML request and responses
+- Pythonic: no artifacts, no class generation, no special types, RPC calls
+ parameters and return values are simple python structures (dicts, list, etc.)
+- Dynamic: no definition (WSDL) required, dynamic generation and parsing
+ supported (cached in a pickle file for performance, supporting fixing broken
+ WSDL)
+- Easy: simple xml manipulation, including basic serialization and raw
+ object-like access to SOAP messages
+- Extensible: supports several HTTP wrappers (httplib2, pycurl, urllib2) for
+ special transport needs over SSL and proxy (ISA)
+
+WWW: https://code.google.com/p/pysimplesoap/