aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2020-09-22 20:36:45 +0000
committerStefan Eßer <se@FreeBSD.org>2020-09-22 20:36:45 +0000
commitfbc199c7c7e345de33f50865b13d7fec926e920a (patch)
tree908aa1b504d0b742cb5ec8a2d9d648bd401662a1 /net
parent55d1f50e35d950478ea06cf7eac60760a9963acb (diff)
downloadports-fbc199c7c7e345de33f50865b13d7fec926e920a.tar.gz
ports-fbc199c7c7e345de33f50865b13d7fec926e920a.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/sniproxy/Makefile5
-rw-r--r--net/sniproxy/files/patch-src_http.h10
-rw-r--r--net/sniproxy/files/patch-src_tls.h10
-rw-r--r--net/sniproxy/pkg-descr2
4 files changed, 23 insertions, 4 deletions
diff --git a/net/sniproxy/Makefile b/net/sniproxy/Makefile
index 3e742ab26232..5c18b79b2058 100644
--- a/net/sniproxy/Makefile
+++ b/net/sniproxy/Makefile
@@ -2,7 +2,7 @@
PORTNAME= sniproxy
DISTVERSION= 0.6.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MAINTAINER= krion@FreeBSD.org
@@ -12,7 +12,7 @@ LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libev.so:devel/libev \
- libpcre.so:devel/pcre \
+ libpcre.so:devel/pcre \
libudns.so:dns/udns
USES= autoreconf:build gettext pkgconfig
@@ -24,7 +24,6 @@ USE_GITHUB= yes
GH_ACCOUNT= dlundquist
GNU_CONFIGURE= yes
-CFLAGS+= -fcommon
USE_LDCONFIG= yes
PLIST_FILES= man/man5/sniproxy.conf.5.gz \
diff --git a/net/sniproxy/files/patch-src_http.h b/net/sniproxy/files/patch-src_http.h
new file mode 100644
index 000000000000..dcaf75cbc06b
--- /dev/null
+++ b/net/sniproxy/files/patch-src_http.h
@@ -0,0 +1,10 @@
+--- src/http.h.orig 2018-12-06 04:14:58 UTC
++++ src/http.h
+@@ -29,6 +29,6 @@
+ #include <stdio.h>
+ #include "protocol.h"
+
+-const struct Protocol *const http_protocol;
++extern const struct Protocol *const http_protocol;
+
+ #endif
diff --git a/net/sniproxy/files/patch-src_tls.h b/net/sniproxy/files/patch-src_tls.h
new file mode 100644
index 000000000000..af3540daa759
--- /dev/null
+++ b/net/sniproxy/files/patch-src_tls.h
@@ -0,0 +1,10 @@
+--- src/tls.h.orig 2018-12-06 04:14:58 UTC
++++ src/tls.h
+@@ -28,6 +28,6 @@
+
+ #include "protocol.h"
+
+-const struct Protocol *const tls_protocol;
++extern const struct Protocol *const tls_protocol;
+
+ #endif
diff --git a/net/sniproxy/pkg-descr b/net/sniproxy/pkg-descr
index 9901c6db5e26..6e63708e325d 100644
--- a/net/sniproxy/pkg-descr
+++ b/net/sniproxy/pkg-descr
@@ -17,5 +17,5 @@ Supports multiple listening sockets per instance.
Supports HAProxy proxy protocol to propagate original source address
to backend servers.
-
+
WWW: https://github.com/dlundquist/sniproxy