aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2024-04-04 05:43:15 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2024-04-04 05:43:24 +0000
commit0c470ad9c557d5e2b544816eabbde428835e49a8 (patch)
treef4ddf605889a07c870c65ba3426695059f281b04 /net
parent3d89d48569bd63f0948c3c234131699404d9a22a (diff)
downloadports-0c470ad9c557d5e2b544816eabbde428835e49a8.tar.gz
ports-0c470ad9c557d5e2b544816eabbde428835e49a8.zip
Diffstat (limited to 'net')
-rw-r--r--net/trippy/Makefile23
1 files changed, 19 insertions, 4 deletions
diff --git a/net/trippy/Makefile b/net/trippy/Makefile
index fd46fffef950..efaf5b2afa9d 100644
--- a/net/trippy/Makefile
+++ b/net/trippy/Makefile
@@ -1,5 +1,6 @@
PORTNAME= trippy
DISTVERSION= 0.10.0
+PORTREVISION= 1
CATEGORIES= net
MAINTAINER= ehaupt@FreeBSD.org
@@ -13,16 +14,30 @@ USES= cargo
USE_GITHUB= yes
GH_ACCOUNT= fujiapple852
-OPTIONS_DEFINE= SUID
-OPTIONS_DEFAULT= SUID
-SUID_DESC= Use suid to allow execution as non root
+PORTSCOUT= skipv:1.0.0
+
+OPTIONS_DEFINE= MANPAGES SUID
+OPTIONS_DEFAULT= MANPAGES SUID
+OPTIONS_SUB= yes
+
+MANPAGES_DESC= Build and install auto-generated manpages
+SUID_DESC= Use suid to allow execution as non root
+MANPAGES_BUILD_DEPENDS= help2man:misc/help2man
+MANPAGES_PLIST_FILES= share/man/man1/trip.1.gz
SUID_PLIST_FILES= "@(,,4110) bin/trip"
SUID_PLIST_FILES_OFF= "@(,,0100) bin/trip"
-PORTSCOUT= skipv:1.0.0
+post-build-MANPAGES-on:
+ help2man -s 1 -Nn "${COMMENT}" \
+ ${CARGO_TARGET_DIR}/${CARGO_BUILD_TARGET}/*/trip \
+ -o ${WRKSRC}/trip.1
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/trip
+post-install-MANPAGES-on:
+ ${INSTALL_MAN} ${WRKSRC}/trip.1 \
+ ${STAGEDIR}${PREFIX}/share/man/man1
+
.include <bsd.port.mk>