aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-07-22 16:27:08 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-07-22 16:27:08 +0000
commitc10f314307a4e84ca4811cb03db549590b4c364a (patch)
treeaefb02047d08a1e3c25a562330070cfdd71f0579 /net
parentbeaeca88a88b0f7e641416a47008edd52290575c (diff)
downloadports-c10f314307a4e84ca4811cb03db549590b4c364a.tar.gz
ports-c10f314307a4e84ca4811cb03db549590b4c364a.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/lam/Makefile5
-rw-r--r--net/p5-Amazon-SQS-Simple/Makefile8
-rw-r--r--net/p5-File-Rsync/Makefile6
-rw-r--r--net/p5-Net-Address-Ethernet/Makefile8
-rw-r--r--net/p5-Net-Amazon-S3/Makefile5
-rw-r--r--net/p5-Net-CSTA/Makefile8
-rw-r--r--net/p5-Net-DAV-Server/Makefile12
-rw-r--r--net/p5-Net-FTP-File/Makefile9
-rw-r--r--net/p5-Net-Frame-Dump/Makefile8
-rw-r--r--net/p5-Net-Radius/Makefile9
-rw-r--r--net/p5-Net-SNPP/Makefile9
-rw-r--r--net/p5-Net-Whois-ARIN/Makefile11
-rw-r--r--net/p5-Net/Makefile9
-rw-r--r--net/p5-POE-Component-Client-Traceroute/Makefile8
-rw-r--r--net/p5-POE-Component-Jabber/Makefile9
-rw-r--r--net/p5-PlRPC/Makefile8
-rw-r--r--net/p5-URI/Makefile8
-rw-r--r--net/p5-What/Makefile8
-rw-r--r--net/p5-XML-Compile-SOAP/Makefile8
-rw-r--r--net/p5-perl-ldap/Makefile8
-rw-r--r--net/rude/Makefile8
21 files changed, 19 insertions, 153 deletions
diff --git a/net/lam/Makefile b/net/lam/Makefile
index b9756cb09b5e..9421eb6e8629 100644
--- a/net/lam/Makefile
+++ b/net/lam/Makefile
@@ -372,11 +372,6 @@ MAN7= LAM.7 \
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 500800
-BUILD_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
-RUN_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
-.endif
-
.if ${ARCH} == "i386"
PLIST_SUB+= I386=""
.else
diff --git a/net/p5-Amazon-SQS-Simple/Makefile b/net/p5-Amazon-SQS-Simple/Makefile
index 414a338a49a4..8718fd7b3ea2 100644
--- a/net/p5-Amazon-SQS-Simple/Makefile
+++ b/net/p5-Amazon-SQS-Simple/Makefile
@@ -31,13 +31,7 @@ MAN3= Amazon::SQS::Simple::Message.3 \
SUB_FILES= pkg-message
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500703
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
-.endif
-
post-install:
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-File-Rsync/Makefile b/net/p5-File-Rsync/Makefile
index de116a32c950..2a9303da12d8 100644
--- a/net/p5-File-Rsync/Makefile
+++ b/net/p5-File-Rsync/Makefile
@@ -25,8 +25,4 @@ MAN3= File::Rsync.3
post-patch:
@${REINPLACE_CMD} -e "s,<STDIN>,'${LOCALBASE}/bin/rsync'," ${WRKSRC}/makepm.PL
-.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 500800
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Scalar/Util.pm:${PORTSDIR}/lang/p5-Scalar-List-Utils
-.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Address-Ethernet/Makefile b/net/p5-Net-Address-Ethernet/Makefile
index 55fd2f4c8855..10888848accc 100644
--- a/net/p5-Net-Address-Ethernet/Makefile
+++ b/net/p5-Net-Address-Ethernet/Makefile
@@ -21,10 +21,4 @@ PERL_CONFIGURE= yes
MAN3= Net::Address::Ethernet.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500702
-RUN_DEPENDS+= ${SITE_PERL}/Net/Domain.pm:${PORTSDIR}/net/p5-Net
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Amazon-S3/Makefile b/net/p5-Net-Amazon-S3/Makefile
index 304cfff5e717..23c2df79823b 100644
--- a/net/p5-Net-Amazon-S3/Makefile
+++ b/net/p5-Net-Amazon-S3/Makefile
@@ -52,11 +52,6 @@ MAN3= Net::Amazon::S3.3 Net::Amazon::S3::Bucket.3 \
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 500703
-RUN_DEPENDS+= p5-Digest-MD5>=0:${PORTSDIR}/security/p5-Digest-MD5 \
- p5-MIME-Base64>=0:${PORTSDIR}/converters/p5-MIME-Base64
-.endif
-
.if ${PERL_LEVEL} < 500904
RUN_DEPENDS+= p5-IO>=1.14:${PORTSDIR}/devel/p5-IO
.endif
diff --git a/net/p5-Net-CSTA/Makefile b/net/p5-Net-CSTA/Makefile
index 6723d6b4499b..381656d0654b 100644
--- a/net/p5-Net-CSTA/Makefile
+++ b/net/p5-Net-CSTA/Makefile
@@ -21,10 +21,4 @@ PERL_CONFIGURE= yes
MAN3= Net::CSTA.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500703
-RUN_DEPENDS+= ${SITE_PERL}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-Net-DAV-Server/Makefile b/net/p5-Net-DAV-Server/Makefile
index 07c94da6e541..d9b87cf9855c 100644
--- a/net/p5-Net-DAV-Server/Makefile
+++ b/net/p5-Net-DAV-Server/Makefile
@@ -29,14 +29,4 @@ PERL_CONFIGURE= yes
MAN3= Net::DAV::Server.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} == 500701
-RUN_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
-.endif
-
-.if ${PERL_LEVEL} < 500701
-RUN_DEPENDS+= ${SITE_PERL}/Encode.pm:${PORTSDIR}/converters/p5-Encode
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-Net-FTP-File/Makefile b/net/p5-Net-FTP-File/Makefile
index 2eb4f4001a4d..a821af696cec 100644
--- a/net/p5-Net-FTP-File/Makefile
+++ b/net/p5-Net-FTP-File/Makefile
@@ -19,11 +19,4 @@ MAN3= Net::FTP::File.3
PERL_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500703
-BUILD_DEPENDS+= p5-Net>=0:${PORTSDIR}/net/p5-Net
-RUN_DEPENDS+= p5-Net>=0:${PORTSDIR}/net/p5-Net
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Frame-Dump/Makefile b/net/p5-Net-Frame-Dump/Makefile
index 9d5b06cf818f..555024c99047 100644
--- a/net/p5-Net-Frame-Dump/Makefile
+++ b/net/p5-Net-Frame-Dump/Makefile
@@ -27,10 +27,4 @@ MAN3= Net::Frame::Dump.3 \
Net::Frame::Dump::Online.3 \
Net::Frame::Dump::Writer.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500703
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Radius/Makefile b/net/p5-Net-Radius/Makefile
index 4e844955f911..1a1c06d66dc2 100644
--- a/net/p5-Net-Radius/Makefile
+++ b/net/p5-Net-Radius/Makefile
@@ -20,11 +20,4 @@ MAN3= Net::Radius::Dictionary.3 Net::Radius::Packet.3
post-extract:
${FIND} ${WRKDIR} -type f | ${XARGS} ${PERL5} -pi -e "s:\r::g"
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
-BUILD_DEPENDS= ${RUN_DEPENDS}
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-Net-SNPP/Makefile b/net/p5-Net-SNPP/Makefile
index 291ba04f80cb..bda56850d09e 100644
--- a/net/p5-Net-SNPP/Makefile
+++ b/net/p5-Net-SNPP/Makefile
@@ -24,11 +24,4 @@ post-patch:
${WRKSRC}/lib/Net/SNPP/Server.pm
@${RM} ${WRKSRC}/lib/Net/SNPP/Server.pm.orig
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-BUILD_DEPENDS= ${SITE_PERL}/Net/Cmd.pm:${PORTSDIR}/net/p5-Net
-RUN_DEPENDS= ${BUILD_DEPENDS}
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-Net-Whois-ARIN/Makefile b/net/p5-Net-Whois-ARIN/Makefile
index 05d36f113f6e..0db6b7d3b6fe 100644
--- a/net/p5-Net-Whois-ARIN/Makefile
+++ b/net/p5-Net-Whois-ARIN/Makefile
@@ -23,13 +23,4 @@ MAN3= Net::Whois::ARIN.3 \
PERL_CONFIGURE= yes
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-BUILD_DEPENDS+= p5-Scalar-List-Utils>0:${PORTSDIR}/lang/p5-Scalar-List-Utils \
- p5-UNIVERSAL-isa>=0:${PORTSDIR}/devel/p5-UNIVERSAL-isa \
- p5-UNIVERSAL-can>=0:${PORTSDIR}/devel/p5-UNIVERSAL-can
-RUN_DEPENDS= ${BUILD_DEPENDS}
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-Net/Makefile b/net/p5-Net/Makefile
index 91f538a2a307..625881df8d4d 100644
--- a/net/p5-Net/Makefile
+++ b/net/p5-Net/Makefile
@@ -32,11 +32,4 @@ MAN3= Net::Cmd.3 \
Net::Time.3 \
Net::libnetFAQ.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500703
-RUN_DEPENDS+= p5-Digest-MD5>=0:${PORTSDIR}/security/p5-Digest-MD5 \
- p5-MIME-Base64>=0:${PORTSDIR}/converters/p5-MIME-Base64
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-POE-Component-Client-Traceroute/Makefile b/net/p5-POE-Component-Client-Traceroute/Makefile
index edde64a79d86..4dea57dcfab4 100644
--- a/net/p5-POE-Component-Client-Traceroute/Makefile
+++ b/net/p5-POE-Component-Client-Traceroute/Makefile
@@ -28,10 +28,4 @@ post-install:
${INSTALL_SCRIPT} ${WRKSRC}/examples/* ${EXAMPLESDIR}
.endif
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500702
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-POE-Component-Jabber/Makefile b/net/p5-POE-Component-Jabber/Makefile
index 04756b888ade..d74e6a8ba279 100644
--- a/net/p5-POE-Component-Jabber/Makefile
+++ b/net/p5-POE-Component-Jabber/Makefile
@@ -46,11 +46,4 @@ post-install:
@${INSTALL_SCRIPT} ${WRKSRC}/examples/* ${EXAMPLESDIR}
.endif
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500703
-RUN_DEPENDS+= p5-Digest-MD5>=0:${PORTSDIR}/security/p5-Digest-MD5 \
- p5-MIME-Base64>=0:${PORTSDIR}/converters/p5-MIME-Base64
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-PlRPC/Makefile b/net/p5-PlRPC/Makefile
index 4fe616dfc97b..e819ecec02f3 100644
--- a/net/p5-PlRPC/Makefile
+++ b/net/p5-PlRPC/Makefile
@@ -28,10 +28,4 @@ MAN3= Bundle::PlRPC.3 \
post-patch:
@${FIND} ${WRKSRC} -name ".svn" | ${XARGS} ${RM} -rf
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-URI/Makefile b/net/p5-URI/Makefile
index 91ceafbd206a..e15ca172d187 100644
--- a/net/p5-URI/Makefile
+++ b/net/p5-URI/Makefile
@@ -27,10 +27,4 @@ MAN3= URI.3 \
URI::file.3 \
URI::ldap.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500703
-RUN_DEPENDS+= p5-MIME-Base64>=2:${PORTSDIR}/converters/p5-MIME-Base64
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-What/Makefile b/net/p5-What/Makefile
index 252dcdf8ed46..45d20decf3c5 100644
--- a/net/p5-What/Makefile
+++ b/net/p5-What/Makefile
@@ -24,10 +24,4 @@ PERL_CONFIGURE= yes
MAN3= What.3 What::MTA.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500702
-BUILD_DEPENDS+= ${SITE_PERL}/Net/Cmd.pm:${PORTSDIR}/net/p5-Net
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-XML-Compile-SOAP/Makefile b/net/p5-XML-Compile-SOAP/Makefile
index 00e8f6aca5d0..7eb8686283b5 100644
--- a/net/p5-XML-Compile-SOAP/Makefile
+++ b/net/p5-XML-Compile-SOAP/Makefile
@@ -34,10 +34,4 @@ MAN3= XML::Compile::SOAP.3 \
XML::Compile::Transport::SOAPHTTP.3 XML::Compile::WSDL11.3 \
XML::Compile::XOP.3 XML::Compile::XOP::Include.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500702
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/p5-perl-ldap/Makefile b/net/p5-perl-ldap/Makefile
index d4f2b7f40f54..840939c98ff4 100644
--- a/net/p5-perl-ldap/Makefile
+++ b/net/p5-perl-ldap/Makefile
@@ -66,10 +66,4 @@ MAN3= Bundle::Net::LDAP.3 \
Net::LDAPI.3 \
Net::LDAPS.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/rude/Makefile b/net/rude/Makefile
index babc409484c6..ca06e97f350a 100644
--- a/net/rude/Makefile
+++ b/net/rude/Makefile
@@ -39,10 +39,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 500800
-RUN_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>