aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorJean-Sébastien Pédron <dumbbell@FreeBSD.org>2020-11-20 09:19:29 +0000
committerJean-Sébastien Pédron <dumbbell@FreeBSD.org>2020-11-20 09:19:29 +0000
commitc595b90c8246c8d8c881252dca92bf3a360aa2e6 (patch)
treee9fed977851c41f6dfb2e8eede16c265f86ba417 /net
parent1295cfab558bd8e2432f0122fa2a69bcafcf993d (diff)
downloadports-c595b90c8246c8d8c881252dca92bf3a360aa2e6.tar.gz
ports-c595b90c8246c8d8c881252dca92bf3a360aa2e6.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/concourse-fly/Makefile23
-rw-r--r--net/concourse-fly/distinfo6
-rw-r--r--net/concourse-fly/files/patch-vendor_golang.org_x_sys_unix_ztypes__freebsd__arm64.go24
3 files changed, 8 insertions, 45 deletions
diff --git a/net/concourse-fly/Makefile b/net/concourse-fly/Makefile
index 3386ff83ad4a..a7bfbd066e8a 100644
--- a/net/concourse-fly/Makefile
+++ b/net/concourse-fly/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= concourse
-PORTVERSION= 5.7.2
+PORTVERSION= 6.7.1
CATEGORIES= net sysutils
MASTER_SITES= LOCAL/dumbbell/concourse/
PKGNAMESUFFIX= -fly
@@ -11,11 +11,11 @@ COMMENT= CLI for Concourse
LICENSE= APACHE20
-GO_PKGNAME= github.com/concourse/fly
-GO_BUILDFLAGS+= -mod=vendor \
- -ldflags="-X github.com/concourse/concourse.Version=${PORTVERSION}"
+USES= go:modules tar:xz
-USES= go tar:xz
+GO_TARGET= ./cmd/concourse:fly
+GO_BUILDFLAGS= -ldflags="-s -w -X github.com/concourse/concourse.Version=${PORTVERSION}"
+CGO_CFLAGS= -I.
CONFLICTS_INSTALL= fly
@@ -42,23 +42,10 @@ PLIST_FILES= bin/fly
#
# make create-src-archive
#
-# Because it doesn't match the project layout USES=go expects, we
-# override the post-extract and do-build targets to adapt the commands.
-#
-# In particular, we must pass `-mod=vendor` to go-install to be able to
-# use the third-party dependencies fetched with `go mod vendor`.
-
# `fly` version is set by default to "0.0.0-dev" in version/Version.go.
# Instead of patching the file, we use a linker flag to set the variable
# to the port's version.
-post-extract:
- @:
-
-do-build:
- (cd ${WRKSRC}/fly; \
- ${SETENV} ${MAKE_ENV} ${GO_ENV} ${GO_CMD} 'install' ${GO_BUILDFLAGS})
-
.PHONY: create-src-archive
ARCHIVE_DIR= ${DISTDIR}/concourse-${PORTVERSION}
create-src-archive:
diff --git a/net/concourse-fly/distinfo b/net/concourse-fly/distinfo
index 378adf67985c..de5191c49c48 100644
--- a/net/concourse-fly/distinfo
+++ b/net/concourse-fly/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1575563043
-SHA256 (concourse-5.7.2.tar.xz) = 631bce5871a1656fad79d33c7f876265de2ced0a78b487f07d8b0039978bd7ab
-SIZE (concourse-5.7.2.tar.xz) = 7296208
+TIMESTAMP = 1605819756
+SHA256 (concourse-6.7.1.tar.xz) = 3fd2de566112b6822928197cffeebe9af4090159cebb22702313c2f9698d911d
+SIZE (concourse-6.7.1.tar.xz) = 8414876
diff --git a/net/concourse-fly/files/patch-vendor_golang.org_x_sys_unix_ztypes__freebsd__arm64.go b/net/concourse-fly/files/patch-vendor_golang.org_x_sys_unix_ztypes__freebsd__arm64.go
deleted file mode 100644
index 0e0603b77cee..000000000000
--- a/net/concourse-fly/files/patch-vendor_golang.org_x_sys_unix_ztypes__freebsd__arm64.go
+++ /dev/null
@@ -1,24 +0,0 @@
-From 33540a1f603772f9d4b761f416f5c10dade23e96 Mon Sep 17 00:00:00 2001
-From: Tobias Klauser <tklauser@distanz.ch>
-Date: Fri, 25 Oct 2019 21:13:51 +0200
-Subject: [PATCH] unix: don't use non-existing uint128 type on freebsd/arm64
-
-CL 179099 introduced type FpReg on freebsd, on freebsd/arm64 using a
-type uint128. This type doesn't exist in Go.
-
-Change-Id: Ie7f065f38f2cc2c163abdfa7dddad886b8edbe3b
-Reviewed-on: https://go-review.googlesource.com/c/sys/+/203419
-Run-TryBot: Tobias Klauser <tobias.klauser@gmail.com>
-TryBot-Result: Gobot Gobot <gobot@golang.org>
-Reviewed-by: Brad Fitzpatrick <bradfitz@golang.org>
---- vendor/golang.org/x/sys/unix/ztypes_freebsd_arm64.go.orig 2019-08-18 13:42:05 UTC
-+++ vendor/golang.org/x/sys/unix/ztypes_freebsd_arm64.go
-@@ -397,7 +397,7 @@ type Reg struct {
- }
-
- type FpReg struct {
-- Fp_q [32]uint128
-+ Fp_q [512]uint8
- Fp_sr uint32
- Fp_cr uint32
- }