aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorTorsten Zuehlsdorff <tz@FreeBSD.org>2017-06-28 08:54:10 +0000
committerTorsten Zuehlsdorff <tz@FreeBSD.org>2017-06-28 08:54:10 +0000
commiteb9a18e35c4179b51df927d13b309165ec81b124 (patch)
treecea125eaf7b49fd2a0d9e85d81c8bfd16f7f7396 /net
parent2c4c73634d2a4adff523b99a2cea3a310291d534 (diff)
downloadports-eb9a18e35c4179b51df927d13b309165ec81b124.tar.gz
ports-eb9a18e35c4179b51df927d13b309165ec81b124.zip
New port: net/rubygem-gitaly
Gitaly is a Git RPC service for handling all the git calls made by GitLab. WWW: https://gitlab.com/gitlab-org/gitaly ATTENTION: the port has currently just a subset of functions and is needed in order to provide the security update of www/gitlab to 9.0
Notes
Notes: svn path=/head/; revision=444552
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/rubygem-gitaly/Makefile17
-rw-r--r--net/rubygem-gitaly/distinfo3
-rw-r--r--net/rubygem-gitaly/files/patch-gitaly.gemspec11
-rw-r--r--net/rubygem-gitaly/files/patch-ruby_lib_gitaly.rb10
-rw-r--r--net/rubygem-gitaly/pkg-descr3
6 files changed, 45 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index bc249b6c6fc4..8b9b30ecad29 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1183,6 +1183,7 @@
SUBDIR += rubygem-fog-vsphere
SUBDIR += rubygem-fog-xenserver
SUBDIR += rubygem-geoip
+ SUBDIR += rubygem-gitaly
SUBDIR += rubygem-gitlab_omniauth-ldap
SUBDIR += rubygem-gitlab_omniauth-ldap1
SUBDIR += rubygem-http_parser.rb
diff --git a/net/rubygem-gitaly/Makefile b/net/rubygem-gitaly/Makefile
new file mode 100644
index 000000000000..f9658b7c7b04
--- /dev/null
+++ b/net/rubygem-gitaly/Makefile
@@ -0,0 +1,17 @@
+# $FreeBSD$
+
+PORTNAME= gitaly
+PORTVERSION= 0.2.1
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+
+MAINTAINER= tz@FreeBSD.org
+COMMENT= Auto-generated gRPC client for gitaly
+
+RUN_DEPENDS= rubygem-google-protobuf>=3.1:devel/rubygem-google-protobuf
+
+NO_ARCH= yes
+USE_RUBY= yes
+USES= gem
+
+.include <bsd.port.mk>
diff --git a/net/rubygem-gitaly/distinfo b/net/rubygem-gitaly/distinfo
new file mode 100644
index 000000000000..c697ac1b6256
--- /dev/null
+++ b/net/rubygem-gitaly/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1497439474
+SHA256 (rubygem/gitaly-0.2.1.gem) = 5ce2a251265161e1e7b15220ead44e339ee3927d6326b80526998353b261d378
+SIZE (rubygem/gitaly-0.2.1.gem) = 6656
diff --git a/net/rubygem-gitaly/files/patch-gitaly.gemspec b/net/rubygem-gitaly/files/patch-gitaly.gemspec
new file mode 100644
index 000000000000..a2144f04dbaa
--- /dev/null
+++ b/net/rubygem-gitaly/files/patch-gitaly.gemspec
@@ -0,0 +1,11 @@
+--- gitaly.gemspec.orig 2017-06-22 08:27:02 UTC
++++ gitaly.gemspec
+@@ -21,8 +21,6 @@ Gem::Specification.new do |s|
+ s.specification_version = 4
+
+ if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
+- s.add_runtime_dependency(%q<google-protobuf>.freeze, ["~> 3.1"])
+- s.add_runtime_dependency(%q<grpc>.freeze, ["~> 1.0"])
+ s.add_development_dependency(%q<bundler>.freeze, ["~> 1.12"])
+ s.add_development_dependency(%q<rake>.freeze, ["~> 10.0"])
+ else
diff --git a/net/rubygem-gitaly/files/patch-ruby_lib_gitaly.rb b/net/rubygem-gitaly/files/patch-ruby_lib_gitaly.rb
new file mode 100644
index 000000000000..9844a3293c0a
--- /dev/null
+++ b/net/rubygem-gitaly/files/patch-ruby_lib_gitaly.rb
@@ -0,0 +1,10 @@
+--- ruby/lib/gitaly.rb.orig 2017-06-22 08:27:11 UTC
++++ ruby/lib/gitaly.rb
+@@ -1,7 +1,6 @@
+ $:.unshift(File.expand_path('../gitaly', __FILE__))
+
+ require "gitaly/version"
+-require "gitaly/gitaly_services_pb"
+
+ module Gitaly
+ # Your code goes here...
diff --git a/net/rubygem-gitaly/pkg-descr b/net/rubygem-gitaly/pkg-descr
new file mode 100644
index 000000000000..294429b70346
--- /dev/null
+++ b/net/rubygem-gitaly/pkg-descr
@@ -0,0 +1,3 @@
+Gitaly is a Git RPC service for handling all the git calls made by GitLab.
+
+WWW: https://gitlab.com/gitlab-org/gitaly