aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2004-11-04 12:22:21 +0000
committerAnton Berezin <tobez@FreeBSD.org>2004-11-04 12:22:21 +0000
commit4ccc6ca0d96a59438ab6d98d687d59238bb9fcdb (patch)
tree906a5cdd6b6cac9e7f93d1ca1064ab7cf470f571 /net
parent3a52300e23f895202d4d112338e40ba8ae1236e0 (diff)
downloadports-4ccc6ca0d96a59438ab6d98d687d59238bb9fcdb.tar.gz
ports-4ccc6ca0d96a59438ab6d98d687d59238bb9fcdb.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/bld/Makefile1
-rw-r--r--net/bld/files/patch-ae11
-rw-r--r--net/bld/files/patch-af12
3 files changed, 24 insertions, 0 deletions
diff --git a/net/bld/Makefile b/net/bld/Makefile
index 600110d1e582..ea75cc2892ae 100644
--- a/net/bld/Makefile
+++ b/net/bld/Makefile
@@ -7,6 +7,7 @@
PORTNAME= bld
PORTVERSION= 0.3.1
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://www.online.redhate.org/bld/
diff --git a/net/bld/files/patch-ae b/net/bld/files/patch-ae
new file mode 100644
index 000000000000..e92c3efadd65
--- /dev/null
+++ b/net/bld/files/patch-ae
@@ -0,0 +1,11 @@
+--- netlist.h.orig Thu Nov 4 12:10:08 2004
++++ netlist.h Thu Nov 4 12:10:12 2004
+@@ -27,6 +27,8 @@
+ #ifndef _NETLIST_H
+ #define _NETLIST_H
+
++#include <sys/types.h>
++#include <sys/socket.h>
+ #include <netinet/in.h> /* in_addr_t */
+
+
diff --git a/net/bld/files/patch-af b/net/bld/files/patch-af
new file mode 100644
index 000000000000..6d367216d086
--- /dev/null
+++ b/net/bld/files/patch-af
@@ -0,0 +1,12 @@
+--- main.c.orig Thu Nov 4 12:40:05 2004
++++ main.c Thu Nov 4 12:40:01 2004
+@@ -41,8 +41,8 @@
+ #include <sys/wait.h>
+ #include <sys/resource.h>
+ #include <unistd.h>
+-#include <arpa/inet.h>
+ #include <netinet/in.h>
++#include <arpa/inet.h>
+ #include <syslog.h>
+ #include "options.h"
+ #include "parse_args.h"