aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2011-06-23 12:46:21 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2011-06-23 12:46:21 +0000
commit53405c875685d2474e42351500bf382a7fdc64ba (patch)
treec99c4f04f29b0eb314b1dabe0ff5e6412b9e102f /net
parent87f064b997c11aa436eed35b680cb00ba8b35bd8 (diff)
downloadports-53405c875685d2474e42351500bf382a7fdc64ba.tar.gz
ports-53405c875685d2474e42351500bf382a7fdc64ba.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/ssspl/Makefile34
-rw-r--r--net/ssspl/distinfo2
-rw-r--r--net/ssspl/pkg-descr6
4 files changed, 43 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index abebf52cfc14..318fa779718f 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -1043,6 +1043,7 @@
SUBDIR += ssltunnel-client
SUBDIR += ssltunnel-server
SUBDIR += ssmping
+ SUBDIR += ssspl
SUBDIR += ssvnc
SUBDIR += stone
SUBDIR += stund
diff --git a/net/ssspl/Makefile b/net/ssspl/Makefile
new file mode 100644
index 000000000000..8f74255b6ea2
--- /dev/null
+++ b/net/ssspl/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: ssspl
+# Date created: 2011-04-02
+# Whom: Hung-Yi Chen <gaod@hychen.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ssspl
+PORTVERSION= 0.1
+CATEGORIES= net perl5
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/sss.pl%20v${PORTVERSION}/
+DISTNAME= sss
+EXTRACT_SUFX= .pl
+
+MAINTAINER= gaod@hychen.org
+COMMENT= A Simple Socks Server for Perl
+
+RUN_DEPENDS= p5-URI>=0:${PORTSDIR}/net/p5-URI \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+
+NO_BUILD= yes
+
+PLIST_FILES= sbin/sss.pl
+STRIP=
+
+do-extract:
+ @${MKDIR} ${WRKSRC}
+ @${CP} ${DISTDIR}/${DISTFILES} ${WRKSRC}
+
+do-install:
+ ${CHMOD} +x ${WRKSRC}/${DISTFILES}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${DISTFILES} ${PREFIX}/sbin
+
+.include <bsd.port.mk>
diff --git a/net/ssspl/distinfo b/net/ssspl/distinfo
new file mode 100644
index 000000000000..cdd5734a7af3
--- /dev/null
+++ b/net/ssspl/distinfo
@@ -0,0 +1,2 @@
+SHA256 (sss.pl) = 71c844853aaaa81709a597cb5f4562ed5e4368737ea4f2f7077a31e71a7798e5
+SIZE (sss.pl) = 13293
diff --git a/net/ssspl/pkg-descr b/net/ssspl/pkg-descr
new file mode 100644
index 000000000000..534c74064734
--- /dev/null
+++ b/net/ssspl/pkg-descr
@@ -0,0 +1,6 @@
+SSSPL - Simple Socks Server for Perl
+
+SSS is a simple socks server written in perl that
+implements the SOCKS v5 protocol.
+
+WWW: http://sourceforge.net/projects/ssspl/