aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-04-30 00:47:21 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-04-30 00:47:21 +0000
commit798e9bed2a389dce8a970e15b68176fd49f442db (patch)
tree9dc5597aab073298ec381964f72cd853b3dd366c /net
parent48b92584b0722f7f6ca412e6cfe16f1381e043cc (diff)
Notes
Diffstat (limited to 'net')
-rw-r--r--net/avahi/Makefile13
-rw-r--r--net/avahi/files/patch-Makefile.in20
-rw-r--r--net/avahi/files/patch-avahi-core_socket.c34
-rw-r--r--net/avahi/files/patch-avahi-sharp_Makefile.in16
-rw-r--r--net/avahi/pkg-plist36
-rw-r--r--net/gnome-nettool/Makefile8
-rw-r--r--net/gnome-nettool/distinfo6
-rw-r--r--net/gnome-nettool/files/patch-src_info.c44
-rw-r--r--net/gnome-nettool/files/patch-src_nettool.c21
-rw-r--r--net/gnome-nettool/pkg-plist6
-rw-r--r--net/gnomenettool/Makefile8
-rw-r--r--net/gnomenettool/distinfo6
-rw-r--r--net/gnomenettool/files/patch-src_info.c44
-rw-r--r--net/gnomenettool/files/patch-src_nettool.c21
-rw-r--r--net/gnomenettool/pkg-plist6
-rw-r--r--net/vino/Makefile8
-rw-r--r--net/vino/distinfo6
-rw-r--r--net/vino/pkg-plist1
18 files changed, 200 insertions, 104 deletions
diff --git a/net/avahi/Makefile b/net/avahi/Makefile
index 5051ee392007..fae5fae41a31 100644
--- a/net/avahi/Makefile
+++ b/net/avahi/Makefile
@@ -3,12 +3,12 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-#
+# $MCom: ports/net/avahi/Makefile,v 1.15 2006/04/28 01:52:15 marcus Exp $
PORTNAME= avahi
PORTVERSION= 0.6.9
-PORTREVISION?= 3
-CATEGORIES= net dns
+PORTREVISION?= 4
+CATEGORIES?= net dns
MASTER_SITES= http://www.avahi.org/download/
MAINTAINER?= gnome@FreeBSD.org
@@ -21,7 +21,7 @@ LIB_DEPENDS?= expat.6:${PORTSDIR}/textproc/expat2 \
USE_GNOME?= gnomehack ltverhack glib20
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:15
INSTALLS_SHLIB= yes
CONFIGURE_ARGS?=--with-distro=freebsd \
--with-dbus-system-address=unix:path=/var/run/dbus/dbus.pipe \
@@ -32,13 +32,16 @@ CONFIGURE_ARGS?=--with-distro=freebsd \
--disable-monodoc \
--disable-doxygen-doc \
--disable-doxygen-dot \
- --localstatedir=/var
+ --localstatedir=/var \
+ --enable-compat-howl \
+ --enable-compat-libdns_sd
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
.if !defined(AVAHI_SLAVE)
+CONFLICTS= howl-[0-9]* mDNSResponder-[0-9]*
MAN1= avahi-browse-domains.1 avahi-browse.1 avahi-publish-address.1 \
avahi-publish-service.1 avahi-publish.1 avahi-resolve-address.1 \
diff --git a/net/avahi/files/patch-Makefile.in b/net/avahi/files/patch-Makefile.in
index 8467b3b3eca8..a117a3b11b5f 100644
--- a/net/avahi/files/patch-Makefile.in
+++ b/net/avahi/files/patch-Makefile.in
@@ -1,5 +1,5 @@
---- Makefile.in.orig Sun Jan 29 13:36:41 2006
-+++ Makefile.in Sun Jan 29 13:37:37 2006
+--- Makefile.in.orig Mon Jan 30 13:05:47 2006
++++ Makefile.in Mon Jan 30 13:07:36 2006
@@ -1037,6 +1037,8 @@
avahi-core.pc: avahi-core.pc.in
sed -e 's,@prefix\@,$(prefix),g' \
@@ -9,3 +9,19 @@
-e 's,@PACKAGE_VERSION\@,$(PACKAGE_VERSION),g' $< > $@
@HAVE_DBUS_TRUE@avahi-client.pc: avahi-client.pc.in
+@@ -1047,11 +1049,15 @@
+ @ENABLE_COMPAT_HOWL_TRUE@@HAVE_DBUS_TRUE@avahi-compat-howl.pc: avahi-compat-howl.pc.in
+ @ENABLE_COMPAT_HOWL_TRUE@@HAVE_DBUS_TRUE@ sed -e 's,@prefix\@,$(prefix),g' \
+ @ENABLE_COMPAT_HOWL_TRUE@@HAVE_DBUS_TRUE@ -e 's,@libdir\@,$(libdir),g' \
++@ENABLE_COMPAT_HOWL_TRUE@@HAVE_DBUS_TRUE@ -e 's,@PTHREAD_CFLAGS\@,$(PTHREAD_CFLAGS),g' \
++@ENABLE_COMPAT_HOWL_TRUE@@HAVE_DBUS_TRUE@ -e 's,@PTHREAD_LIBS\@,$(PTHREAD_LIBS),g' \
+ @ENABLE_COMPAT_HOWL_TRUE@@HAVE_DBUS_TRUE@ -e 's,@HOWL_COMPAT_VERSION\@,$(HOWL_COMPAT_VERSION),g' $< > $@
+
+ @ENABLE_COMPAT_LIBDNS_SD_TRUE@@HAVE_DBUS_TRUE@avahi-compat-libdns_sd.pc: avahi-compat-libdns_sd.pc.in
+ @ENABLE_COMPAT_LIBDNS_SD_TRUE@@HAVE_DBUS_TRUE@ sed -e 's,@prefix\@,$(prefix),g' \
+ @ENABLE_COMPAT_LIBDNS_SD_TRUE@@HAVE_DBUS_TRUE@ -e 's,@libdir\@,$(libdir),g' \
++@ENABLE_COMPAT_LIBDNS_SD_TRUE@@HAVE_DBUS_TRUE@ -e 's,@PTHREAD_CFLAGS\@,$(PTHREAD_CFLAGS),g' \
++@ENABLE_COMPAT_LIBDNS_SD_TRUE@@HAVE_DBUS_TRUE@ -e 's,@PTHREAD_LIBS\@,$(PTHREAD_LIBS),g' \
+ @ENABLE_COMPAT_LIBDNS_SD_TRUE@@HAVE_DBUS_TRUE@ -e 's,@PACKAGE_VERSION\@,$(PACKAGE_VERSION),g' $< > $@
+
+ @HAVE_DBUS_TRUE@@HAVE_MONO_TRUE@avahi-sharp.pc: avahi-sharp.pc.in
diff --git a/net/avahi/files/patch-avahi-core_socket.c b/net/avahi/files/patch-avahi-core_socket.c
index 783d41c02f35..dc19ed3795be 100644
--- a/net/avahi/files/patch-avahi-core_socket.c
+++ b/net/avahi/files/patch-avahi-core_socket.c
@@ -1,38 +1,28 @@
---- avahi-core/socket.c.orig Sun Apr 23 19:20:31 2006
-+++ avahi-core/socket.c Sun Apr 23 20:16:46 2006
+--- avahi-core/socket.c.orig Thu Feb 9 20:45:09 2006
++++ avahi-core/socket.c Mon Apr 24 17:14:18 2006
@@ -468,7 +468,7 @@ int avahi_send_dns_packet_ipv4(int fd, A
size_t cmsg_data[( CMSG_SPACE(sizeof(struct in_pktinfo)) / sizeof(size_t)) + 1];
#elif defined(IP_SENDSRCADDR)
struct cmsghdr *cmsg;
- size_t cmsg_data[( CMSG_SPACE(sizeof(struct in_addr)) / sizeof(size_t)) + 1];
-+ char cmsg_data[CMSG_SPACE(sizeof(struct in_addr))];
++ uint8_t cmsg_data[CMSG_SPACE(sizeof(struct in_addr))];
#endif
assert(fd >= 0);
-@@ -491,8 +491,8 @@ int avahi_send_dns_packet_ipv4(int fd, A
- msg.msg_iov = &io;
- msg.msg_iovlen = 1;
- msg.msg_flags = 0;
-- msg.msg_control = NULL;
-- msg.msg_controllen = 0;
-+ msg.msg_control = cmsg_data;
-+ msg.msg_controllen = sizeof(cmsg_data);
-
- #ifdef IP_PKTINFO
- if (interface > 0 || src_address) {
-@@ -518,18 +518,15 @@ int avahi_send_dns_packet_ipv4(int fd, A
+@@ -518,18 +518,17 @@ int avahi_send_dns_packet_ipv4(int fd, A
#elif defined(IP_SENDSRCADDR)
if (src_address) {
struct in_addr *addr;
+
++ msg.msg_control = cmsg_data;
++ msg.msg_controllen = sizeof(cmsg_data);
+ cmsg = CMSG_FIRSTHDR(&msg);
- memset(cmsg_data, 0, sizeof(cmsg_data));
- cmsg = (struct cmsghdr*) cmsg_data;
-- cmsg->cmsg_len = CMSG_LEN(sizeof(struct in_addr));
+ cmsg->cmsg_len = CMSG_LEN(sizeof(struct in_addr));
cmsg->cmsg_level = IPPROTO_IP;
cmsg->cmsg_type = IP_SENDSRCADDR;
-+ cmsg->cmsg_len = CMSG_LEN(sizeof(struct in_addr));
addr = (struct in_addr *)CMSG_DATA(cmsg);
addr->s_addr = src_address->address;
@@ -42,30 +32,30 @@
}
#elif defined(IP_MULTICAST_IF)
{
-@@ -551,7 +548,7 @@ int avahi_send_dns_packet_ipv6(int fd, A
+@@ -551,7 +550,7 @@ int avahi_send_dns_packet_ipv6(int fd, A
struct msghdr msg;
struct iovec io;
struct cmsghdr *cmsg;
- size_t cmsg_data[(CMSG_SPACE(sizeof(struct in6_pktinfo))/sizeof(size_t)) + 1];
-+ char cmsg_data[CMSG_SPACE(sizeof(struct in6_pktinfo))];
++ uint8_t cmsg_data[CMSG_SPACE(sizeof(struct in6_pktinfo))];
assert(fd >= 0);
assert(p);
-@@ -576,9 +573,11 @@ int avahi_send_dns_packet_ipv6(int fd, A
+@@ -576,9 +575,11 @@ int avahi_send_dns_packet_ipv6(int fd, A
if (interface > 0 || src_address) {
struct in6_pktinfo *pkti;
+
+ msg.msg_control = cmsg_data;
+ msg.msg_controllen = sizeof(cmsg_data);
-+ cmsg = CMSG_FIRSTHDR(&msg);
++ cmsg = CMSG_FIRSTHDR(&msg);
- memset(cmsg_data, 0, sizeof(cmsg_data));
- cmsg = (struct cmsghdr*) cmsg_data;
cmsg->cmsg_len = CMSG_LEN(sizeof(struct in6_pktinfo));
cmsg->cmsg_level = IPPROTO_IPV6;
cmsg->cmsg_type = IPV6_PKTINFO;
-@@ -591,8 +590,6 @@ int avahi_send_dns_packet_ipv6(int fd, A
+@@ -591,8 +592,6 @@ int avahi_send_dns_packet_ipv6(int fd, A
if (src_address)
memcpy(&pkti->ipi6_addr, src_address->address, sizeof(src_address->address));
diff --git a/net/avahi/files/patch-avahi-sharp_Makefile.in b/net/avahi/files/patch-avahi-sharp_Makefile.in
deleted file mode 100644
index 45c44adbea75..000000000000
--- a/net/avahi/files/patch-avahi-sharp_Makefile.in
+++ /dev/null
@@ -1,16 +0,0 @@
---- avahi-sharp/Makefile.in.orig Tue Feb 7 23:04:12 2006
-+++ avahi-sharp/Makefile.in Tue Feb 7 23:25:30 2006
-@@ -573,10 +573,10 @@
- $(ASSEMBLY): $(AVAHISOURCES)
- mcs -keyfile:$(srcdir)/avahi.snk -target:library -out:$@ -debug $(AVAHISOURCES) -r:Mono.Posix
-
- $(ASSEMBLY).config: $(ASSEMBLY).config.in
-- $(srcdir)/gencfg.sh $(top_builddir)/avahi-client/libavahi-client.la \
-- $(top_builddir)/avahi-common/libavahi-common.la \
-- $(top_builddir)/avahi-glib/libavahi-glib.la < $< > $@
-+# $(srcdir)/gencfg.sh $(top_builddir)/avahi-client/libavahi-client.la \
-+# $(top_builddir)/avahi-common/libavahi-common.la \
-+# $(top_builddir)/avahi-glib/libavahi-glib.la < $< > $@
-
- @HAVE_DBUS_TRUE@@HAVE_MONO_TRUE@all: $(ASSEMBLY) $(ASSEMBLY).config
-
diff --git a/net/avahi/pkg-plist b/net/avahi/pkg-plist
index 62470d47895c..52fb63b9b0e2 100644
--- a/net/avahi/pkg-plist
+++ b/net/avahi/pkg-plist
@@ -32,6 +32,26 @@ include/avahi-common/strlst.h
include/avahi-common/thread-watch.h
include/avahi-common/timeval.h
include/avahi-common/watch.h
+include/avahi-compat-howl/corby/buffer.h
+include/avahi-compat-howl/corby/channel.h
+include/avahi-compat-howl/corby/corby.h
+include/avahi-compat-howl/corby/message.h
+include/avahi-compat-howl/corby/object.h
+include/avahi-compat-howl/corby/orb.h
+include/avahi-compat-howl/discovery/discovery.h
+include/avahi-compat-howl/discovery/text_record.h
+include/avahi-compat-howl/howl.h
+include/avahi-compat-howl/rendezvous/rendezvous.h
+include/avahi-compat-howl/rendezvous/text_record.h
+include/avahi-compat-howl/salt/address.h
+include/avahi-compat-howl/salt/debug.h
+include/avahi-compat-howl/salt/interface.h
+include/avahi-compat-howl/salt/platform.h
+include/avahi-compat-howl/salt/salt.h
+include/avahi-compat-howl/salt/signal.h
+include/avahi-compat-howl/salt/socket.h
+include/avahi-compat-howl/salt/time.h
+include/avahi-compat-libdns_sd/dns_sd.h
include/avahi-core/core.h
include/avahi-core/log.h
include/avahi-core/lookup.h
@@ -55,7 +75,17 @@ lib/libavahi-glib.a
lib/libavahi-glib.la
lib/libavahi-glib.so
lib/libavahi-glib.so.1
+lib/libdns_sd.a
+lib/libdns_sd.la
+lib/libdns_sd.so
+lib/libdns_sd.so.1
+lib/libhowl.a
+lib/libhowl.la
+lib/libhowl.so
+lib/libhowl.so.0
libdata/pkgconfig/avahi-client.pc
+libdata/pkgconfig/avahi-compat-howl.pc
+libdata/pkgconfig/avahi-compat-libdns_sd.pc
libdata/pkgconfig/avahi-core.pc
libdata/pkgconfig/avahi-glib.pc
sbin/avahi-daemon
@@ -77,6 +107,12 @@ sbin/avahi-dnsconfd
@dirrm %%DATADIR%%
@dirrm include/avahi-glib
@dirrm include/avahi-core
+@dirrm include/avahi-compat-libdns_sd
+@dirrm include/avahi-compat-howl/salt
+@dirrm include/avahi-compat-howl/rendezvous
+@dirrm include/avahi-compat-howl/discovery
+@dirrm include/avahi-compat-howl/corby
+@dirrm include/avahi-compat-howl
@dirrm include/avahi-common
@dirrm include/avahi-client
@dirrm etc/avahi/services
diff --git a/net/gnome-nettool/Makefile b/net/gnome-nettool/Makefile
index 64bd2d9d7209..ff331c15cef1 100644
--- a/net/gnome-nettool/Makefile
+++ b/net/gnome-nettool/Makefile
@@ -3,15 +3,16 @@
# Whom: Adam Weinberger <adamw@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/net/gnomenettool/Makefile,v 1.11 2005/10/04 03:12:16 ahze Exp $
+# $MCom: ports/net/gnomenettool/Makefile,v 1.23 2006/04/24 02:02:46 marcus Exp $
#
PORTNAME= gnomenettool
-PORTVERSION= 1.4.1
+PORTVERSION= 2.14.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= net gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-nettool/1.4
+MASTER_SITE_SUBDIR= sources/gnome-nettool/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
DISTNAME= gnome-nettool-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -22,6 +23,7 @@ USE_X_PREFIX= yes
USE_BZIP2= yes
USE_GNOME= gnomehack intlhack gnomeprefix libglade2 gconf2
USE_GMAKE= yes
+USE_GETTEXT= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/net/gnome-nettool/distinfo b/net/gnome-nettool/distinfo
index 2062ca84df73..830c528617b2 100644
--- a/net/gnome-nettool/distinfo
+++ b/net/gnome-nettool/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gnome-nettool-1.4.1.tar.bz2) = a64f7b39f24b4d3a843d545f2dbb611d
-SHA256 (gnome2/gnome-nettool-1.4.1.tar.bz2) = 8b8fc47dcfddf4194c30efba4cdbf6efc96a49b1fd69b3a87461d1af383f4a91
-SIZE (gnome2/gnome-nettool-1.4.1.tar.bz2) = 477548
+MD5 (gnome2/gnome-nettool-2.14.1.tar.bz2) = d7693bf04adfdb5d3a64dafb1c59cb3c
+SHA256 (gnome2/gnome-nettool-2.14.1.tar.bz2) = 9ec757eed3315c12e1e1ca84d3deed6f3ad7d82dc9005608e33768559be6ead7
+SIZE (gnome2/gnome-nettool-2.14.1.tar.bz2) = 490947
diff --git a/net/gnome-nettool/files/patch-src_info.c b/net/gnome-nettool/files/patch-src_info.c
index 9b895e8fd67f..7faf5e433c9b 100644
--- a/net/gnome-nettool/files/patch-src_info.c
+++ b/net/gnome-nettool/files/patch-src_info.c
@@ -1,15 +1,17 @@
---- src/info.c.orig Thu Jan 27 18:26:53 2005
-+++ src/info.c Sun Jul 3 17:46:31 2005
-@@ -20,6 +20,8 @@
+--- src/info.c.orig Mon Apr 3 15:41:33 2006
++++ src/info.c Sun Apr 23 21:57:39 2006
+@@ -20,6 +20,10 @@
#include <gtk/gtk.h>
#include <glib/gi18n.h>
#include <glib/gprintf.h>
+#include <sys/types.h>
+#include <string.h>
++#include <errno.h>
++#include <unistd.h>
#ifdef HAVE_CONFIG_H
# include <config.h>
-@@ -38,6 +40,11 @@
+@@ -38,6 +42,11 @@
#include <sys/ioctl.h>
#include <stdlib.h>
#include <net/if.h>
@@ -21,7 +23,7 @@
#include "info.h"
#include "utils.h"
-@@ -58,6 +65,7 @@ static InfoInterfaceDescription info_ifa
+@@ -58,6 +67,7 @@ static InfoInterfaceDescription info_ifa
{ N_("Ethernet Interface"), INFO_INTERFACE_ETH, "16_ethernet.xpm", "eth", NULL },
{ N_("Wireless Interface"), INFO_INTERFACE_WLAN, "wavelan-16.png", "wlan", NULL },
{ N_("Modem Interface"), INFO_INTERFACE_PPP, "16_ppp.xpm", "ppp", NULL },
@@ -29,7 +31,7 @@
{ N_("Parallel Line Interface"), INFO_INTERFACE_PLIP, "16_plip.xpm", "plip", NULL },
{ N_("Infrared Interface"), INFO_INTERFACE_IRLAN, "irda-16.png", "irlan", NULL },
{ N_("Loopback Interface"), INFO_INTERFACE_LO, "16_loopback.xpm", "lo", NULL },
-@@ -128,9 +136,42 @@ info_get_interface_from_dev_name (const
+@@ -128,9 +138,42 @@ info_get_interface_from_dev_name (const
{
gint i;
gchar *path;
@@ -71,10 +73,10 @@
for (i = 0; info_iface_desc[i].name; i++)
- if (strstr (dev_name, info_iface_desc[i].prefix) == dev_name) {
+ if (strstr (dev_type, info_iface_desc[i].prefix) == dev_type) {
- (*iface) = g_strdup_printf ("%s (%s)", info_iface_desc[i].name, dev_name);
+ (*iface) = g_strdup_printf ("%s (%s)", _(info_iface_desc[i].name), dev_name);
if (info_iface_desc[i].pixbuf == NULL) {
path = g_build_filename (PIXMAPS_DIR, info_iface_desc[i].icon, NULL);
-@@ -217,38 +258,87 @@ info_nic_update_stats (gpointer data)
+@@ -217,38 +260,87 @@ info_nic_update_stats (gpointer data)
gchar tx[10], tx_error[10], tx_drop[10], tx_ovr[10];
*/
gchar iface[30]; /*, flags[30]; */
@@ -168,7 +170,7 @@
if (g_ascii_strcasecmp (iface, text) == 0) {
/*
-@@ -276,7 +366,9 @@ info_nic_update_stats (gpointer data)
+@@ -276,7 +368,9 @@ info_nic_update_stats (gpointer data)
}
g_io_channel_unref (io);
@@ -179,24 +181,29 @@
return TRUE;
}
-@@ -405,8 +497,16 @@ info_get_nic_information (const gchar *n
+@@ -405,8 +499,20 @@ info_get_nic_information (const gchar *n
InfoIpAddr *ip;
gint flags;
mii_data_result data;
+#ifdef __FreeBSD__
-+ gint hwmib[6], hwlen;
++ gint hwmib[6];
++ size_t hwlen;
+ gchar *hwbuf;
+ guchar *hwptr;
+ struct if_msghdr *hwifm;
+ struct sockaddr_dl *hwsinptr;
+#endif
- getifaddrs (&ifa0);
+- getifaddrs (&ifa0);
++ if (getifaddrs (&ifa0) != 0) {
++ g_warning ("getifaddrs failed: %s", g_strerror (errno));
++ goto fail;
++ }
+ memset (&data, 0, sizeof (data));
for (ifr6 = ifa0; ifr6; ifr6 = ifr6->ifa_next) {
if (strcmp (ifr6->ifa_name, nic) != 0) {
-@@ -452,7 +552,9 @@ info_get_nic_information (const gchar *n
+@@ -452,7 +558,9 @@ info_get_nic_information (const gchar *n
ifc.ifc_req = (struct ifreq *) buf;
ioctl (sockfd, SIOCGIFCONF, &ifc);
@@ -206,7 +213,7 @@
for (ptr = buf; ptr < buf + ifc.ifc_len;) {
ifr = (struct ifreq *) ptr;
-@@ -483,6 +585,45 @@ info_get_nic_information (const gchar *n
+@@ -483,6 +591,45 @@ info_get_nic_information (const gchar *n
(int) ((guchar *) &ifrcopy.ifr_hwaddr.sa_data)[3],
(int) ((guchar *) &ifrcopy.ifr_hwaddr.sa_data)[4],
(int) ((guchar *) &ifrcopy.ifr_hwaddr.sa_data)[5]);
@@ -252,3 +259,12 @@
#else
g_sprintf (dst, NOT_AVAILABLE);
#endif /* SIOCGIFHWADDR */
+@@ -595,6 +742,8 @@ info_get_nic_information (const gchar *n
+ }
+
+ freeifaddrs (ifa0);
++fail:
++ ;
+ }
+
+ static gint *
diff --git a/net/gnome-nettool/files/patch-src_nettool.c b/net/gnome-nettool/files/patch-src_nettool.c
index cae4f648fdf8..d8ac21225fdd 100644
--- a/net/gnome-nettool/files/patch-src_nettool.c
+++ b/net/gnome-nettool/files/patch-src_nettool.c
@@ -1,14 +1,23 @@
---- src/nettool.c.orig Fri Jan 7 23:13:56 2005
-+++ src/nettool.c Mon Jan 24 21:03:48 2005
-@@ -22,6 +22,7 @@
- #include <glib/gi18n.h>
+--- src/nettool.c.orig Tue May 10 18:14:48 2005
++++ src/nettool.c Sun Apr 23 22:00:13 2006
+@@ -24,6 +24,7 @@
+ #include <string.h>
#include <sys/types.h>
#include <sys/socket.h>
+#include <netinet/in.h>
#include <signal.h>
#include <errno.h>
#include <sys/wait.h>
-@@ -357,6 +358,10 @@
+@@ -315,7 +316,7 @@ netinfo_io_text_buffer_dialog (GIOChanne
+ GIOCondition condition, gpointer data)
+ {
+ gchar *text = NULL;
+- gint len;
++ gsize len;
+ Netinfo *netinfo = (Netinfo *) data;
+
+ g_return_val_if_fail (channel != NULL, FALSE);
+@@ -360,6 +361,10 @@ netinfo_io_text_buffer_dialog (GIOChanne
len, NULL);
}
@@ -19,7 +28,7 @@
} else if (status == G_IO_STATUS_AGAIN) {
char buf[1];
-@@ -368,12 +373,13 @@
+@@ -371,12 +376,13 @@ netinfo_io_text_buffer_dialog (GIOChanne
}
g_string_append_c (netinfo->command_output, buf[0]);
}
diff --git a/net/gnome-nettool/pkg-plist b/net/gnome-nettool/pkg-plist
index 0d3d6886cd50..531ea6a3d90c 100644
--- a/net/gnome-nettool/pkg-plist
+++ b/net/gnome-nettool/pkg-plist
@@ -17,8 +17,10 @@ share/locale/bn/LC_MESSAGES/gnome-nettool.mo
share/locale/bs/LC_MESSAGES/gnome-nettool.mo
share/locale/ca/LC_MESSAGES/gnome-nettool.mo
share/locale/cs/LC_MESSAGES/gnome-nettool.mo
+share/locale/cy/LC_MESSAGES/gnome-nettool.mo
share/locale/da/LC_MESSAGES/gnome-nettool.mo
share/locale/de/LC_MESSAGES/gnome-nettool.mo
+share/locale/dz/LC_MESSAGES/gnome-nettool.mo
share/locale/el/LC_MESSAGES/gnome-nettool.mo
share/locale/en_CA/LC_MESSAGES/gnome-nettool.mo
share/locale/en_GB/LC_MESSAGES/gnome-nettool.mo
@@ -32,11 +34,13 @@ share/locale/ga/LC_MESSAGES/gnome-nettool.mo
share/locale/gl/LC_MESSAGES/gnome-nettool.mo
share/locale/gu/LC_MESSAGES/gnome-nettool.mo
share/locale/he/LC_MESSAGES/gnome-nettool.mo
+share/locale/hi/LC_MESSAGES/gnome-nettool.mo
share/locale/hr/LC_MESSAGES/gnome-nettool.mo
share/locale/hu/LC_MESSAGES/gnome-nettool.mo
share/locale/id/LC_MESSAGES/gnome-nettool.mo
share/locale/it/LC_MESSAGES/gnome-nettool.mo
share/locale/ja/LC_MESSAGES/gnome-nettool.mo
+share/locale/ka/LC_MESSAGES/gnome-nettool.mo
share/locale/ko/LC_MESSAGES/gnome-nettool.mo
share/locale/lt/LC_MESSAGES/gnome-nettool.mo
share/locale/mk/LC_MESSAGES/gnome-nettool.mo
@@ -68,6 +72,8 @@ share/locale/wa/LC_MESSAGES/gnome-nettool.mo
share/locale/xh/LC_MESSAGES/gnome-nettool.mo
share/locale/zh_CN/LC_MESSAGES/gnome-nettool.mo
share/locale/zh_TW/LC_MESSAGES/gnome-nettool.mo
+@dirrmtry share/locale/dz/LC_MESSAGES
+@dirrmtry share/locale/dz
@dirrm share/gnome/gnome-nettool/pixmaps
@dirrm share/gnome/gnome-nettool/dialogs
@dirrm share/gnome/gnome-nettool
diff --git a/net/gnomenettool/Makefile b/net/gnomenettool/Makefile
index 64bd2d9d7209..ff331c15cef1 100644
--- a/net/gnomenettool/Makefile
+++ b/net/gnomenettool/Makefile
@@ -3,15 +3,16 @@
# Whom: Adam Weinberger <adamw@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/net/gnomenettool/Makefile,v 1.11 2005/10/04 03:12:16 ahze Exp $
+# $MCom: ports/net/gnomenettool/Makefile,v 1.23 2006/04/24 02:02:46 marcus Exp $
#
PORTNAME= gnomenettool
-PORTVERSION= 1.4.1
+PORTVERSION= 2.14.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= net gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/gnome-nettool/1.4
+MASTER_SITE_SUBDIR= sources/gnome-nettool/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
DISTNAME= gnome-nettool-${PORTVERSION}
DIST_SUBDIR= gnome2
@@ -22,6 +23,7 @@ USE_X_PREFIX= yes
USE_BZIP2= yes
USE_GNOME= gnomehack intlhack gnomeprefix libglade2 gconf2
USE_GMAKE= yes
+USE_GETTEXT= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/net/gnomenettool/distinfo b/net/gnomenettool/distinfo
index 2062ca84df73..830c528617b2 100644
--- a/net/gnomenettool/distinfo
+++ b/net/gnomenettool/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/gnome-nettool-1.4.1.tar.bz2) = a64f7b39f24b4d3a843d545f2dbb611d
-SHA256 (gnome2/gnome-nettool-1.4.1.tar.bz2) = 8b8fc47dcfddf4194c30efba4cdbf6efc96a49b1fd69b3a87461d1af383f4a91
-SIZE (gnome2/gnome-nettool-1.4.1.tar.bz2) = 477548
+MD5 (gnome2/gnome-nettool-2.14.1.tar.bz2) = d7693bf04adfdb5d3a64dafb1c59cb3c
+SHA256 (gnome2/gnome-nettool-2.14.1.tar.bz2) = 9ec757eed3315c12e1e1ca84d3deed6f3ad7d82dc9005608e33768559be6ead7
+SIZE (gnome2/gnome-nettool-2.14.1.tar.bz2) = 490947
diff --git a/net/gnomenettool/files/patch-src_info.c b/net/gnomenettool/files/patch-src_info.c
index 9b895e8fd67f..7faf5e433c9b 100644
--- a/net/gnomenettool/files/patch-src_info.c
+++ b/net/gnomenettool/files/patch-src_info.c
@@ -1,15 +1,17 @@
---- src/info.c.orig Thu Jan 27 18:26:53 2005
-+++ src/info.c Sun Jul 3 17:46:31 2005
-@@ -20,6 +20,8 @@
+--- src/info.c.orig Mon Apr 3 15:41:33 2006
++++ src/info.c Sun Apr 23 21:57:39 2006
+@@ -20,6 +20,10 @@
#include <gtk/gtk.h>
#include <glib/gi18n.h>
#include <glib/gprintf.h>
+#include <sys/types.h>
+#include <string.h>
++#include <errno.h>
++#include <unistd.h>
#ifdef HAVE_CONFIG_H
# include <config.h>
-@@ -38,6 +40,11 @@
+@@ -38,6 +42,11 @@
#include <sys/ioctl.h>
#include <stdlib.h>
#include <net/if.h>
@@ -21,7 +23,7 @@
#include "info.h"
#include "utils.h"
-@@ -58,6 +65,7 @@ static InfoInterfaceDescription info_ifa
+@@ -58,6 +67,7 @@ static InfoInterfaceDescription info_ifa
{ N_("Ethernet Interface"), INFO_INTERFACE_ETH, "16_ethernet.xpm", "eth", NULL },
{ N_("Wireless Interface"), INFO_INTERFACE_WLAN, "wavelan-16.png", "wlan", NULL },
{ N_("Modem Interface"), INFO_INTERFACE_PPP, "16_ppp.xpm", "ppp", NULL },
@@ -29,7 +31,7 @@
{ N_("Parallel Line Interface"), INFO_INTERFACE_PLIP, "16_plip.xpm", "plip", NULL },
{ N_("Infrared Interface"), INFO_INTERFACE_IRLAN, "irda-16.png", "irlan", NULL },
{ N_("Loopback Interface"), INFO_INTERFACE_LO, "16_loopback.xpm", "lo", NULL },
-@@ -128,9 +136,42 @@ info_get_interface_from_dev_name (const
+@@ -128,9 +138,42 @@ info_get_interface_from_dev_name (const
{
gint i;
gchar *path;
@@ -71,10 +73,10 @@
for (i = 0; info_iface_desc[i].name; i++)
- if (strstr (dev_name, info_iface_desc[i].prefix) == dev_name) {
+ if (strstr (dev_type, info_iface_desc[i].prefix) == dev_type) {
- (*iface) = g_strdup_printf ("%s (%s)", info_iface_desc[i].name, dev_name);
+ (*iface) = g_strdup_printf ("%s (%s)", _(info_iface_desc[i].name), dev_name);
if (info_iface_desc[i].pixbuf == NULL) {
path = g_build_filename (PIXMAPS_DIR, info_iface_desc[i].icon, NULL);
-@@ -217,38 +258,87 @@ info_nic_update_stats (gpointer data)
+@@ -217,38 +260,87 @@ info_nic_update_stats (gpointer data)
gchar tx[10], tx_error[10], tx_drop[10], tx_ovr[10];
*/
gchar iface[30]; /*, flags[30]; */
@@ -168,7 +170,7 @@
if (g_ascii_strcasecmp (iface, text) == 0) {
/*
-@@ -276,7 +366,9 @@ info_nic_update_stats (gpointer data)
+@@ -276,7 +368,9 @@ info_nic_update_stats (gpointer data)
}
g_io_channel_unref (io);
@@ -179,24 +181,29 @@
return TRUE;
}
-@@ -405,8 +497,16 @@ info_get_nic_information (const gchar *n
+@@ -405,8 +499,20 @@ info_get_nic_information (const gchar *n
InfoIpAddr *ip;
gint flags;
mii_data_result data;
+#ifdef __FreeBSD__
-+ gint hwmib[6], hwlen;
++ gint hwmib[6];
++ size_t hwlen;
+ gchar *hwbuf;
+ guchar *hwptr;
+ struct if_msghdr *hwifm;
+ struct sockaddr_dl *hwsinptr;
+#endif
- getifaddrs (&ifa0);
+- getifaddrs (&ifa0);
++ if (getifaddrs (&ifa0) != 0) {
++ g_warning ("getifaddrs failed: %s", g_strerror (errno));
++ goto fail;
++ }
+ memset (&data, 0, sizeof (data));
for (ifr6 = ifa0; ifr6; ifr6 = ifr6->ifa_next) {
if (strcmp (ifr6->ifa_name, nic) != 0) {
-@@ -452,7 +552,9 @@ info_get_nic_information (const gchar *n
+@@ -452,7 +558,9 @@ info_get_nic_information (const gchar *n
ifc.ifc_req = (struct ifreq *) buf;
ioctl (sockfd, SIOCGIFCONF, &ifc);
@@ -206,7 +213,7 @@
for (ptr = buf; ptr < buf + ifc.ifc_len;) {
ifr = (struct ifreq *) ptr;
-@@ -483,6 +585,45 @@ info_get_nic_information (const gchar *n
+@@ -483,6 +591,45 @@ info_get_nic_information (const gchar *n
(int) ((guchar *) &ifrcopy.ifr_hwaddr.sa_data)[3],
(int) ((guchar *) &ifrcopy.ifr_hwaddr.sa_data)[4],
(int) ((guchar *) &ifrcopy.ifr_hwaddr.sa_data)[5]);
@@ -252,3 +259,12 @@
#else
g_sprintf (dst, NOT_AVAILABLE);
#endif /* SIOCGIFHWADDR */
+@@ -595,6 +742,8 @@ info_get_nic_information (const gchar *n
+ }
+
+ freeifaddrs (ifa0);
++fail:
++ ;
+ }
+
+ static gint *
diff --git a/net/gnomenettool/files/patch-src_nettool.c b/net/gnomenettool/files/patch-src_nettool.c
index cae4f648fdf8..d8ac21225fdd 100644
--- a/net/gnomenettool/files/patch-src_nettool.c
+++ b/net/gnomenettool/files/patch-src_nettool.c
@@ -1,14 +1,23 @@
---- src/nettool.c.orig Fri Jan 7 23:13:56 2005
-+++ src/nettool.c Mon Jan 24 21:03:48 2005
-@@ -22,6 +22,7 @@
- #include <glib/gi18n.h>
+--- src/nettool.c.orig Tue May 10 18:14:48 2005
++++ src/nettool.c Sun Apr 23 22:00:13 2006
+@@ -24,6 +24,7 @@
+ #include <string.h>
#include <sys/types.h>
#include <sys/socket.h>
+#include <netinet/in.h>
#include <signal.h>
#include <errno.h>
#include <sys/wait.h>
-@@ -357,6 +358,10 @@
+@@ -315,7 +316,7 @@ netinfo_io_text_buffer_dialog (GIOChanne
+ GIOCondition condition, gpointer data)
+ {
+ gchar *text = NULL;
+- gint len;
++ gsize len;
+ Netinfo *netinfo = (Netinfo *) data;
+
+ g_return_val_if_fail (channel != NULL, FALSE);
+@@ -360,6 +361,10 @@ netinfo_io_text_buffer_dialog (GIOChanne
len, NULL);
}
@@ -19,7 +28,7 @@
} else if (status == G_IO_STATUS_AGAIN) {
char buf[1];
-@@ -368,12 +373,13 @@
+@@ -371,12 +376,13 @@ netinfo_io_text_buffer_dialog (GIOChanne
}
g_string_append_c (netinfo->command_output, buf[0]);
}
diff --git a/net/gnomenettool/pkg-plist b/net/gnomenettool/pkg-plist
index 0d3d6886cd50..531ea6a3d90c 100644
--- a/net/gnomenettool/pkg-plist
+++ b/net/gnomenettool/pkg-plist
@@ -17,8 +17,10 @@ share/locale/bn/LC_MESSAGES/gnome-nettool.mo
share/locale/bs/LC_MESSAGES/gnome-nettool.mo
share/locale/ca/LC_MESSAGES/gnome-nettool.mo
share/locale/cs/LC_MESSAGES/gnome-nettool.mo
+share/locale/cy/LC_MESSAGES/gnome-nettool.mo
share/locale/da/LC_MESSAGES/gnome-nettool.mo
share/locale/de/LC_MESSAGES/gnome-nettool.mo
+share/locale/dz/LC_MESSAGES/gnome-nettool.mo
share/locale/el/LC_MESSAGES/gnome-nettool.mo
share/locale/en_CA/LC_MESSAGES/gnome-nettool.mo
share/locale/en_GB/LC_MESSAGES/gnome-nettool.mo
@@ -32,11 +34,13 @@ share/locale/ga/LC_MESSAGES/gnome-nettool.mo
share/locale/gl/LC_MESSAGES/gnome-nettool.mo
share/locale/gu/LC_MESSAGES/gnome-nettool.mo
share/locale/he/LC_MESSAGES/gnome-nettool.mo
+share/locale/hi/LC_MESSAGES/gnome-nettool.mo
share/locale/hr/LC_MESSAGES/gnome-nettool.mo
share/locale/hu/LC_MESSAGES/gnome-nettool.mo
share/locale/id/LC_MESSAGES/gnome-nettool.mo
share/locale/it/LC_MESSAGES/gnome-nettool.mo
share/locale/ja/LC_MESSAGES/gnome-nettool.mo
+share/locale/ka/LC_MESSAGES/gnome-nettool.mo
share/locale/ko/LC_MESSAGES/gnome-nettool.mo
share/locale/lt/LC_MESSAGES/gnome-nettool.mo
share/locale/mk/LC_MESSAGES/gnome-nettool.mo
@@ -68,6 +72,8 @@ share/locale/wa/LC_MESSAGES/gnome-nettool.mo
share/locale/xh/LC_MESSAGES/gnome-nettool.mo
share/locale/zh_CN/LC_MESSAGES/gnome-nettool.mo
share/locale/zh_TW/LC_MESSAGES/gnome-nettool.mo
+@dirrmtry share/locale/dz/LC_MESSAGES
+@dirrmtry share/locale/dz
@dirrm share/gnome/gnome-nettool/pixmaps
@dirrm share/gnome/gnome-nettool/dialogs
@dirrm share/gnome/gnome-nettool
diff --git a/net/vino/Makefile b/net/vino/Makefile
index 8dd024dcf71b..9f7c2d214635 100644
--- a/net/vino/Makefile
+++ b/net/vino/Makefile
@@ -3,15 +3,14 @@
# Whom: Tom McLaughlin <tmclaugh@sdf.lonestar.org>
#
# $FreeBSD$
-# $MCom: ports/net/vino/Makefile,v 1.21 2005/10/08 19:41:39 marcus Exp $
+# $MCom: ports/net/vino/Makefile,v 1.28 2006/04/13 07:52:37 bland Exp $
#
PORTNAME= vino
-PORTVERSION= 2.12.0
-PORTREVISION= 2
+PORTVERSION= 2.13.5
CATEGORIES= net gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.12
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
MAINTAINER= gnome@FreeBSD.org
COMMENT= VNC server that allows for remote access to your GNOME desktop
@@ -19,6 +18,7 @@ COMMENT= VNC server that allows for remote access to your GNOME desktop
LIB_DEPENDS= gnutls:${PORTSDIR}/security/gnutls
USE_BZIP2= yes
+USE_GETTEXT= yes
USE_X_PREFIX= yes
USE_GNOME= gnomeprefix intlhack gnomehack gnomepanel
USE_GMAKE= yes
diff --git a/net/vino/distinfo b/net/vino/distinfo
index 421a629fb605..8a52a9171bea 100644
--- a/net/vino/distinfo
+++ b/net/vino/distinfo
@@ -1,3 +1,3 @@
-MD5 (vino-2.12.0.tar.bz2) = eba0962a0e1b9f21719c5688d3d0728b
-SHA256 (vino-2.12.0.tar.bz2) = 235780a5ff2b714c9a514ec64b0e7dd04a230655b094c0ad2dcd8fa0c4dea627
-SIZE (vino-2.12.0.tar.bz2) = 564627
+MD5 (vino-2.13.5.tar.bz2) = 9bc8c3f0e639fdc7b9ed023501308359
+SHA256 (vino-2.13.5.tar.bz2) = 58ee9c77070a8865cce6d25dd6b68fae02b307b64b203d78bd492e33c8e0c89f
+SIZE (vino-2.13.5.tar.bz2) = 566620
diff --git a/net/vino/pkg-plist b/net/vino/pkg-plist
index b0791a558051..7138e41d395d 100644
--- a/net/vino/pkg-plist
+++ b/net/vino/pkg-plist
@@ -34,6 +34,7 @@ share/locale/id/LC_MESSAGES/vino.mo
share/locale/it/LC_MESSAGES/vino.mo
share/locale/ja/LC_MESSAGES/vino.mo
share/locale/ko/LC_MESSAGES/vino.mo
+share/locale/ku/LC_MESSAGES/vino.mo
share/locale/lt/LC_MESSAGES/vino.mo
share/locale/mk/LC_MESSAGES/vino.mo
share/locale/mn/LC_MESSAGES/vino.mo