aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorAaron Dalton <aaron@FreeBSD.org>2007-01-03 17:15:02 +0000
committerAaron Dalton <aaron@FreeBSD.org>2007-01-03 17:15:02 +0000
commit453b4809756f3938c81d4a8b85093cb9b829e04e (patch)
tree12b14e5e8fe5a28aa5ddc285df84c17817642bc6 /net
parent5560eb3d293ed1099a25067da4ada8e5de89b05e (diff)
Notes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-Whois-ARIN/Makefile40
-rw-r--r--net/p5-Net-Whois-ARIN/distinfo3
-rw-r--r--net/p5-Net-Whois-ARIN/pkg-descr7
-rw-r--r--net/p5-Net-Whois-ARIN/pkg-plist13
5 files changed, 64 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 75d3146e90fc..edcdd2462e52 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -498,6 +498,7 @@
SUBDIR += p5-Net-VNC
SUBDIR += p5-Net-Wake
SUBDIR += p5-Net-Whois
+ SUBDIR += p5-Net-Whois-ARIN
SUBDIR += p5-Net-Whois-IP
SUBDIR += p5-Net-Whois-RIPE
SUBDIR += p5-Net-Whois-Raw
diff --git a/net/p5-Net-Whois-ARIN/Makefile b/net/p5-Net-Whois-ARIN/Makefile
new file mode 100644
index 000000000000..77fddcd24522
--- /dev/null
+++ b/net/p5-Net-Whois-ARIN/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: p5-Net-Whois-ARIN
+# Date created: 03 Jan 2007
+# Whom: Aaron Dalton <aaron@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-Whois-ARIN
+PORTVERSION= 0.11
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@FreeBSD.org
+COMMENT= ARIN whois client
+
+MAN3= Net::Whois::ARIN.3 \
+ Net::Whois::ARIN::AS.3 \
+ Net::Whois::ARIN::Contact.3 \
+ Net::Whois::ARIN::Customer.3 \
+ Net::Whois::ARIN::Network.3 \
+ Net::Whois::ARIN::Organization.3
+
+PERL_CONFIGURE= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= p5-Scalar-List-Utils>0:${PORTSDIR}/lang/p5-Scalar-List-Utils \
+ p5-UNIVERSAL-isa>=0:${PORTSDIR}/devel/p5-UNIVERSAL-isa \
+ p5-UNIVERSAL-can>=0:${PORTSDIR}/devel/p5-UNIVERSAL-can
+RUN_DEPENDS= ${BUILD_DEPENDS}
+.endif
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires at least Perl 5.6. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/p5-Net-Whois-ARIN/distinfo b/net/p5-Net-Whois-ARIN/distinfo
new file mode 100644
index 000000000000..e9e60ac12d92
--- /dev/null
+++ b/net/p5-Net-Whois-ARIN/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-Whois-ARIN-0.11.tar.gz) = a5aee39187c6272acd2a77e30847fdef
+SHA256 (Net-Whois-ARIN-0.11.tar.gz) = d47a6720ff265674cbd918d866c73221be9916d81e1c30ccdb0d49e6b45110e8
+SIZE (Net-Whois-ARIN-0.11.tar.gz) = 11058
diff --git a/net/p5-Net-Whois-ARIN/pkg-descr b/net/p5-Net-Whois-ARIN/pkg-descr
new file mode 100644
index 000000000000..2e2119042e51
--- /dev/null
+++ b/net/p5-Net-Whois-ARIN/pkg-descr
@@ -0,0 +1,7 @@
+This module provides a Perl interface to the ARIN Whois server. The module
+takes care of connecting to an ARIN whois server, sending your whois
+requests, and parsing the whois output. The whois records are returned as
+lists of Net::Whois::ARIN::* instances.
+
+WWW: http://search.cpan.org/dist/Net-Whois-ARIN
+Author: Todd Caine <todd.caine at gmail.com>
diff --git a/net/p5-Net-Whois-ARIN/pkg-plist b/net/p5-Net-Whois-ARIN/pkg-plist
new file mode 100644
index 000000000000..b9498789a048
--- /dev/null
+++ b/net/p5-Net-Whois-ARIN/pkg-plist
@@ -0,0 +1,13 @@
+%%SITE_PERL%%/Net/Whois/ARIN.pm
+%%SITE_PERL%%/Net/Whois/ARIN/AS.pm
+%%SITE_PERL%%/Net/Whois/ARIN/Contact.pm
+%%SITE_PERL%%/Net/Whois/ARIN/Customer.pm
+%%SITE_PERL%%/Net/Whois/ARIN/Network.pm
+%%SITE_PERL%%/Net/Whois/ARIN/Organization.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Whois/ARIN/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Whois/ARIN
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Whois
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrm %%SITE_PERL%%/Net/Whois/ARIN
+@dirrmtry %%SITE_PERL%%/Net/Whois
+@dirrmtry %%SITE_PERL%%/Net