aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-03-31 03:51:25 +0000
committerWill Andrews <will@FreeBSD.org>2001-03-31 03:51:25 +0000
commit67fc8379f6687707e8aa716e013c3831d59bf9bc (patch)
tree7cddc08058488b5141f984aece244bb37296b097 /net
parent7b3558e834a57d48e7f36b606a4b39b6487ecf7e (diff)
downloadports-67fc8379f6687707e8aa716e013c3831d59bf9bc.tar.gz
ports-67fc8379f6687707e8aa716e013c3831d59bf9bc.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/jud/Makefile35
-rw-r--r--net/jud/distinfo1
-rw-r--r--net/jud/files/patch-Makefile10
-rw-r--r--net/jud/pkg-comment1
-rw-r--r--net/jud/pkg-descr4
-rw-r--r--net/jud/pkg-plist2
7 files changed, 54 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 974c1651367b..c4ff2b939c0b 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -137,6 +137,7 @@
SUBDIR += isc-dhcp3
SUBDIR += isic
SUBDIR += jabber
+ SUBDIR += jud
SUBDIR += jumpgate
SUBDIR += jwhois
SUBDIR += kdenetwork2
diff --git a/net/jud/Makefile b/net/jud/Makefile
new file mode 100644
index 000000000000..945e1980102b
--- /dev/null
+++ b/net/jud/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: jud
+# Date created: 04 December 2000
+# Whom: Yen-Ming Lee <leeym@cae.ce.ntu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jud
+PORTVERSION= 0.4
+CATEGORIES= net
+MASTER_SITES= http://download.jabber.org/dists/1.4/final/
+
+MAINTAINER= leeym@cae.ce.ntu.edu.tw
+
+BUILD_DEPENDS= ${NONEXISTENT}:${JABBER_PORT}:configure
+RUN_DEPENDS= jabberd:${JABBER_PORT}
+
+.include <bsd.port.pre.mk>
+
+JABBER_PORT= ${PORTSDIR}/net/jabber
+JABBER_WRKSRC!= cd ${JABBER_PORT} && ${MAKE} -V WRKSRC
+MAKE_ENV= JABBER_WRKSRC=${JABBER_WRKSRC}
+
+do-install:
+ @${MKDIR} ${PREFIX}/lib/jabber/${PORTNAME}
+ @${INSTALL_PROGRAM} ${WRKSRC}/jud.so ${PREFIX}/lib/jabber/${PORTNAME}
+ @${ECHO} ""
+ @${ECHO} "============================================================================="
+ @${ECHO} "Please read ${WRKSRC}/README first"
+ @${ECHO} "and add \"./${PORTNAME}/jud.so\" into ${PREFIX}/etc/jabber.xml"
+ @${ECHO} "then restart jabberd to enable ${PORTNAME}"
+ @${ECHO} "============================================================================="
+ @${ECHO} ""
+
+.include <bsd.port.post.mk>
diff --git a/net/jud/distinfo b/net/jud/distinfo
new file mode 100644
index 000000000000..96234f381c1e
--- /dev/null
+++ b/net/jud/distinfo
@@ -0,0 +1 @@
+MD5 (jud-0.4.tar.gz) = a057e8dd5966fa0d26ded03697ba395a
diff --git a/net/jud/files/patch-Makefile b/net/jud/files/patch-Makefile
new file mode 100644
index 000000000000..f7aa1259eee3
--- /dev/null
+++ b/net/jud/files/patch-Makefile
@@ -0,0 +1,10 @@
+--- Makefile.orig Thu Feb 1 17:46:54 2001
++++ Makefile Wed Feb 14 05:02:15 2001
+@@ -1,5 +1,5 @@
+-include ../platform-settings
++include $(JABBER_WRKSRC)/platform-settings
+
+-CFLAGS:=$(CFLAGS) -I../jabberd
++CFLAGS:=$(CFLAGS) -I$(JABBER_WRKSRC)/jabberd
+
+ jud_OBJECTS=jud.o jud_reg.o jud_search.o
diff --git a/net/jud/pkg-comment b/net/jud/pkg-comment
new file mode 100644
index 000000000000..efde88b8a5c9
--- /dev/null
+++ b/net/jud/pkg-comment
@@ -0,0 +1 @@
+Jabber User Directory
diff --git a/net/jud/pkg-descr b/net/jud/pkg-descr
new file mode 100644
index 000000000000..633a79ec766f
--- /dev/null
+++ b/net/jud/pkg-descr
@@ -0,0 +1,4 @@
+This is the first public release of the simple JUD (Jabber User Directory).
+
+--
+Yen-Ming Lee <leeym@cae.ce.ntu.edu.tw>
diff --git a/net/jud/pkg-plist b/net/jud/pkg-plist
new file mode 100644
index 000000000000..8871a58b080c
--- /dev/null
+++ b/net/jud/pkg-plist
@@ -0,0 +1,2 @@
+lib/jabber/jud/jud.so
+@dirrm lib/jabber/jud