aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2006-06-28 08:50:57 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2006-06-28 08:50:57 +0000
commitd2ed5107d9ed5298b7e3b1fdc1a535dba942d953 (patch)
treee71d9fb5548e9588288d8af770d315274c00e0d6 /net
parentac5498c2a300a9c26c1db1419336da719378ec4a (diff)
downloadports-d2ed5107d9ed5298b7e3b1fdc1a535dba942d953.tar.gz
ports-d2ed5107d9ed5298b7e3b1fdc1a535dba942d953.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-SFTP-Foreign/Makefile28
-rw-r--r--net/p5-Net-SFTP-Foreign/distinfo3
-rw-r--r--net/p5-Net-SFTP-Foreign/pkg-descr4
-rw-r--r--net/p5-Net-SFTP-Foreign/pkg-plist17
5 files changed, 53 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 0515c05f9d4c..542d4fa4c75e 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -453,6 +453,7 @@
SUBDIR += p5-Net-SCP-Expect
SUBDIR += p5-Net-SDP
SUBDIR += p5-Net-SFTP
+ SUBDIR += p5-Net-SFTP-Foreign
SUBDIR += p5-Net-SMPP
SUBDIR += p5-Net-SNPP
SUBDIR += p5-Net-SSH
diff --git a/net/p5-Net-SFTP-Foreign/Makefile b/net/p5-Net-SFTP-Foreign/Makefile
new file mode 100644
index 000000000000..0efb5bbd1647
--- /dev/null
+++ b/net/p5-Net-SFTP-Foreign/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: Net-SFTP-Foreign
+# Date created: 27 Jun 2006
+# Whom: Simun Mikecin <numisemis@yahoo.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-SFTP-Foreign
+DISTVERSION= 0.90_10
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/S/SA/SALVA
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= numisemis@yahoo.com
+COMMENT= Net::SFTP::Foreign - Secure File Transfer Protocol client
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::SFTP::Foreign.3 \
+ Net::SFTP::Foreign::Attributes.3 \
+ Net::SFTP::Foreign::Attributes::Compat.3 \
+ Net::SFTP::Foreign::Buffer.3 \
+ Net::SFTP::Foreign::Compat.3 \
+ Net::SFTP::Foreign::Constants.3 \
+ Net::SFTP::Foreign::Local.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-Net-SFTP-Foreign/distinfo b/net/p5-Net-SFTP-Foreign/distinfo
new file mode 100644
index 000000000000..3f2dd34a1574
--- /dev/null
+++ b/net/p5-Net-SFTP-Foreign/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-SFTP-Foreign-0.90_10.tar.gz) = 020a9c437b8d17389bf1a83c6a9350c7
+SHA256 (Net-SFTP-Foreign-0.90_10.tar.gz) = c56475af6b68ac1cc1d63b1922b03a02b080e2800994a3e736a4827b8acae54c
+SIZE (Net-SFTP-Foreign-0.90_10.tar.gz) = 88395
diff --git a/net/p5-Net-SFTP-Foreign/pkg-descr b/net/p5-Net-SFTP-Foreign/pkg-descr
new file mode 100644
index 000000000000..bd293487fdef
--- /dev/null
+++ b/net/p5-Net-SFTP-Foreign/pkg-descr
@@ -0,0 +1,4 @@
+Net::SFTP::Foreign - Secure File Transfer Protocol client
+WARNING: This is a development version, expect bugs on it!!!
+
+WWW: http://search.cpan.org/dist/Net-SFTP-Foreign/
diff --git a/net/p5-Net-SFTP-Foreign/pkg-plist b/net/p5-Net-SFTP-Foreign/pkg-plist
new file mode 100644
index 000000000000..96f4cfd5f544
--- /dev/null
+++ b/net/p5-Net-SFTP-Foreign/pkg-plist
@@ -0,0 +1,17 @@
+%%SITE_PERL%%/Net/SFTP/Foreign.pm
+%%SITE_PERL%%/Net/SFTP/Foreign/Attributes.pm
+%%SITE_PERL%%/Net/SFTP/Foreign/Attributes/Compat.pm
+%%SITE_PERL%%/Net/SFTP/Foreign/Buffer.pm
+%%SITE_PERL%%/Net/SFTP/Foreign/Compat.pm
+%%SITE_PERL%%/Net/SFTP/Foreign/Common.pm
+%%SITE_PERL%%/Net/SFTP/Foreign/Constants.pm
+%%SITE_PERL%%/Net/SFTP/Foreign/Helpers.pm
+%%SITE_PERL%%/Net/SFTP/Foreign/Local.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/SFTP/Foreign/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/SFTP/Foreign
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/SFTP
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrm %%SITE_PERL%%/Net/SFTP/Foreign/Attributes
+@dirrm %%SITE_PERL%%/Net/SFTP/Foreign
+@dirrmtry %%SITE_PERL%%/Net/SFTP
+@dirrmtry %%SITE_PERL%%/Net