aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2005-12-26 15:39:20 +0000
committerAndrej Zverev <az@FreeBSD.org>2005-12-26 15:39:20 +0000
commit78aa3c31e697d874b6ed51bddd61f86c5f192b09 (patch)
tree004b20f08b8ae6dcade02d908b23c2d8522ce6f9 /net
parent5f4d62af14cc226c41e358744b42a8a8829c4786 (diff)
downloadports-78aa3c31e697d874b6ed51bddd61f86c5f192b09.tar.gz
ports-78aa3c31e697d874b6ed51bddd61f86c5f192b09.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/smb4k/Makefile12
-rw-r--r--net/smb4k/files/patch-smb4kfileio11
2 files changed, 8 insertions, 15 deletions
diff --git a/net/smb4k/Makefile b/net/smb4k/Makefile
index 2645488096b1..21a0e8d203c6 100644
--- a/net/smb4k/Makefile
+++ b/net/smb4k/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= smb4k
-PORTVERSION= 0.6.3
+PORTVERSION= 0.6.4
CATEGORIES= net kde
MASTER_SITES= http://download.berlios.de/smb4k/
@@ -16,9 +16,7 @@ COMMENT= KDE 3.x SMB Network browser and SMB shares mounting center
RUN_DEPENDS= sudo:${PORTSDIR}/security/sudo \
smbstatus:${PORTSDIR}/net/samba3
-BROKEN= Does not compile
-
-USE_KDELIBS_VER= 3
+USE_KDEBASE_VER= 3
USE_GMAKE= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
@@ -31,6 +29,12 @@ PLIST_SUB= DOCSDIR=${DOCSDIR}
USE_AUTOTOOLS= libtool:15
INSTALLS_SHLIB= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "does not build on 4.x (missing sys/statvfs.h)"
+.endif
+
post-install:
.for i in smb2awk smb2nsmbrc
${INSTALL_SCRIPT} ${FILESDIR}/${i} ${PREFIX}/bin
diff --git a/net/smb4k/files/patch-smb4kfileio b/net/smb4k/files/patch-smb4kfileio
deleted file mode 100644
index 7d4725c5b286..000000000000
--- a/net/smb4k/files/patch-smb4kfileio
+++ /dev/null
@@ -1,11 +0,0 @@
---- smb4k/core/smb4kfileio.cpp.bak Mon Oct 31 17:09:18 2005
-+++ smb4k/core/smb4kfileio.cpp Mon Oct 31 17:09:18 2005
-@@ -221,7 +221,7 @@
- contents.append( "smb4k_mount\t"+m_config->readPathEntry( "smb4k_mount" )+"\t$(Smb4KUsers)\tuid=root\tgid=root\tenv=PASSWD,USER" );
- #else
- contents.append( "smb4k_kill\t"+m_config->readPathEntry( "smb4k_kill" )+"\t$(Smb4KUsers)\tuid=root\tgid=wheel" );
-- contents.append( "smb4k_umount\t"+m_config->readPathEntry( "smb4k_umount" )+"\t$(Smb4KUsers)\tuid=root\tgid=wheel" );item
-+ contents.append( "smb4k_umount\t"+m_config->readPathEntry( "smb4k_umount" )+"\t$(Smb4KUsers)\tuid=root\tgid=wheel" );
- contents.append( "smb4k_mount\t"+m_config->readPathEntry( "smb4k_mount" )+"\t$(Smb4KUsers)\tuid=root\tgid=wheel\tsetenv=HOME=$CALLER_HOME\tenv=PASSWD,USER" );
- #endif
- contents.append( "# End of Smb4K user entries." );