aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorCy Schubert <cy@FreeBSD.org>2013-02-18 21:17:12 +0000
committerCy Schubert <cy@FreeBSD.org>2013-02-18 21:17:12 +0000
commit94e4ae2915b7c58ef4804f03f5e7369f1fbddf2c (patch)
tree448203d8940d5de62fc202e70711574204def3a6 /net
parentfcb98a504a4b2d61662773d959b7cc3ee239eb09 (diff)
Notes
Diffstat (limited to 'net')
-rw-r--r--net/ntp-devel/Makefile4
-rw-r--r--net/ntp-devel/Makefile.inc1
-rw-r--r--net/ntp-rc/Makefile4
-rw-r--r--net/ntp-rc/Makefile.inc1
-rw-r--r--net/ntp/Makefile4
-rw-r--r--net/ntp/Makefile.inc1
6 files changed, 15 insertions, 0 deletions
diff --git a/net/ntp-devel/Makefile b/net/ntp-devel/Makefile
index 1eedc9183fd9..27153dfa3685 100644
--- a/net/ntp-devel/Makefile
+++ b/net/ntp-devel/Makefile
@@ -44,6 +44,10 @@ PLIST_SUB+= SSL=""
CONFIGURE_ARGS+= --enable-ipv6
.endif
+.if !defined(WITH_NTP_SIGND)
+CONFIGURE_ARGS+= --enable-ntp-signd
+.endif
+
.if defined(WITH_NTPSNMPD)
PLIST_FILES+= sbin/ntpsnmpd
BUILD_DEPENDS+= ${LOCALBASE}/include/net-snmp/net-snmp-config.h:${PORTSDIR}/net-mgmt/net-snmp
diff --git a/net/ntp-devel/Makefile.inc b/net/ntp-devel/Makefile.inc
index 62ad4c87c05c..03493036d920 100644
--- a/net/ntp-devel/Makefile.inc
+++ b/net/ntp-devel/Makefile.inc
@@ -3,6 +3,7 @@
OPTIONS= NTPSNMPD "Build and install ntpsnmpd" OFF \
SSL "Enable SSL" ON \
IPV6 "Enable IPv6" OFF \
+ NTP_SIGND "Enable signed NTP" OFF \
BANCOMM "Enable Datum/Bancomm bc635/VME interface" OFF \
GPSVME "Enable TrueTime GPS receiver/VME interface" OFF \
ACTS "Enable ACTS modem service" OFF \
diff --git a/net/ntp-rc/Makefile b/net/ntp-rc/Makefile
index aaa2d7103d4a..de90ee8f1740 100644
--- a/net/ntp-rc/Makefile
+++ b/net/ntp-rc/Makefile
@@ -57,6 +57,10 @@ PLIST_SUB+= SSL=""
CONFIGURE_ARGS+= --enable-ipv6
.endif
+.if !defined(WITH_NTP_SIGND)
+CONFIGURE_ARGS+= --enable-ntp-signd
+.endif
+
.for D in ${NTP_DRIVERS}
.if defined(WITH_${D})
CONFIGURE_ARGS+= --enable-${D}
diff --git a/net/ntp-rc/Makefile.inc b/net/ntp-rc/Makefile.inc
index 400aa4a36f9c..7cdaf128a0fa 100644
--- a/net/ntp-rc/Makefile.inc
+++ b/net/ntp-rc/Makefile.inc
@@ -3,6 +3,7 @@
OPTIONS= NTPSNMPD "Build and install ntpsnmpd" OFF \
SSL "Enable SSL" ON \
IPV6 "Enable IPv6" OFF \
+ NTP_SIGND "Enable signed NTP" OFF \
BANCOMM "Enable Datum/Bancomm bc635/VME interface" OFF \
GPSVME "Enable TrueTime GPS receiver/VME interface" OFF \
ACTS "Enable ACTS modem service" OFF \
diff --git a/net/ntp/Makefile b/net/ntp/Makefile
index 1f01cb600ce3..b9ec13ea5bba 100644
--- a/net/ntp/Makefile
+++ b/net/ntp/Makefile
@@ -56,6 +56,10 @@ PLIST_SUB+= SSL=""
CONFIGURE_ARGS+= --enable-ipv6
.endif
+.if !defined(WITH_NTP_SIGND)
+CONFIGURE_ARGS+= --enable-ntp-signd
+.endif
+
.for D in ${NTP_DRIVERS}
.if defined(WITH_${D})
CONFIGURE_ARGS+= --enable-${D}
diff --git a/net/ntp/Makefile.inc b/net/ntp/Makefile.inc
index 24eda06811ae..f40716e094ba 100644
--- a/net/ntp/Makefile.inc
+++ b/net/ntp/Makefile.inc
@@ -3,6 +3,7 @@
OPTIONS= NTPSNMPD "Build and install ntpsnmpd" OFF \
SSL "Enable SSL" ON \
IPV6 "Enable IPv6" OFF \
+ NTP_SIGND "Enable signed NTP" OFF \
BANCOMM "Enable Datum/Bancomm bc635/VME interface" OFF \
GPSVME "Enable TrueTime GPS receiver/VME interface" OFF \
ACTS "Enable ACTS modem service" OFF \