aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2012-12-12 15:16:56 +0000
committerMartin Matuska <mm@FreeBSD.org>2012-12-12 15:16:56 +0000
commitcd4b5e26f1f107f63d1df5461afe8a66829dc3ec (patch)
tree3fb7d6080e4c46250a144599804046174e893258 /net
parent17ceff765800de56a99184d5868cc6c54dd38812 (diff)
downloadports-cd4b5e26f1f107f63d1df5461afe8a66829dc3ec.tar.gz
ports-cd4b5e26f1f107f63d1df5461afe8a66829dc3ec.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/pear-Horde_Kolab_Server/Makefile10
-rw-r--r--net/pear-Horde_Kolab_Server/distinfo4
-rw-r--r--net/pear-Horde_Kolab_Session/Makefile8
-rw-r--r--net/pear-Horde_Kolab_Session/distinfo4
-rw-r--r--net/pear-Horde_Ldap/Makefile5
-rw-r--r--net/pear-Horde_Ldap/distinfo4
-rw-r--r--net/pear-Horde_Rpc/Makefile19
-rw-r--r--net/pear-Horde_Rpc/distinfo4
-rw-r--r--net/pear-Horde_Scribe/Makefile3
-rw-r--r--net/pear-Horde_Scribe/distinfo4
-rw-r--r--net/pear-Horde_Url/Makefile2
-rw-r--r--net/pear-Horde_Url/distinfo4
12 files changed, 43 insertions, 28 deletions
diff --git a/net/pear-Horde_Kolab_Server/Makefile b/net/pear-Horde_Kolab_Server/Makefile
index 148c364d1038..771120d98b93 100644
--- a/net/pear-Horde_Kolab_Server/Makefile
+++ b/net/pear-Horde_Kolab_Server/Makefile
@@ -6,25 +6,27 @@
#
PORTNAME= Horde_Kolab_Server
-PORTVERSION= 1.0.2
+PORTVERSION= 2.0.1
CATEGORIES= net www pear
PKGNAMEPREFIX= pear-
MAINTAINER= horde@FreeBSD.org
COMMENT= Horde library for manipulating the Kolab user database
-OPTIONS= LDAP "Enable LDAP support" On
-
USE_PHP= hash
USE_HORDE_RUN= Horde_Auth \
Horde_Exception
+OPTIONS_DEFAULT= LDAP
+OPTIONS_DEFINE= LDAP
+LDAP_DESC= Enable LDAP support
+
# Not required but we want it
USE_HORDE_RUN+= Horde_Date
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_LDAP)
+.if ${PORT_OPTIONS:MLDAP}
USE_HORDE_RUN+= Horde_Ldap
.endif
diff --git a/net/pear-Horde_Kolab_Server/distinfo b/net/pear-Horde_Kolab_Server/distinfo
index 0e1be867a38a..22bb43f931ef 100644
--- a/net/pear-Horde_Kolab_Server/distinfo
+++ b/net/pear-Horde_Kolab_Server/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Horde/Horde_Kolab_Server-1.0.2.tgz) = fa212afe27fe519192b6941652f93e510c94d873e5077acf673d1d1a06a33eac
-SIZE (Horde/Horde_Kolab_Server-1.0.2.tgz) = 101876
+SHA256 (Horde/Horde_Kolab_Server-2.0.1.tgz) = 38ba3928c5341e10b3fc9ddffba8673532862498d1bef5f24c895791db95fe34
+SIZE (Horde/Horde_Kolab_Server-2.0.1.tgz) = 101817
diff --git a/net/pear-Horde_Kolab_Session/Makefile b/net/pear-Horde_Kolab_Session/Makefile
index d8eba45ff3b0..50a7ecc70d61 100644
--- a/net/pear-Horde_Kolab_Session/Makefile
+++ b/net/pear-Horde_Kolab_Session/Makefile
@@ -5,14 +5,16 @@
# $FreeBSD$
PORTNAME= Horde_Kolab_Session
-PORTVERSION= 1.1.1
+PORTVERSION= 2.0.1
CATEGORIES= net www pear
MAINTAINER= horde@FreeBSD.org
COMMENT= Horde library for managing an active Kolab session
-USE_HORDE_RUN= Horde_Exception \
- Horde_Kolab_Server \
+USE_HORDE_RUN= Horde_Exception
+
+# Optional but we want it
+USE_HORDE_RUN+= Horde_Kolab_Server \
Horde_Log
.include <bsd.port.pre.mk>
diff --git a/net/pear-Horde_Kolab_Session/distinfo b/net/pear-Horde_Kolab_Session/distinfo
index 3986fac175dc..f9c99a68cf19 100644
--- a/net/pear-Horde_Kolab_Session/distinfo
+++ b/net/pear-Horde_Kolab_Session/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Horde/Horde_Kolab_Session-1.1.1.tgz) = c90aa46927e901341ea311b2f24a4e1beb8d0d1070a489090964badb3f618a31
-SIZE (Horde/Horde_Kolab_Session-1.1.1.tgz) = 21207
+SHA256 (Horde/Horde_Kolab_Session-2.0.1.tgz) = 8097f7ae46405c05148e9af49a006f700149ba85576b6b1cb4e7412b4781a8be
+SIZE (Horde/Horde_Kolab_Session-2.0.1.tgz) = 21181
diff --git a/net/pear-Horde_Ldap/Makefile b/net/pear-Horde_Ldap/Makefile
index 20477a53a24d..5c251e1dda1a 100644
--- a/net/pear-Horde_Ldap/Makefile
+++ b/net/pear-Horde_Ldap/Makefile
@@ -5,14 +5,15 @@
# $FreeBSD$
PORTNAME= Horde_Ldap
-PORTVERSION= 1.1.5
+PORTVERSION= 2.0.1
CATEGORIES= net www pear
MAINTAINER= horde@FreeBSD.org
COMMENT= Horde LDAP libraries
USE_PHP= ldap
-USE_HORDE_RUN= Horde_Exception Horde_Util
+USE_HORDE_RUN= Horde_Exception \
+ Horde_Util
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/devel/pear-channel-horde/bsd.horde.mk"
diff --git a/net/pear-Horde_Ldap/distinfo b/net/pear-Horde_Ldap/distinfo
index e9e36f7f30e6..4bf09f4683d4 100644
--- a/net/pear-Horde_Ldap/distinfo
+++ b/net/pear-Horde_Ldap/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Horde/Horde_Ldap-1.1.5.tgz) = 2fbb66aa7fb9642e0eb2f97d92d733519ae30f07fa061690ce8173ef578157aa
-SIZE (Horde/Horde_Ldap-1.1.5.tgz) = 63232
+SHA256 (Horde/Horde_Ldap-2.0.1.tgz) = b7d4699c8c9f07bf027c09e6fd9585c56398246a24eee5816418329fd264bcfd
+SIZE (Horde/Horde_Ldap-2.0.1.tgz) = 63212
diff --git a/net/pear-Horde_Rpc/Makefile b/net/pear-Horde_Rpc/Makefile
index bc853bff032a..ab2dace1422b 100644
--- a/net/pear-Horde_Rpc/Makefile
+++ b/net/pear-Horde_Rpc/Makefile
@@ -5,15 +5,26 @@
# $FreeBSD$
PORTNAME= Horde_Rpc
-PORTVERSION= 1.0.4
+PORTVERSION= 2.0.1
CATEGORIES= net www pear
MAINTAINER= horde@FreeBSD.org
COMMENT= Horde RPC API
-USE_HORDE_RUN= Horde_ActiveSync Horde_Core Horde_Exception Horde_Lock \
- Horde_Perms Horde_Serialize Horde_Support Horde_SyncMl \
- Horde_Translation Horde_Util Horde_Xml_Element Horde_Http
+USE_HORDE_RUN= Horde_Core \
+ Horde_Exception \
+ Horde_Perms \
+ Horde_Serialize \
+ Horde_Support \
+ Horde_Translation \
+ Horde_Util \
+ Horde_Xml_Element
+
+# Optional but we want it
+USE_HORDE_RUN+= Horde_ActiveSync \
+ Horde_Lock \
+ Horde_SyncMl \
+ Horde_Http
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/devel/pear-channel-horde/bsd.horde.mk"
diff --git a/net/pear-Horde_Rpc/distinfo b/net/pear-Horde_Rpc/distinfo
index a4187d24997a..a9257f911781 100644
--- a/net/pear-Horde_Rpc/distinfo
+++ b/net/pear-Horde_Rpc/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Horde/Horde_Rpc-1.0.4.tgz) = b5b790684aee6adfd6e05a0a3cf6c2934396b9b772c331ae482ad233b8883a5d
-SIZE (Horde/Horde_Rpc-1.0.4.tgz) = 60359
+SHA256 (Horde/Horde_Rpc-2.0.1.tgz) = 049fc13e69bd08e09ef4ad3ef2c2418f397981bb8c942e472b4ea50773fb837d
+SIZE (Horde/Horde_Rpc-2.0.1.tgz) = 61268
diff --git a/net/pear-Horde_Scribe/Makefile b/net/pear-Horde_Scribe/Makefile
index 297a983a30b0..0b101ab34229 100644
--- a/net/pear-Horde_Scribe/Makefile
+++ b/net/pear-Horde_Scribe/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= Horde_Scribe
-PORTVERSION= 1.0.2
-PORTREVISION= 1
+PORTVERSION= 2.0.1
CATEGORIES= net www pear
MAINTAINER= horde@FreeBSD.org
diff --git a/net/pear-Horde_Scribe/distinfo b/net/pear-Horde_Scribe/distinfo
index b6b6cb1908ed..ff28530b471a 100644
--- a/net/pear-Horde_Scribe/distinfo
+++ b/net/pear-Horde_Scribe/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Horde/Horde_Scribe-1.0.2.tgz) = 4cad50e19aebde1c514956ba31ef06da66b1e696055510234395b349e6bc9611
-SIZE (Horde/Horde_Scribe-1.0.2.tgz) = 4944
+SHA256 (Horde/Horde_Scribe-2.0.1.tgz) = b0feb0d51f4dcd907f28793fef68eaddb00022aa1bd6c3f55ff28c48a92b2be1
+SIZE (Horde/Horde_Scribe-2.0.1.tgz) = 5021
diff --git a/net/pear-Horde_Url/Makefile b/net/pear-Horde_Url/Makefile
index fc191a35b9dd..d684e0956457 100644
--- a/net/pear-Horde_Url/Makefile
+++ b/net/pear-Horde_Url/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= Horde_Url
-PORTVERSION= 1.0.2
+PORTVERSION= 2.0.1
CATEGORIES= net www pear
MAINTAINER= horde@FreeBSD.org
diff --git a/net/pear-Horde_Url/distinfo b/net/pear-Horde_Url/distinfo
index 1a44d20457a0..7ec38831962e 100644
--- a/net/pear-Horde_Url/distinfo
+++ b/net/pear-Horde_Url/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Horde/Horde_Url-1.0.2.tgz) = 51adb65a5c733c53616de9c328c15a260ed04e35e4a8c8f1cca62bfe58fee76d
-SIZE (Horde/Horde_Url-1.0.2.tgz) = 14233
+SHA256 (Horde/Horde_Url-2.0.1.tgz) = 2c63a71385f53fadcc2286e8dc15d93bb7ec89211f4d4f2e50ca78c561b2f787
+SIZE (Horde/Horde_Url-2.0.1.tgz) = 14938