aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorOliver Eikemeier <eik@FreeBSD.org>2004-01-26 21:51:37 +0000
committerOliver Eikemeier <eik@FreeBSD.org>2004-01-26 21:51:37 +0000
commitdd5fadd0881a9cb60b536f0d43b13c4e7c7bb066 (patch)
tree3ee2b31ee1e3dd76cad80f1e289d27bf30d116c2 /net
parent6864e301a1317b035fc6cc9718da748a3f642f04 (diff)
downloadports-dd5fadd0881a9cb60b536f0d43b13c4e7c7bb066.tar.gz
ports-dd5fadd0881a9cb60b536f0d43b13c4e7c7bb066.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/openldap21-server/Makefile16
-rw-r--r--net/openldap21-server/distinfo5
-rw-r--r--net/openldap21-server/files/patch-configure19
-rw-r--r--net/openldap21-server/files/patch-servers::slapd::repl.c13
-rw-r--r--net/openldap21-server/pkg-plist4
5 files changed, 28 insertions, 29 deletions
diff --git a/net/openldap21-server/Makefile b/net/openldap21-server/Makefile
index 75e97c172d3b..39ca110bb2e7 100644
--- a/net/openldap21-server/Makefile
+++ b/net/openldap21-server/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= openldap
-PORTVERSION= 2.1.23
+PORTVERSION= 2.1.26
PORTREVISION= ${OPENLDAP_PORTVERSION}
CATEGORIES= net databases
MASTER_SITES= ftp://ftp.OpenLDAP.org/pub/OpenLDAP/%SUBDIR%/ \
@@ -123,7 +123,10 @@ CONFIGURE_ARGS+= --localstatedir=${LOCALSTATEDIR} \
WITH_BDB_VER?= 41
-.if ${WITH_BDB_VER} == 41
+.if ${WITH_BDB_VER} == 42
+LIB_DEPENDS+= db-4.2.2:${PORTSDIR}/databases/db42
+CONFIGURE_ARGS+= --enable-bdb
+.elif ${WITH_BDB_VER} == 41
LIB_DEPENDS+= db41.1:${PORTSDIR}/databases/db41
CONFIGURE_ARGS+= --enable-bdb
.elif ${WITH_BDB_VER} == 4
@@ -133,9 +136,13 @@ CONFIGURE_ARGS+= --disable-bdb
LIB_DEPENDS+= db3.3:${PORTSDIR}/databases/db3
CONFIGURE_ARGS+= --disable-bdb
.else
-.error WITH_BDB_VER must be 3, 4 or 41
+.error WITH_BDB_VER must be 3, 4, 41 or 42
.endif
+.if ${WITH_BDB_VER} == 42
+LIBS+= -ldb-4.2
+.else
LIBS+= -ldb${WITH_BDB_VER}
+.endif
CPPFLAGS+= -I${LOCALBASE}/include/db${WITH_BDB_VER}
.if defined(WITH_SHELL)
@@ -213,7 +220,7 @@ pre-everything::
.if defined(CLIENT_ONLY)
@${ECHO} "WITH_SASL with (Cyrus) SASL2 support"
.else
- @${ECHO} "WITH_BDB_VER select BerkeleyDB version (default 4.1)"
+ @${ECHO} "WITH_BDB_VER select BerkeleyDB version (default 41)"
@${ECHO} "WITH_SASL with (Cyrus) SASL2 password verification"
@${ECHO} "WITH_PERL with Perl backend"
@${ECHO} "WITH_SHELL with Shell backend"
@@ -263,7 +270,6 @@ post-install:
${MKDIR} ${DOCSDIR}/$${dir}; \
${INSTALL_DATA} ${WRKSRC}/doc/$${dir}/* ${DOCSDIR}/$${dir}; \
done
- @${ECHO_CMD} "@dirrm ${DOCSDIR:S,^${PREFIX}/,,}" >>${TMPPLIST}
.endif
.else
@for schema in ${SCHEMATA}; do \
diff --git a/net/openldap21-server/distinfo b/net/openldap21-server/distinfo
index 63d9185b4893..0989a96964bd 100644
--- a/net/openldap21-server/distinfo
+++ b/net/openldap21-server/distinfo
@@ -1,3 +1,2 @@
-MD5 (openldap-2.1.23.tgz) = a25b5806f8fe031e248f99ca7fe6df2c
-SHA1 (openldap-2.1.23.tgz) = 6e9feb29cfe6026ec9cc6d5a3e971118545cb388
-SIZE (openldap-2.1.23.tgz) = 2035411
+MD5 (openldap-2.1.26.tgz) = e3388c021b1029c15cfbd462d3bfcc9d
+SIZE (openldap-2.1.26.tgz) = 2042658
diff --git a/net/openldap21-server/files/patch-configure b/net/openldap21-server/files/patch-configure
deleted file mode 100644
index c5b2c6831552..000000000000
--- a/net/openldap21-server/files/patch-configure
+++ /dev/null
@@ -1,19 +0,0 @@
-#
-# ITS#2764: fix sed of perl ldopts
-#
---- configure.orig Sun Oct 12 00:40:06 2003
-+++ configure Fri Nov 14 15:39:47 2003
-@@ -7808,10 +7808,11 @@
-
- else
- PERL_CPPFLAGS="`$PERLBIN -MExtUtils::Embed -e ccopts`"
-+ PERL_LDFLAGS="`$PERLBIN -MExtUtils::Embed -e ldopts|sed -e 's/ -lc / /g' -e 's/ -lc$//'`"
- if test x"$ol_with_perl_module" = "xstatic" ; then
-- SLAPD_PERL_LDFLAGS="`$PERLBIN -MExtUtils::Embed -e ldopts|sed -e s/-lc//`"
-+ SLAPD_PERL_LDFLAGS="$PERL_LDFLAGS"
- else
-- MOD_PERL_LDFLAGS="`$PERLBIN -MExtUtils::Embed -e ldopts|sed -e s/-lc//`"
-+ MOD_PERL_LDFLAGS="$PERL_LDFLAGS"
- fi
- ol_link_perl=yes
- fi
diff --git a/net/openldap21-server/files/patch-servers::slapd::repl.c b/net/openldap21-server/files/patch-servers::slapd::repl.c
new file mode 100644
index 000000000000..ebe28b445dd3
--- /dev/null
+++ b/net/openldap21-server/files/patch-servers::slapd::repl.c
@@ -0,0 +1,13 @@
+#
+# OpenLDAP ITS#2930
+#
+--- servers/slapd/repl.c 2004/01/24 01:21:41
++++ servers/slapd/repl.c 2004/01/24 01:46:37
+@@ -383,6 +383,7 @@
+ break;
+
+ case LDAP_REQ_ADD:
++ e = change;
+ for ( a = e->e_attrs; a != NULL; a=a->a_next ) {
+ if ( ri && ri->ri_attrs ) {
+ int is_in = ad_inlist( a->a_desc, ri->ri_attrs );
diff --git a/net/openldap21-server/pkg-plist b/net/openldap21-server/pkg-plist
index e64d6608a94c..5dbd58325f06 100644
--- a/net/openldap21-server/pkg-plist
+++ b/net/openldap21-server/pkg-plist
@@ -12,8 +12,8 @@ sbin/slapcat
sbin/slapindex
sbin/slappasswd
@exec mkdir -p %%LDAP_RUN_DIR%%
-@exec mkdir -p %%DATABASEDIR%%
-@exec mkdir -p %%SLURPDIR%%
@unexec rmdir %%LDAP_RUN_DIR%% 2>/dev/null || true
+@exec mkdir -p %%DATABASEDIR%%
@unexec rmdir %%DATABASEDIR%% 2>/dev/null || true
+@exec mkdir -p %%SLURPDIR%%
@unexec rmdir %%SLURPDIR%% 2>/dev/null || true