aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2003-06-07 23:00:46 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2003-06-07 23:00:46 +0000
commit077b4b53b0d0814df73a850dfa8625101c7b8404 (patch)
tree1635d75a5b1ebd11d644c2d01607580c9063de35 /net
parent95cfdcc8b6a9c07b40477662aa446e3bdd99525b (diff)
downloadports-077b4b53b0d0814df73a850dfa8625101c7b8404.tar.gz
ports-077b4b53b0d0814df73a850dfa8625101c7b8404.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/pear-Net_SMTP/Makefile28
-rw-r--r--net/pear-Net_SMTP/distinfo2
-rw-r--r--net/pear-Net_SMTP/pkg-descr2
-rw-r--r--net/pear-Net_SMTP/pkg-plist4
-rw-r--r--net/pear-Net_Sieve/Makefile25
-rw-r--r--net/pear-Net_Sieve/pkg-deinstall13
-rw-r--r--net/pear-Net_Sieve/pkg-descr2
-rw-r--r--net/pear-Net_Sieve/pkg-plist2
-rw-r--r--net/pear-Net_Socket/Makefile22
-rw-r--r--net/pear-Net_Socket/pkg-descr2
-rw-r--r--net/pear-Net_Socket/pkg-plist3
11 files changed, 25 insertions, 80 deletions
diff --git a/net/pear-Net_SMTP/Makefile b/net/pear-Net_SMTP/Makefile
index 027541d9e1e5..c6aa7ddcac94 100644
--- a/net/pear-Net_SMTP/Makefile
+++ b/net/pear-Net_SMTP/Makefile
@@ -6,42 +6,24 @@
#
PORTNAME= Net_SMTP
-PORTVERSION= 1.1.2
+PORTVERSION= 1.2.3
CATEGORIES= net mail www
-MASTER_SITES= http://pear.php.net/get/
-PKGNAMEPREFIX= pear-
-EXTRACT_SUFX= .tgz
-DIST_SUBDIR= PEAR
MAINTAINER= ports@FreeBSD.org
COMMENT= PEAR class that provides an implementation of the SMTP protocol
-BUILD_DEPENDS= ${PEARDIR}/Auth/SASL.php:${PORTSDIR}/security/pear-Auth_SASL
-# ${PEARDIR}/Net/Socket.php:${PORTSDIR}/net/pear-Net_Socket
+BUILD_DEPENDS= ${PEARDIR}/Auth/SASL.php:${PORTSDIR}/security/pear-Auth_SASL \
+ ${PEARDIR}/Net/Socket.php:${PORTSDIR}/net/pear-Net_Socket
+# The Auth_SASL package is no longer absolutely required, but it will be used if it is available.
RUN_DEPENDS= ${BUILD_DEPENDS}
-NO_BUILD= yes
-
.include <bsd.port.pre.mk>
+.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
-.if exists(${LOCALBASE}/bin/php-config)
-PHP_BASE!= ${LOCALBASE}/bin/php-config --prefix
-.else
-PHP_BASE= ${LOCALBASE}
-.endif
-PEAR= ${LOCALBASE}/bin/pear
-LPHP_LIB= lib/php
-PEARDIR= ${LOCALBASE}/${LPHP_LIB}
-PLIST_SUB= PEARDIR=${LPHP_LIB}
MANIFEST= Net/SMTP.php
do-install:
- @${MV} ${PEARDIR}/${MANIFEST} ${PEARDIR}/${MANIFEST}.dist
@${CP} -p ${WRKSRC}/SMTP.php ${PEARDIR}/Net
@${CHOWN} ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/${MANIFEST}
-post-install:
-# Register an upgraded package
- @${PEAR} upgrade -r -f ${WRKDIR}/package.xml
-
.include <bsd.port.post.mk>
diff --git a/net/pear-Net_SMTP/distinfo b/net/pear-Net_SMTP/distinfo
index 9b2b061eafc9..d75df09b3dc7 100644
--- a/net/pear-Net_SMTP/distinfo
+++ b/net/pear-Net_SMTP/distinfo
@@ -1 +1 @@
-MD5 (PEAR/Net_SMTP-1.1.2.tgz) = af7f864596ed36cc17023991aeb96c69
+MD5 (PEAR/Net_SMTP-1.2.3.tgz) = 3c1ee9556bec8184f26bf7b64ce0b80e
diff --git a/net/pear-Net_SMTP/pkg-descr b/net/pear-Net_SMTP/pkg-descr
index ace9ff315210..b3748a3dfb4e 100644
--- a/net/pear-Net_SMTP/pkg-descr
+++ b/net/pear-Net_SMTP/pkg-descr
@@ -1,4 +1,4 @@
This PEAR class provides an implementation of the SMTP protocol using PEAR's
Net_Socket:: class.
-WWW: http://pear.php.net/package-info.php?pacid=90
+WWW: http://pear.php.net/package-info.php?package=Net_SMTP
diff --git a/net/pear-Net_SMTP/pkg-plist b/net/pear-Net_SMTP/pkg-plist
index 87398a599255..4d01f94a59c7 100644
--- a/net/pear-Net_SMTP/pkg-plist
+++ b/net/pear-Net_SMTP/pkg-plist
@@ -1,3 +1,3 @@
-@exec mv %D/lib/php/Net/SMTP.php %D/lib/php/Net/SMTP.php.dist
%%PEARDIR%%/Net/SMTP.php
-@unexec mv %D/lib/php/Net/SMTP.php.dist %D/lib/php/Net/SMTP.php || true
+%%PKGREGDIR%%/package.xml
+@dirrm %%PKGREGDIR%%
diff --git a/net/pear-Net_Sieve/Makefile b/net/pear-Net_Sieve/Makefile
index 656096187ecb..887d9b19faef 100644
--- a/net/pear-Net_Sieve/Makefile
+++ b/net/pear-Net_Sieve/Makefile
@@ -7,40 +7,21 @@
PORTNAME= Net_Sieve
PORTVERSION= 0.8.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net www
-MASTER_SITES= http://pear.php.net/get/
-PKGNAMEPREFIX= pear-
-EXTRACT_SUFX= .tgz
-DIST_SUBDIR= PEAR
MAINTAINER= ports@FreeBSD.org
COMMENT= PEAR class to handle talking to timsieved
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php.dist:${PORTSDIR}/devel/pear-PEAR
+BUILD_DEPENDS= ${PEARDIR}/Net/Socket.php:${PORTSDIR}/net/pear-Net_Socket
RUN_DEPENDS= ${BUILD_DEPENDS}
-NO_BUILD= yes
-
.include <bsd.port.pre.mk>
-
-.if exists(${LOCALBASE}/bin/php-config)
-PHP_BASE!= ${LOCALBASE}/bin/php-config --prefix
-.else
-PHP_BASE= ${LOCALBASE}
-.endif
-PEAR= ${LOCALBASE}/bin/pear
-LPHP_LIB= lib/php
-PEARDIR= ${PHP_BASE}/${LPHP_LIB}
-PLIST_SUB= PEARDIR=${LPHP_LIB}
+.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
do-install:
@${CP} -Rp ${WRKSRC}/* ${PEARDIR}/Net
@${CHOWN} ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/Net/Sieve.php
@${CHMOD} a-x ${PEARDIR}/Net/Sieve.php
-post-install:
-# Register a new package
- @${PEAR} install -r -f ${WRKDIR}/package.xml
-
.include <bsd.port.post.mk>
diff --git a/net/pear-Net_Sieve/pkg-deinstall b/net/pear-Net_Sieve/pkg-deinstall
deleted file mode 100644
index c17e9d19ced0..000000000000
--- a/net/pear-Net_Sieve/pkg-deinstall
+++ /dev/null
@@ -1,13 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-#
-# Remove package declaration from PEAR's registry.
-
-if [ x$2 != xDEINSTALL ]; then
- exit
-fi
-PKG_NAME=${1%%-[0-9._]*}
-PACKAGE=$(echo $PKG_NAME | sed 's/pear-//')
-
-${PKG_PREFIX}/bin/pear uninstall -r ${PACKAGE} || true
diff --git a/net/pear-Net_Sieve/pkg-descr b/net/pear-Net_Sieve/pkg-descr
index e994efc7f20b..4932c5c33881 100644
--- a/net/pear-Net_Sieve/pkg-descr
+++ b/net/pear-Net_Sieve/pkg-descr
@@ -3,4 +3,4 @@ Net_Sieve is a PEAR class which handles talking to timsieved.
Provides an API to talk to the timsieved server that comes with Cyrus
IMAPd. Can be used to install, remove, mark active, etc. SIEVE scripts.
-WWW: http://pear.php.net/package-info.php?pacid=71
+WWW: http://pear.php.net/package-info.php?package=Net_Sieve
diff --git a/net/pear-Net_Sieve/pkg-plist b/net/pear-Net_Sieve/pkg-plist
index a1753da6c08f..769b8a5fea1c 100644
--- a/net/pear-Net_Sieve/pkg-plist
+++ b/net/pear-Net_Sieve/pkg-plist
@@ -1 +1,3 @@
%%PEARDIR%%/Net/Sieve.php
+%%PKGREGDIR%%/package.xml
+@dirrm %%PKGREGDIR%%
diff --git a/net/pear-Net_Socket/Makefile b/net/pear-Net_Socket/Makefile
index f9456bbc492a..b9ee878428e4 100644
--- a/net/pear-Net_Socket/Makefile
+++ b/net/pear-Net_Socket/Makefile
@@ -7,31 +7,21 @@
PORTNAME= Net_Socket
PORTVERSION= 1.0.1
+PORTREVISION= 1
CATEGORIES= net www
-MASTER_SITES= http://pear.php.net/get/
-PKGNAMEPREFIX= pear-
-EXTRACT_SUFX= .tgz
-DIST_SUBDIR= PEAR
MAINTAINER= ports@FreeBSD.org
COMMENT= PEAR Network Socket Interface
-BUILD_DEPENDS= ${PEARDIR}.DIST_PHP:${PORTSDIR}/devel/pear-install
-RUN_DEPENDS= ${PEARDIR}.DIST_PHP:${PORTSDIR}/devel/pear-install
-
-NO_BUILD= yes
+BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear-PEAR
+RUN_DEPENDS= ${BUILD_DEPENDS}
.include <bsd.port.pre.mk>
-
-.if exists(${LOCALBASE}/bin/php-config)
-PHP_BASE!= ${LOCALBASE}/bin/php-config --prefix
-.endif
-LPHP_LIB= lib/php
-PEARDIR= ${PHP_BASE}/${LPHP_LIB}
-PLIST_SUB= PEARDIR=${LPHP_LIB}
+.include "${.CURDIR}/../../devel/pear-PEAR/Makefile.common"
do-install:
+ @${MKDIR} ${PEARDIR}/Net
@${CP} -Rp ${WRKSRC}/* ${PEARDIR}/Net
- @${CHOWN} -R root:wheel ${PEARDIR}/Net/Socket.php
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${PEARDIR}/Net
.include <bsd.port.post.mk>
diff --git a/net/pear-Net_Socket/pkg-descr b/net/pear-Net_Socket/pkg-descr
index 9bca37de98af..d00622aa5be2 100644
--- a/net/pear-Net_Socket/pkg-descr
+++ b/net/pear-Net_Socket/pkg-descr
@@ -4,4 +4,4 @@ It provides blocking and non-blocking operation, with different reading
and writing modes (byte-wise, block-wise, line-wise and special formats
like network byte-order ip addresses).
-WWW: http://pear.php.net/manual/en/core.networking.net_socket.php
+WWW: http://pear.php.net/package-info.php?package=Net_Socket
diff --git a/net/pear-Net_Socket/pkg-plist b/net/pear-Net_Socket/pkg-plist
index 2426b9ad72eb..da686f64a0e6 100644
--- a/net/pear-Net_Socket/pkg-plist
+++ b/net/pear-Net_Socket/pkg-plist
@@ -1 +1,4 @@
%%PEARDIR%%/Net/Socket.php
+%%PKGREGDIR%%/package.xml
+@dirrm %%PKGREGDIR%%
+@unexec rmdir %D/share/pear/Net 2> /dev/null || true