aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2004-04-14 05:51:01 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2004-04-14 05:51:01 +0000
commit0af7dd45f7f99d76ec314f1e4f211f397192af9d (patch)
treeb92669edb7361e13911e7c84cf9ad81cdafa9190 /net
parent47194e8cfadb4fa278a9ecd7b72c39cc3414dffb (diff)
downloadports-0af7dd45f7f99d76ec314f1e4f211f397192af9d.tar.gz
ports-0af7dd45f7f99d76ec314f1e4f211f397192af9d.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/arp-sk/Makefile34
-rw-r--r--net/arp-sk/distinfo2
-rw-r--r--net/arp-sk/pkg-descr4
4 files changed, 41 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 64b705453572..22294cec6871 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -22,6 +22,7 @@
SUBDIR += archie.el
SUBDIR += ari-yahoo
SUBDIR += arla
+ SUBDIR += arp-sk
SUBDIR += arpd
SUBDIR += arping
SUBDIR += arprelease
diff --git a/net/arp-sk/Makefile b/net/arp-sk/Makefile
new file mode 100644
index 000000000000..150790c250d7
--- /dev/null
+++ b/net/arp-sk/Makefile
@@ -0,0 +1,34 @@
+# ex:ts=8
+# Ports collection makefile for: arp-sk
+# Date Created: Apr 14, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= arp-sk
+PORTVERSION= 0.0.15
+CATEGORIES= net
+MASTER_SITES= http://www.arp-sk.org/files/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= A tool designed to manipulate ARP tables of all kinds of equipment
+
+BUILD_DEPENDS= ${LOCALBASE}/include/libnet/libnet-types.h:${PORTSDIR}/net/libnet-devel
+
+USE_REINPLACE= yes
+#USE_GETOPT_LONG= yes
+GNU_CONFIGURE= yes
+
+MAN1= arp-sk.1
+PLIST_FILES= sbin/arp-sk
+
+post-patch:
+ @${REINPLACE_CMD} -e "s, -pedantic -g,," ${WRKSRC}/configure
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/arp-sk ${PREFIX}/sbin
+ ${INSTALL_MAN} ${WRKSRC}/man/arp-sk.1 ${MAN1PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/net/arp-sk/distinfo b/net/arp-sk/distinfo
new file mode 100644
index 000000000000..614b77b78519
--- /dev/null
+++ b/net/arp-sk/distinfo
@@ -0,0 +1,2 @@
+MD5 (arp-sk-0.0.15.tgz) = fb2694c322efdddfd14307557fe469ec
+SIZE (arp-sk-0.0.15.tgz) = 148454
diff --git a/net/arp-sk/pkg-descr b/net/arp-sk/pkg-descr
new file mode 100644
index 000000000000..d58f9ac74b70
--- /dev/null
+++ b/net/arp-sk/pkg-descr
@@ -0,0 +1,4 @@
+arp-sk is a tool designed to manipulate ARP tables of all kinds of equipment.
+This can be easily performed through the sending of the appropriate packet(s).
+
+WWW: http://www.arp-sk.org/