aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2012-12-12 00:16:21 +0000
committerJason Helfman <jgh@FreeBSD.org>2012-12-12 00:16:21 +0000
commit35edd21037a069774f0b9f8834f9f87fd232973a (patch)
treee2a6dd1b599021cde9f012d41d127bd2254f5517 /net
parent62e1182e153c703ad3194d413122113716f65bdc (diff)
downloadports-35edd21037a069774f0b9f8834f9f87fd232973a.tar.gz
ports-35edd21037a069774f0b9f8834f9f87fd232973a.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/hornetq/Makefile9
-rw-r--r--net/hornetq/files/hornetq.in4
2 files changed, 6 insertions, 7 deletions
diff --git a/net/hornetq/Makefile b/net/hornetq/Makefile
index 8faab392f64f..d0499f7774b3 100644
--- a/net/hornetq/Makefile
+++ b/net/hornetq/Makefile
@@ -1,12 +1,9 @@
-# New ports collection makefile for: hornetq
-# Date created: 2012-03-16
-# Whom: Radim Kolar
-#
+# Created by: Radim Kolar
# $FreeBSD$
-#
PORTNAME= hornetq
PORTVERSION= 2.2.14
+PORTREVISION= 1
CATEGORIES= net java
MASTER_SITES= http://downloads.jboss.org/hornetq/
DISTNAME= ${PORTNAME}-${PORTVERSION}.Final
@@ -21,7 +18,7 @@ PORTDOCS= quickstart-guide api rest-api user-manual \
USE_RC_SUBR= hornetq
USE_JAVA= yes
-JAVA_VERSION= 1.6
+JAVA_VERSION= 1.7
JAVA_VENDOR= openjdk
NO_BUILD= yes
diff --git a/net/hornetq/files/hornetq.in b/net/hornetq/files/hornetq.in
index 5682b3f4dd9d..1da1d8ef9a99 100644
--- a/net/hornetq/files/hornetq.in
+++ b/net/hornetq/files/hornetq.in
@@ -38,6 +38,7 @@ load_rc_config $name
hornetq_enable=${hornetq_enable:-"NO"}
hornetq_config=${hornetq_config:-"non-clustered"}
+hornetq_vmargs=${hornetq_vmargs:-""}
hornetq_deployment=${hornetq_deployment:-"hornetq-beans.xml"}
hornetq_data=${hornetq_data:-"/var/spool/hornetq"}
@@ -54,7 +55,8 @@ export PATH=$PATH:%%LOCALBASE%%/bin
export HORNETQ_HOME=%%DATADIR%%
export CLUSTER_PROPS=-Ddata.dir=${hornetq_data}
export JAVA_VENDOR=openjdk
-export JAVA_VERSION=1.6
+export JAVA_VERSION=1.7
+export CLUSTER_PROPS="${hornetq_vmargs}"
hornetq_prestop() {
$HORNETQ_HOME/bin/stop.sh %%DATADIR%%/config/stand-alone/${hornetq_config}