aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-12-23 04:38:19 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-12-23 04:38:19 +0000
commit46f77a59b3aead7d62a943098498e56d0e72dc31 (patch)
treec29628ddfa5f033771c3f827622a85e8f97d1f15 /net
parent72259604cea5e87e03d7a52b883bdc037af58d39 (diff)
downloadports-46f77a59b3aead7d62a943098498e56d0e72dc31.tar.gz
ports-46f77a59b3aead7d62a943098498e56d0e72dc31.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/linux-overnet-core/Makefile48
-rw-r--r--net/linux-overnet-core/distinfo2
-rw-r--r--net/linux-overnet-core/pkg-descr9
-rw-r--r--net/linux-overnet-core/pkg-plist8
5 files changed, 68 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index ab1c6afff5f7..d6af6f9ae4ba 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -321,6 +321,7 @@
SUBDIR += linux-edonkey-server
SUBDIR += linux-jigdo
SUBDIR += linux-nx-client
+ SUBDIR += linux-overnet-core
SUBDIR += linux-ymessenger
SUBDIR += linuxigd
SUBDIR += liveMedia
diff --git a/net/linux-overnet-core/Makefile b/net/linux-overnet-core/Makefile
new file mode 100644
index 000000000000..524b77326502
--- /dev/null
+++ b/net/linux-overnet-core/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: overnet 'core' command line client
+# Date created: Wed Dec 31 22:43:16 CET 2003
+# Whom: <arundel@gmx.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= overnet
+PORTVERSION= 1.0.1
+CATEGORIES= net linux
+MASTER_SITES= http://www.zen18864.zen.co.uk/${PORTNAME}/${PORTVERSION}/
+PKGNAMEPREFIX= linux-
+PKGNAMESUFFIX= -core
+DISTNAME= ${PORTNAME}clc-${PORTVERSION}_${ARCH}_compat
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= arundel@h3c.de
+COMMENT= Overnet 'core' command line client
+
+ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+STRIP=
+
+BINARY_NAME_OLD?= ${PORTNAME}clc
+TARGET_DIR= ${PORTNAME}
+
+DOC_FILES= ChangeLog LISEZMOI README changelog.Debian.gz
+
+pre-install:
+ @${BRANDELF} -t Linux ${WRKSRC}/usr/bin/${BINARY_NAME_OLD}
+
+do-install:
+ ${INSTALL} -d ${PREFIX}/sbin
+ ${INSTALL_PROGRAM} ${WRKSRC}/usr/bin/${BINARY_NAME_OLD} ${PREFIX}/sbin/${BINARY_NAME}
+ ${INSTALL} -d ${PREFIX}/share/${PORTNAME}${PKGNAMESUFFIX}
+ ${INSTALL_DATA} ${WRKSRC}/usr/share/${PORTNAME}clc/contact.dat ${PREFIX}/share/${PORTNAME}${PKGNAMESUFFIX}/contact.dat
+
+post-install:
+.ifndef(NOPORTDOCS)
+ ${INSTALL} -d ${DOCSDIR}${PKGNAMESUFFIX}
+.for f in ${DOC_FILES}
+ ${INSTALL_MAN} ${WRKSRC}/usr/share/doc/${PORTNAME}clc/${f} ${DOCSDIR}${PKGNAMESUFFIX}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/linux-overnet-core/distinfo b/net/linux-overnet-core/distinfo
new file mode 100644
index 000000000000..5ea91b02d0ef
--- /dev/null
+++ b/net/linux-overnet-core/distinfo
@@ -0,0 +1,2 @@
+MD5 (overnetclc-1.0.1_i386_compat.tgz) = a9f3b7107fd51c7e9776923b83e49b5c
+SIZE (overnetclc-1.0.1_i386_compat.tgz) = 377089
diff --git a/net/linux-overnet-core/pkg-descr b/net/linux-overnet-core/pkg-descr
new file mode 100644
index 000000000000..72e4988067da
--- /dev/null
+++ b/net/linux-overnet-core/pkg-descr
@@ -0,0 +1,9 @@
+The Overnet 'core' is the actual Overnet program which does
+everything behind the scenes - connecting to peers, searching,
+downloading, uploading, all that stuff. It is the serverless
+equivalent to eDonkey2000.
+
+The 'core' comes with a very simple text interface (=command line
+client), where you can tell it what to do by typing in commands.
+
+WWW: http://www.overnet.com/
diff --git a/net/linux-overnet-core/pkg-plist b/net/linux-overnet-core/pkg-plist
new file mode 100644
index 000000000000..2b14049a720f
--- /dev/null
+++ b/net/linux-overnet-core/pkg-plist
@@ -0,0 +1,8 @@
+sbin/overnetclc
+share/overnet-core/contact.dat
+%%PORTDOCS%%%%DOCSDIR%%-core/ChangeLog
+%%PORTDOCS%%%%DOCSDIR%%-core/LISEZMOI
+%%PORTDOCS%%%%DOCSDIR%%-core/README
+%%PORTDOCS%%%%DOCSDIR%%-core/changelog.Debian.gz
+%%PORTDOCS%%@dirrm share/doc/overnet-core
+@dirrm share/overnet-core