aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2012-03-07 20:07:18 +0000
committerSteve Wills <swills@FreeBSD.org>2012-03-07 20:07:18 +0000
commit919029fcba4c827f25e371ddb1d757dd8bb39a57 (patch)
treeeae837737075c828ed0c2b4cd449d25a6198b04d /net
parent612bf9145238d7fb1ff5222a6f850201b619058c (diff)
downloadports-919029fcba4c827f25e371ddb1d757dd8bb39a57.tar.gz
ports-919029fcba4c827f25e371ddb1d757dd8bb39a57.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-POE-Component-PubSub/Makefile25
-rw-r--r--net/p5-POE-Component-PubSub/distinfo2
-rw-r--r--net/p5-POE-Component-PubSub/pkg-descr4
-rw-r--r--net/p5-POE-Component-PubSub/pkg-plist3
5 files changed, 35 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index ea88a544f7eb..ff76d5ac1940 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -688,6 +688,7 @@
SUBDIR += p5-POE-Component-Generic
SUBDIR += p5-POE-Component-Jabber
SUBDIR += p5-POE-Component-Pcap
+ SUBDIR += p5-POE-Component-PubSub
SUBDIR += p5-POE-Component-Server-Twirc
SUBDIR += p5-POE-Component-Spread
SUBDIR += p5-POEx-Role-TCPServer
diff --git a/net/p5-POE-Component-PubSub/Makefile b/net/p5-POE-Component-PubSub/Makefile
new file mode 100644
index 000000000000..d98930b999f6
--- /dev/null
+++ b/net/p5-POE-Component-PubSub/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-POE-Component-PubSub
+# Date created: 2012-03-07
+# Whom: Steve Wills <swills@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-PubSub
+PORTVERSION= 0.05
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+#MASTER_SITE_SUBDIR= CPAN:nperez
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= A generic publish/subscribe POE::Component
+
+BUILD_DEPENDS= p5-POE>=0:${PORTSDIR}/devel/p5-POE
+RUN_DEPENDS= p5-POE>=0:${PORTSDIR}/devel/p5-POE
+
+PERL_MODBUILD= yes
+
+MAN3= POE::Component::PubSub.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-POE-Component-PubSub/distinfo b/net/p5-POE-Component-PubSub/distinfo
new file mode 100644
index 000000000000..32e7e3e509e6
--- /dev/null
+++ b/net/p5-POE-Component-PubSub/distinfo
@@ -0,0 +1,2 @@
+SHA256 (POE-Component-PubSub-0.05.tar.gz) = 73be9494299b71d65951289da4ffc422b78fc46cd10ab12a6b240caa3051665a
+SIZE (POE-Component-PubSub-0.05.tar.gz) = 6892
diff --git a/net/p5-POE-Component-PubSub/pkg-descr b/net/p5-POE-Component-PubSub/pkg-descr
new file mode 100644
index 000000000000..efea62e8825f
--- /dev/null
+++ b/net/p5-POE-Component-PubSub/pkg-descr
@@ -0,0 +1,4 @@
+A generic publish/subscribe POE::Component that enables POE::Sessions to
+publish events to which other POE::Sessions may subscribe.
+
+WWW: http://search.cpan.org/dist/POE-Component-PubSub/
diff --git a/net/p5-POE-Component-PubSub/pkg-plist b/net/p5-POE-Component-PubSub/pkg-plist
new file mode 100644
index 000000000000..940180000b8d
--- /dev/null
+++ b/net/p5-POE-Component-PubSub/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/POE/Component/PubSub.pm
+@dirrmtry %%SITE_PERL%%/POE/Component
+@dirrmtry %%SITE_PERL%%/POE