aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorWesley Shields <wxs@FreeBSD.org>2013-12-29 20:44:20 +0000
committerWesley Shields <wxs@FreeBSD.org>2013-12-29 20:44:20 +0000
commit9deecd43765bca7f1cec2b3a64b878630985e1a7 (patch)
tree9529015c4782c34fc5b9bf9235c4858bf24f3252 /net
parent5c4174835fc6edfc444e44c42ef9b3bca427ab31 (diff)
downloadports-9deecd43765bca7f1cec2b3a64b878630985e1a7.tar.gz
ports-9deecd43765bca7f1cec2b3a64b878630985e1a7.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/tcpdump/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/net/tcpdump/Makefile b/net/tcpdump/Makefile
index 3ad9eca709e4..1921768b1b69 100644
--- a/net/tcpdump/Makefile
+++ b/net/tcpdump/Makefile
@@ -29,8 +29,10 @@ SMI_DESC= Allow MIBs to be loaded on the fly
USER_DESC= Drop privileges to nobody
CHROOT_DESC= Chroot to /var/run/tcpdump (set CHROOTDIR to change)
-NO_STAGE= yes
.include <bsd.port.options.mk>
+
+CONFIGURE_ARGS+= --enable-pcap_setdirection --with-pcap_setdirection
+
# The --without-crypto flag needs to be explicitly specified. The
# configure script gets confused if you specify --with-crypto and
# thinks this means you *don't* want crypto.
@@ -65,14 +67,14 @@ CONFIGURE_ARGS+= --with-chroot=${CHROOTDIR}
.include <bsd.port.pre.mk>
-MAN1= tcpdump.1
-PLIST_FILES= sbin/tcpdump
+PLIST_FILES= sbin/tcpdump \
+ man/man1/tcpdump.1.gz
post-configure:
@${REINPLACE_CMD} -e "s,\./\.\./${LIBPCAP_FORCE_VER}/libpcap\.a,${LOCALBASE}/lib/libpcap.so.1," ${WRKSRC}/Makefile
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/tcpdump ${PREFIX}/sbin
- ${INSTALL_MAN} ${WRKSRC}/tcpdump.1 ${MAN1PREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/tcpdump ${STAGEDIR}/${PREFIX}/sbin
+ ${INSTALL_MAN} ${WRKSRC}/tcpdump.1 ${STAGEDIR}/${MAN1PREFIX}/man/man1
.include <bsd.port.post.mk>