aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2011-09-09 05:42:09 +0000
committerAndrej Zverev <az@FreeBSD.org>2011-09-09 05:42:09 +0000
commitbd794b5869ca7f726d51769b0ea08ebd63e5beb1 (patch)
tree5fad7b3cd5e4a2541b147202af756332aa9a4720 /net
parent2fa0153bd47273b2148f9a7c9e25032b4ff73847 (diff)
downloadports-bd794b5869ca7f726d51769b0ea08ebd63e5beb1.tar.gz
ports-bd794b5869ca7f726d51769b0ea08ebd63e5beb1.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-SOAP-Transport-TCP/Makefile25
-rw-r--r--net/p5-SOAP-Transport-TCP/distinfo2
-rw-r--r--net/p5-SOAP-Transport-TCP/pkg-descr10
-rw-r--r--net/p5-SOAP-Transport-TCP/pkg-plist3
5 files changed, 41 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 68fa316594db..b2b60be25adf 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -714,6 +714,7 @@
SUBDIR += p5-SOAP-Lite
SUBDIR += p5-SOAP-Lite-060
SUBDIR += p5-SOAP-MySOAP
+ SUBDIR += p5-SOAP-Transport-TCP
SUBDIR += p5-Samba-LDAP
SUBDIR += p5-Server-Starter
SUBDIR += p5-Socket-Class
diff --git a/net/p5-SOAP-Transport-TCP/Makefile b/net/p5-SOAP-Transport-TCP/Makefile
new file mode 100644
index 000000000000..2d5f506d6499
--- /dev/null
+++ b/net/p5-SOAP-Transport-TCP/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: SOAP::Transport::TCP
+# Date created: 2011-09-09
+# Whom: Andrej Zverev <az@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= SOAP-Transport-TCP
+PORTVERSION= 0.715
+CATEGORIES= net perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:MKUTTER
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= TCP Transport Support for SOAP::Lite
+
+RUN_DEPENDS= p5-SOAP-Lite>=0.714:${PORTSDIR}/net/p5-SOAP-Lite
+BUILD_DEPENDS:= ${RUN_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= SOAP::Transport::TCP.3
+
+.include <bsd.port.mk>
diff --git a/net/p5-SOAP-Transport-TCP/distinfo b/net/p5-SOAP-Transport-TCP/distinfo
new file mode 100644
index 000000000000..ea09e95f0acd
--- /dev/null
+++ b/net/p5-SOAP-Transport-TCP/distinfo
@@ -0,0 +1,2 @@
+SHA256 (SOAP-Transport-TCP-0.715.tar.gz) = cb30da9bd4ed726c20272d5d8391d47db54e931c670f0bc8f278040472f3ab40
+SIZE (SOAP-Transport-TCP-0.715.tar.gz) = 44554
diff --git a/net/p5-SOAP-Transport-TCP/pkg-descr b/net/p5-SOAP-Transport-TCP/pkg-descr
new file mode 100644
index 000000000000..d2fcf0154af4
--- /dev/null
+++ b/net/p5-SOAP-Transport-TCP/pkg-descr
@@ -0,0 +1,10 @@
+The classes provided by this module implement direct TCP/IP communications
+methods for both clients and servers. The connections don't use HTTP or any
+other higher-level protocol. These classes are selected when the client or
+server object being created uses an endpoint URI that starts with tcp://. Both
+client and server classes support using Secure Socket Layer if it is available.
+If any of the parameters to a new method from either of the classes begins with
+SSL_ (such as SSL_server in place of Server), the class attempts to load the
+IO::Socket::SSL package and use it to create socket objects.
+
+WWW: http://search.cpan.org/dist/SOAP-Transport-TCP/
diff --git a/net/p5-SOAP-Transport-TCP/pkg-plist b/net/p5-SOAP-Transport-TCP/pkg-plist
new file mode 100644
index 000000000000..d0a3fa3d9a53
--- /dev/null
+++ b/net/p5-SOAP-Transport-TCP/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/SOAP/Transport/TCP.pm
+@dirrmtry %%SITE_PERL%%/SOAP/Transport
+@dirrmtry %%SITE_PERL%%/SOAP