aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-07-14 21:17:21 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-07-14 21:17:21 +0000
commitbfa3958c83312f4c1cd3aa72db2f2d932648ba99 (patch)
tree045532534e1db412f1f596cdc2d983f42e70441a /net
parent9b087dd60f7fe2952b34f2fe25ae98ff2e6d54b9 (diff)
downloadports-bfa3958c83312f4c1cd3aa72db2f2d932648ba99.tar.gz
ports-bfa3958c83312f4c1cd3aa72db2f2d932648ba99.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/Makefile1
-rw-r--r--net/avahi-app/Makefile60
-rw-r--r--net/avahi-app/distinfo4
-rw-r--r--net/avahi-app/files/patch-avahi-daemon_Makefile.in16
-rw-r--r--net/avahi-app/files/patch-avahi-utils_Makefile.in14
-rw-r--r--net/avahi-app/files/patch-check_nss.c15
-rw-r--r--net/avahi-autoipd/Makefile7
-rw-r--r--net/avahi-gtk/Makefile15
-rw-r--r--net/avahi-gtk/pkg-plist2
-rw-r--r--net/avahi-gtk3/Makefile31
-rw-r--r--net/avahi-gtk3/pkg-descr3
-rw-r--r--net/avahi-gtk3/pkg-plist5
-rw-r--r--net/avahi-header/Makefile28
-rw-r--r--net/avahi-header/pkg-descr5
-rw-r--r--net/avahi-header/pkg-plist2
-rw-r--r--net/avahi-libdns/Makefile8
-rw-r--r--net/avahi-qt4/Makefile9
-rw-r--r--net/avahi-sharp/Makefile6
-rw-r--r--net/avahi/Makefile13
19 files changed, 135 insertions, 109 deletions
diff --git a/net/Makefile b/net/Makefile
index 4337133abfa0..08c08c0a485c 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -39,7 +39,6 @@
SUBDIR += avahi-autoipd
SUBDIR += avahi-gtk
SUBDIR += avahi-libdns
- SUBDIR += avahi-qt3
SUBDIR += avahi-qt4
SUBDIR += avahi-sharp
SUBDIR += babeld
diff --git a/net/avahi-app/Makefile b/net/avahi-app/Makefile
index 6388ea8012f6..1dafbf2b4eeb 100644
--- a/net/avahi-app/Makefile
+++ b/net/avahi-app/Makefile
@@ -1,14 +1,10 @@
-# New ports collection makefile for: avahi
-# Date created: 18 November 2005
-# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
-#
+# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/net/avahi-app/Makefile,v 1.17 2011/03/13 17:23:19 kwm Exp $
-#
+# $MCom: ports/net/avahi-app/Makefile,v 1.25 2012/09/01 23:02:11 mezz Exp $
PORTNAME= avahi
-PORTVERSION= 0.6.29
-PORTREVISION?= 3
+PORTVERSION= 0.6.31
+PORTREVISION?= 0
CATEGORIES?= net dns
MASTER_SITES= http://www.avahi.org/download/
PKGNAMESUFFIX?= -app
@@ -16,36 +12,36 @@ PKGNAMESUFFIX?= -app
MAINTAINER?= gnome@FreeBSD.org
COMMENT?= Service discovery on a local network
+AVAHI_SLAVE?= no
+
+.if ${AVAHI_SLAVE} != header
BUILD_DEPENDS?= g-ir-scanner:${PORTSDIR}/devel/gobject-introspection
-LIB_DEPENDS?= expat.6:${PORTSDIR}/textproc/expat2 \
+LIB_DEPENDS?= expat:${PORTSDIR}/textproc/expat2 \
daemon.0:${PORTSDIR}/devel/libdaemon \
- dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
- gdbm.4:${PORTSDIR}/databases/gdbm
+ dbus-glib-1:${PORTSDIR}/devel/dbus-glib \
+ gdbm:${PORTSDIR}/databases/gdbm
RUN_DEPENDS?= g-ir-scanner:${PORTSDIR}/devel/gobject-introspection
USERS?= ${PORTNAME}
GROUPS?= ${USERS}
-USE_GNOME?= gnomehack ltverhack glib20 intltool
-USES= gettext
+USE_GNOME= ltverhack glib20 intltool
+USES= gettext gmake pathfix
USE_GNOME_SUBR= yes
-USE_GMAKE= yes
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
-AVAHI_SLAVE?= no
CONFIGURE_ARGS?=--with-distro=freebsd \
--with-dbus-system-socket=unix:path=/var/run/dbus/system_bus_socket \
--disable-monodoc \
--disable-doxygen-doc \
--disable-doxygen-dot \
+ --disable-qt3 \
--localstatedir=/var \
--enable-compat-howl
-CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
- PTHREAD_LIBS="${PTHREAD_LIBS}"
CPPFLAGS+= -I${LOCALBASE}/include -DHAVE_KQUEUE
LDFLAGS+= -L${LOCALBASE}/lib
-.if ${AVAHI_SLAVE}=="no"
+.if ${AVAHI_SLAVE} == no
CONFLICTS= howl-[0-9]*
MAN1= avahi-browse.1 avahi-publish.1 avahi-resolve.1 avahi-set-host-name.1
@@ -62,47 +58,44 @@ DAEMON_CONFIG_FILES= hosts avahi-daemon.conf
.endif
USE_RC_SUBR=yes
+.endif # !avahi-header
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if ${AVAHI_SLAVE}=="autoipd"
+.if ${AVAHI_SLAVE} != header
+.if ${AVAHI_SLAVE} == autoipd
CONFIGURE_ARGS+=--enable-autoipd
.else
CONFIGURE_ARGS+=--disable-autoipd
.endif
-.if ${AVAHI_SLAVE}=="gtk"
+.if ${AVAHI_SLAVE} == gtk
CONFIGURE_ARGS+=--enable-gtk
.else
CONFIGURE_ARGS+=--disable-gtk
.endif
-.if ${AVAHI_SLAVE}=="gtk3"
+.if ${AVAHI_SLAVE} == gtk3
CONFIGURE_ARGS+=--enable-gtk3
.else
CONFIGURE_ARGS+=--disable-gtk3
.endif
-.if ${AVAHI_SLAVE}=="libdns"
+.if ${AVAHI_SLAVE} == libdns
CONFIGURE_ARGS+=--enable-compat-libdns_sd
.else
CONFIGURE_ARGS+=--disable-compat-libdns_sd
.endif
-.if ${AVAHI_SLAVE}=="python"
+.if ${AVAHI_SLAVE} == python
CONFIGURE_ARGS+=--enable-python
.else
CONFIGURE_ARGS+=--disable-python
.endif
-.if ${AVAHI_SLAVE}=="qt3"
-CONFIGURE_ARGS+=--enable-qt3
-.else
-CONFIGURE_ARGS+=--disable-qt3
-.endif
-.if ${AVAHI_SLAVE}=="qt4"
+.if ${AVAHI_SLAVE} == qt4
CONFIGURE_ARGS+=--enable-qt4 \
--disable-expat \
--disable-gdbm
.else
CONFIGURE_ARGS+=--disable-qt4
.endif
-.if ${AVAHI_SLAVE}=="sharp"
+.if ${AVAHI_SLAVE} == sharp
CONFIGURE_ARGS+=--enable-mono
.else
CONFIGURE_ARGS+=--disable-mono
@@ -132,6 +125,8 @@ avahi-post-patch:
${WRKSRC}/avahi-daemon/dbus-protocol.c
@${REINPLACE_CMD} -e 's|^_||g' \
${WRKSRC}/avahi-ui/*.desktop.in.in
+ @${REINPLACE_CMD} -e 's|am: install-avahiincludeHEADERS|am:|g' \
+ ${WRKSRC}/avahi-ui/Makefile.in
post-build: avahi-post-build
@@ -173,5 +168,6 @@ avahi-post-install:
${INSTALL_DATA} ${FILESDIR}/org.freedesktop.Avahi.service \
${LOCALBASE}/share/dbus-1/system-services
.endif
+.endif # avahi-header
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net/avahi-app/distinfo b/net/avahi-app/distinfo
index e0264b34bb6a..c476c7bd638f 100644
--- a/net/avahi-app/distinfo
+++ b/net/avahi-app/distinfo
@@ -1,2 +1,2 @@
-SHA256 (avahi-0.6.29.tar.gz) = 4eb1a6bdc93f1b245fc1b26ff6a79f5f958c1135c04bff60d36d374d98cc14d8
-SIZE (avahi-0.6.29.tar.gz) = 1244081
+SHA256 (avahi-0.6.31.tar.gz) = 8372719b24e2dd75de6f59bb1315e600db4fd092805bd1201ed0cb651a2dab48
+SIZE (avahi-0.6.31.tar.gz) = 1268686
diff --git a/net/avahi-app/files/patch-avahi-daemon_Makefile.in b/net/avahi-app/files/patch-avahi-daemon_Makefile.in
index 7f36a6f25df9..5f08d07c1387 100644
--- a/net/avahi-app/files/patch-avahi-daemon_Makefile.in
+++ b/net/avahi-app/files/patch-avahi-daemon_Makefile.in
@@ -1,5 +1,5 @@
---- avahi-daemon/Makefile.in.orig 2013-01-01 13:29:10.000000000 -0600
-+++ avahi-daemon/Makefile.in 2013-01-01 13:31:10.000000000 -0600
+--- avahi-daemon/Makefile.in.orig 2013-01-01 13:45:35.000000000 -0600
++++ avahi-daemon/Makefile.in 2013-01-01 13:47:30.000000000 -0600
@@ -69,7 +69,7 @@
@ENABLE_CHROOT_TRUE@@HAVE_LIBDAEMON_TRUE@@HAVE_XML_TRUE@ caps.c caps.h
@@ -9,18 +9,18 @@
@HAVE_DBUS_TRUE@@HAVE_LIBDAEMON_TRUE@@HAVE_XML_TRUE@am__append_5 = \
@HAVE_DBUS_TRUE@@HAVE_LIBDAEMON_TRUE@@HAVE_XML_TRUE@ dbus-protocol.c dbus-protocol.h \
@HAVE_DBUS_TRUE@@HAVE_LIBDAEMON_TRUE@@HAVE_XML_TRUE@ dbus-util.c dbus-util.h \
-@@ -682,7 +682,7 @@
+@@ -688,7 +688,7 @@
rm -f $$list
- avahi-daemon$(EXEEXT): $(avahi_daemon_OBJECTS) $(avahi_daemon_DEPENDENCIES)
+ avahi-daemon$(EXEEXT): $(avahi_daemon_OBJECTS) $(avahi_daemon_DEPENDENCIES) $(EXTRA_avahi_daemon_DEPENDENCIES)
@rm -f avahi-daemon$(EXEEXT)
- $(AM_V_CCLD)$(avahi_daemon_LINK) $(avahi_daemon_OBJECTS) $(avahi_daemon_LDADD) $(LIBS)
+ $(AM_V_CCLD)$(avahi_daemon_LINK) $(avahi_daemon_OBJECTS) $(avahi_daemon_LDADD) $(LIBS) $(INTLLIBS)
- ini-file-parser-test$(EXEEXT): $(ini_file_parser_test_OBJECTS) $(ini_file_parser_test_DEPENDENCIES)
+ ini-file-parser-test$(EXEEXT): $(ini_file_parser_test_OBJECTS) $(ini_file_parser_test_DEPENDENCIES) $(EXTRA_ini_file_parser_test_DEPENDENCIES)
@rm -f ini-file-parser-test$(EXEEXT)
$(AM_V_CCLD)$(ini_file_parser_test_LINK) $(ini_file_parser_test_OBJECTS) $(ini_file_parser_test_LDADD) $(LIBS)
-@@ -1283,17 +1283,17 @@
- echo " ( cd '$(DESTDIR)$(servicedir)' && rm -f" $$files ")"; \
- cd "$(DESTDIR)$(servicedir)" && rm -f $$files
+@@ -1222,17 +1222,17 @@
+ files=`for p in $$list; do echo $$p; done | sed -e 's|^.*/||'`; \
+ dir='$(DESTDIR)$(servicedir)'; $(am__uninstall_files_from_dir)
install-pkgsysconfDATA: $(pkgsysconf_DATA)
- @$(NORMAL_INSTALL)
- test -z "$(pkgsysconfdir)" || $(MKDIR_P) "$(DESTDIR)$(pkgsysconfdir)"
diff --git a/net/avahi-app/files/patch-avahi-utils_Makefile.in b/net/avahi-app/files/patch-avahi-utils_Makefile.in
index 90bc06015bf6..49b05ea3cf29 100644
--- a/net/avahi-app/files/patch-avahi-utils_Makefile.in
+++ b/net/avahi-app/files/patch-avahi-utils_Makefile.in
@@ -1,20 +1,20 @@
---- avahi-utils/Makefile.in.orig 2010-07-24 19:59:10.000000000 -0400
-+++ avahi-utils/Makefile.in 2010-07-24 20:00:07.000000000 -0400
-@@ -513,16 +513,16 @@ clean-binPROGRAMS:
+--- avahi-utils/Makefile.in.orig 2012-07-09 20:07:19.000000000 +0200
++++ avahi-utils/Makefile.in 2012-07-09 20:10:46.000000000 +0200
+@@ -518,16 +518,16 @@
rm -f $$list
- avahi-browse$(EXEEXT): $(avahi_browse_OBJECTS) $(avahi_browse_DEPENDENCIES)
+ avahi-browse$(EXEEXT): $(avahi_browse_OBJECTS) $(avahi_browse_DEPENDENCIES) $(EXTRA_avahi_browse_DEPENDENCIES)
@rm -f avahi-browse$(EXEEXT)
- $(AM_V_CCLD)$(avahi_browse_LINK) $(avahi_browse_OBJECTS) $(avahi_browse_LDADD) $(LIBS)
+ $(AM_V_CCLD)$(avahi_browse_LINK) $(avahi_browse_OBJECTS) $(avahi_browse_LDADD) $(LIBS) $(INTLLIBS)
- avahi-publish$(EXEEXT): $(avahi_publish_OBJECTS) $(avahi_publish_DEPENDENCIES)
+ avahi-publish$(EXEEXT): $(avahi_publish_OBJECTS) $(avahi_publish_DEPENDENCIES) $(EXTRA_avahi_publish_DEPENDENCIES)
@rm -f avahi-publish$(EXEEXT)
- $(AM_V_CCLD)$(avahi_publish_LINK) $(avahi_publish_OBJECTS) $(avahi_publish_LDADD) $(LIBS)
+ $(AM_V_CCLD)$(avahi_publish_LINK) $(avahi_publish_OBJECTS) $(avahi_publish_LDADD) $(LIBS) $(INTLLIBS)
- avahi-resolve$(EXEEXT): $(avahi_resolve_OBJECTS) $(avahi_resolve_DEPENDENCIES)
+ avahi-resolve$(EXEEXT): $(avahi_resolve_OBJECTS) $(avahi_resolve_DEPENDENCIES) $(EXTRA_avahi_resolve_DEPENDENCIES)
@rm -f avahi-resolve$(EXEEXT)
- $(AM_V_CCLD)$(avahi_resolve_LINK) $(avahi_resolve_OBJECTS) $(avahi_resolve_LDADD) $(LIBS)
+ $(AM_V_CCLD)$(avahi_resolve_LINK) $(avahi_resolve_OBJECTS) $(avahi_resolve_LDADD) $(LIBS) $(INTLLIBS)
- avahi-set-host-name$(EXEEXT): $(avahi_set_host_name_OBJECTS) $(avahi_set_host_name_DEPENDENCIES)
+ avahi-set-host-name$(EXEEXT): $(avahi_set_host_name_OBJECTS) $(avahi_set_host_name_DEPENDENCIES) $(EXTRA_avahi_set_host_name_DEPENDENCIES)
@rm -f avahi-set-host-name$(EXEEXT)
- $(AM_V_CCLD)$(avahi_set_host_name_LINK) $(avahi_set_host_name_OBJECTS) $(avahi_set_host_name_LDADD) $(LIBS)
+ $(AM_V_CCLD)$(avahi_set_host_name_LINK) $(avahi_set_host_name_OBJECTS) $(avahi_set_host_name_LDADD) $(LIBS) $(INTLLIBS)
diff --git a/net/avahi-app/files/patch-check_nss.c b/net/avahi-app/files/patch-check_nss.c
deleted file mode 100644
index 3f1360d83dbc..000000000000
--- a/net/avahi-app/files/patch-check_nss.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- avahi-client/check-nss.c.orig 2010-06-29 12:30:33.000000000 +0900
-+++ avahi-client/check-nss.c 2012-03-13 14:32:57.000000000 +0900
-@@ -33,9 +33,9 @@
-
- #ifdef HAVE_DLOPEN
- static const char * const libs[] = {
-- "libnss_mdns.so.2",
-- "libnss_mdns4.so.2",
-- "libnss_mdns6.so.2",
-+ "nss_mdns.so",
-+ "nss_mdns4.so",
-+ "nss_mdns6.so",
- NULL };
-
- const char * const *l;
diff --git a/net/avahi-autoipd/Makefile b/net/avahi-autoipd/Makefile
index 058b3c008eff..3559b495f03d 100644
--- a/net/avahi-autoipd/Makefile
+++ b/net/avahi-autoipd/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: avahi-autoipd
-# Date created: 31 July 2007
-# Whom: Michael Johnson <ahze@FreeBSD.org>
-#
+# Created by: Michael Johnson <ahze@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/net/avahi-autoipd/Makefile,v 1.1 2007/07/31 18:24:12 ahze Exp $
-#
PORTREVISION= 0
CATEGORIES= net
@@ -27,6 +23,5 @@ PLIST= ${.CURDIR}/pkg-plist
AVAHI_SLAVE= autoipd
MAN8= avahi-autoipd.8
-USE_GNOME= gnomehack ltverhack intltool
.include "${MASTERDIR}/Makefile"
diff --git a/net/avahi-gtk/Makefile b/net/avahi-gtk/Makefile
index 84335c305091..3e2e7f623171 100644
--- a/net/avahi-gtk/Makefile
+++ b/net/avahi-gtk/Makefile
@@ -1,19 +1,16 @@
-# New ports collection makefile for: avahi-gtk
-# Date created: 31 July 2007
-# Whom: Michael Johnson <ahze@FreeBSD.org>
-#
+# Created by: Michael Johnson <ahze@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/net/avahi-gtk/Makefile,v 1.2 2007/09/12 12:41:45 ahze Exp $
-#
+# $MCom: ports/net/avahi-gtk/Makefile,v 1.9 2012/07/09 18:22:19 kwm Exp $
-PORTREVISION= 2
+PORTREVISION= 0
CATEGORIES= net
PKGNAMESUFFIX= -gtk
MAINTAINER= gnome@FreeBSD.org
COMMENT= Gtk+ tools and bindings to the Avahi mDNS system
-LIB_DEPENDS= avahi-common.3:${PORTSDIR}/net/avahi-app
+LIB_DEPENDS= avahi-common:${PORTSDIR}/net/avahi-app
+RUN_DEPENDS= avahi-header>=0.6:${PORTSDIR}/net/avahi-header
MASTERDIR= ${.CURDIR}/../avahi-app
BUILD_WRKSRC= ${WRKSRC}/avahi-ui
@@ -27,7 +24,7 @@ AVAHI_PKGCONFIG=avahi-ui.pc
MAN1+= bssh.1
MLINKS+= bssh.1 bvnc.1 \
bssh.1 bshell.1
-USE_GNOME= gnomehack ltverhack intltool libglade2
+USE_GNOME+= libglade2
post-build:
@(cd ${WRKSRC}/avahi-discover-standalone; \
diff --git a/net/avahi-gtk/pkg-plist b/net/avahi-gtk/pkg-plist
index bba24f81d354..e545a05d83af 100644
--- a/net/avahi-gtk/pkg-plist
+++ b/net/avahi-gtk/pkg-plist
@@ -2,7 +2,6 @@ bin/avahi-discover-standalone
bin/bshell
bin/bssh
bin/bvnc
-include/avahi-ui/avahi-ui.h
lib/libavahi-ui.a
lib/libavahi-ui.la
lib/libavahi-ui.so
@@ -13,4 +12,3 @@ share/applications/bvnc.desktop
%%DATADIR%%/interfaces/avahi-discover.ui
@dirrm %%DATADIR%%/interfaces
@dirrmtry share/applications
-@dirrm include/avahi-ui
diff --git a/net/avahi-gtk3/Makefile b/net/avahi-gtk3/Makefile
new file mode 100644
index 000000000000..b260b985192f
--- /dev/null
+++ b/net/avahi-gtk3/Makefile
@@ -0,0 +1,31 @@
+# Created by: Michael Johnson <ahze@FreeBSD.org>
+# $FreeBSD$
+
+PORTREVISION= 0
+CATEGORIES= net
+PKGNAMESUFFIX= -gtk3
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Gtk+ 3 library to the Avahi mDNS system
+
+LIB_DEPENDS= avahi-common:${PORTSDIR}/net/avahi-app
+RUN_DEPENDS= avahi-header>=0.6:${PORTSDIR}/net/avahi-header
+
+MASTERDIR= ${.CURDIR}/../avahi-app
+BUILD_WRKSRC= ${WRKSRC}/avahi-ui
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+DESCR= ${.CURDIR}/pkg-descr
+PLIST= ${.CURDIR}/pkg-plist
+
+AVAHI_SLAVE= gtk3
+AVAHI_PKGCONFIG=avahi-ui-gtk3.pc
+
+USE_GNOME+= gtk30
+
+do-build:
+ @(cd ${WRKSRC}/avahi-ui; ${GMAKE} libavahi-ui-gtk3.la)
+
+do-install:
+ @(cd ${WRKSRC}/avahi-ui; ${GMAKE} install-libLTLIBRARIES)
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net/avahi-gtk3/pkg-descr b/net/avahi-gtk3/pkg-descr
new file mode 100644
index 000000000000..a1980414528b
--- /dev/null
+++ b/net/avahi-gtk3/pkg-descr
@@ -0,0 +1,3 @@
+Gtk+ tools and bindings to the avahi mDNS service discovery system.
+
+WWW: http://www.avahi.org/
diff --git a/net/avahi-gtk3/pkg-plist b/net/avahi-gtk3/pkg-plist
new file mode 100644
index 000000000000..08125fa552f3
--- /dev/null
+++ b/net/avahi-gtk3/pkg-plist
@@ -0,0 +1,5 @@
+lib/libavahi-ui-gtk3.a
+lib/libavahi-ui-gtk3.la
+lib/libavahi-ui-gtk3.so
+lib/libavahi-ui-gtk3.so.0
+libdata/pkgconfig/avahi-ui-gtk3.pc
diff --git a/net/avahi-header/Makefile b/net/avahi-header/Makefile
new file mode 100644
index 000000000000..d69e14091aa5
--- /dev/null
+++ b/net/avahi-header/Makefile
@@ -0,0 +1,28 @@
+# Created by: Michael Johnson <ahze@FreeBSD.org>
+# $FreeBSD$
+# $MCom: ports/net/avahi-header/Makefile,v 1.4 2012/07/09 18:22:19 kwm Exp $
+
+PORTREVISION= 0
+CATEGORIES= net
+PKGNAMESUFFIX= -header
+
+COMMENT= Install an avahi-gtk* header to avoid conflict
+
+CONFLICT= avahi-gtk-0.6.[0-2]*
+
+MASTERDIR= ${.CURDIR}/../avahi-app
+BUILD_WRKSRC= ${WRKSRC}/avahi-ui
+INSTALL_WRKSRC= ${BUILD_WRKSRC}
+DESCR= ${.CURDIR}/pkg-descr
+PLIST= ${.CURDIR}/pkg-plist
+
+AVAHI_SLAVE= header
+
+NO_BUILD= yes
+
+do-install:
+ ${MKDIR} ${PREFIX}/include/avahi-ui
+ ${INSTALL_DATA} ${BUILD_WRKSRC}/avahi-ui.h \
+ ${PREFIX}/include/avahi-ui/
+
+.include "${MASTERDIR}/Makefile"
diff --git a/net/avahi-header/pkg-descr b/net/avahi-header/pkg-descr
new file mode 100644
index 000000000000..e83ee0ebb50a
--- /dev/null
+++ b/net/avahi-header/pkg-descr
@@ -0,0 +1,5 @@
+The net/avahi-gtk and net/avahi-gtk3 install same header, avahi-ui.h. To
+avoid both ports to get conflict with the each others. Avoid both ports
+to install avahi-ui.h then have both ports to depend on here.
+
+WWW: http://www.avahi.org/
diff --git a/net/avahi-header/pkg-plist b/net/avahi-header/pkg-plist
new file mode 100644
index 000000000000..07fff5e6970a
--- /dev/null
+++ b/net/avahi-header/pkg-plist
@@ -0,0 +1,2 @@
+include/avahi-ui/avahi-ui.h
+@dirrm include/avahi-ui
diff --git a/net/avahi-libdns/Makefile b/net/avahi-libdns/Makefile
index b7121c4016c8..f645a6303ebd 100644
--- a/net/avahi-libdns/Makefile
+++ b/net/avahi-libdns/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: avahi-libdns
-# Date created: 31 July 2007
-# Whom: Michael Johnson <ahze@FreeBSD.org>
-#
+# Created by: Michael Johnson <ahze@FreeBSD.org>
# $FreeBSD$
-#
PORTREVISION= 0
CATEGORIES= net
@@ -12,7 +8,7 @@ PKGNAMESUFFIX= -libdns
MAINTAINER= gnome@FreeBSD.org
COMMENT= mDNSResponder compatibility from Avahi
-LIB_DEPENDS= avahi-common.3:${PORTSDIR}/net/avahi-app
+LIB_DEPENDS= avahi-common:${PORTSDIR}/net/avahi-app
MASTERDIR= ${.CURDIR}/../avahi-app
BUILD_WRKSRC= ${WRKSRC}/avahi-compat-libdns_sd
diff --git a/net/avahi-qt4/Makefile b/net/avahi-qt4/Makefile
index d03a7e4c50fe..8f0d00842afd 100644
--- a/net/avahi-qt4/Makefile
+++ b/net/avahi-qt4/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: avahi-qt4
-# Date created: 26 October 2007
-# Whom: Michael Johnson <ahze@FreeBSD.org
-#
+# Created by: Michael Johnson <ahze@FreeBSD.org
# $FreeBSD$
-#
PORTREVISION= 0
CATEGORIES= net
@@ -12,7 +8,7 @@ PKGNAMESUFFIX= -qt4
MAINTAINER= gnome@FreeBSD.org
COMMENT= Qt 4 bindings to the Avahi mDNS system
-LIB_DEPENDS= avahi-common.3:${PORTSDIR}/net/avahi-app
+LIB_DEPENDS= avahi-common:${PORTSDIR}/net/avahi-app
MASTERDIR= ${.CURDIR}/../avahi-app
BUILD_WRKSRC= ${WRKSRC}/avahi-qt
@@ -21,7 +17,6 @@ DESCR= ${.CURDIR}/pkg-descr
PLIST= ${.CURDIR}/pkg-plist
AVAHI_SLAVE= qt4
-USE_GNOME= gnomehack ltverhack intltool
USE_QT4= corelib moc_build
AVAHI_PKGCONFIG= avahi-qt4.pc
diff --git a/net/avahi-sharp/Makefile b/net/avahi-sharp/Makefile
index 9b63a8a6b4f0..ad6cd9fc66de 100644
--- a/net/avahi-sharp/Makefile
+++ b/net/avahi-sharp/Makefile
@@ -1,10 +1,6 @@
-# New ports collection makefile for: avahi-sharp
-# Date Created: 20041011
-# Whom: Tom McLaughlin <tmclaugh@FreeBSD.org>
-#
+# Created by: Tom McLaughlin <tmclaugh@FreeBSD.org>
# $FreeBSD$
# $Id: Makefile,v 1.2 2006/02/15 19:15:40 tmclau02 Exp $
-#
PORTREVISION= 0
CATEGORIES= net dns
diff --git a/net/avahi/Makefile b/net/avahi/Makefile
index e262da38c1c1..7576d466dcb8 100644
--- a/net/avahi/Makefile
+++ b/net/avahi/Makefile
@@ -3,8 +3,8 @@
# $MCom: ports/net/avahi/Makefile,v 1.30 2011/03/13 17:23:19 kwm Exp $
PORTNAME= avahi
-PORTVERSION= 0.6.29
-PORTREVISION?= 1
+PORTVERSION= 0.6.31
+PORTREVISION?= 0
CATEGORIES?= net dns
MASTER_SITES= # empty
DISTFILES= # empty
@@ -14,14 +14,13 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT= The "meta-port" for the Avahi service discovery suite
RUN_DEPENDS= avahi-resolve:${PORTSDIR}/net/avahi-app \
- avahi-app>=0.6.20_2:${PORTSDIR}/net/avahi-app
+ avahi-app>=0.6.31:${PORTSDIR}/net/avahi-app
-OPTIONS_DEFINE= AUTOIPD GTK LIBDNS MONO QT3 QT4 PYTHON
+OPTIONS_DEFINE= AUTOIPD GTK LIBDNS MONO QT4 PYTHON
OPTIONS_DEFAULT=AUTOIPD GTK LIBDNS
AUTOIPD_DESC= IPv4LL network address configuration daemon
GTK_DESC= Gtk+ tools and bindings
LIBDNS_DESC= Apple's mDNSResponder compatibility library
-QT3_DESC= Qt 3 toolkit
NO_BUILD= yes
@@ -43,10 +42,6 @@ RUN_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/avahi-compat-libdns_sd.pc:${PORTSDI
RUN_DEPENDS+= ${LOCALBASE}/lib/mono/avahi-sharp/avahi-sharp.dll:${PORTSDIR}/net/avahi-sharp
.endif
-.if ${PORT_OPTIONS:MQT3}
-RUN_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/avahi-qt3.pc:${PORTSDIR}/net/avahi-qt3
-.endif
-
.if ${PORT_OPTIONS:MQT4}
RUN_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/avahi-qt4.pc:${PORTSDIR}/net/avahi-qt4
.endif