aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-11-08 14:37:33 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-11-08 14:37:33 +0000
commitd6ba76a311536f939bce998ee74ed4622e6604c5 (patch)
tree70172e120dec51873bd82013c08511957c78e1d8 /net
parent791ddc4d73cf4faf1f16239faacca30b5aa9d0a5 (diff)
downloadports-d6ba76a311536f939bce998ee74ed4622e6604c5.tar.gz
ports-d6ba76a311536f939bce998ee74ed4622e6604c5.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/owncloud-csync/Makefile21
-rw-r--r--net/owncloud-csync/distinfo4
-rw-r--r--net/owncloud-csync/pkg-plist2
3 files changed, 19 insertions, 8 deletions
diff --git a/net/owncloud-csync/Makefile b/net/owncloud-csync/Makefile
index c8f38ef9c02a..4f0902381743 100644
--- a/net/owncloud-csync/Makefile
+++ b/net/owncloud-csync/Makefile
@@ -2,19 +2,19 @@
# $FreeBSD$
PORTNAME= owncloud-csync
-PORTVERSION= 0.90.2
+PORTVERSION= 0.90.4
CATEGORIES= net kde
MASTER_SITES= http://download.owncloud.com/download/
DISTNAME= ocsync-${PORTVERSION}
MAINTAINER= 6yearold@gmail.com
-COMMENT= csync fork for Owncloud
+COMMENT= Csync fork for Owncloud
LICENSE= GPLv2
LIB_DEPENDS= libiniparser.so:${PORTSDIR}/devel/iniparser \
libsmbclient.so:${PORTSDIR}/net/samba-libsmbclient \
- libssh.so.4.2.2:${PORTSDIR}/security/libssh \
+ libssh.so.4:${PORTSDIR}/security/libssh \
libneon.so:${PORTSDIR}/www/neon29
USES= cmake:outsource iconv pkgconfig
@@ -25,7 +25,18 @@ CMAKE_ARGS+= -DUNIT_TESTING=NO \
USE_LDCONFIG= yes
-DOCSDIR= ${LOCALBASE}/share/doc/ocsync
-ETCDIR= ${LOCALBASE}/etc/ocsync
+DOCSDIR= ${PREFIX}/share/doc/ocsync
+ETCDIR= ${PREFIX}/etc/ocsync
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
+.if ! ${PORT_OPTIONS:MDOCS}
+BUILD_DEPENDS+= asciidoc:${PORTSDIR}/textproc/asciidoc
+
+post-patch:
+ @${REINPLACE_CMD} -e 's/^add_subdirectory(doc)//' ${WRKSRC}/CMakeLists.txt
+.endif
.include <bsd.port.mk>
diff --git a/net/owncloud-csync/distinfo b/net/owncloud-csync/distinfo
index 1cd5ec6160d5..814b86d708de 100644
--- a/net/owncloud-csync/distinfo
+++ b/net/owncloud-csync/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ocsync-0.90.2.tar.bz2) = 91359c7934cf23b5ac51f9cc329f6a2f8e7cb8a47d13619220cadf917f702a05
-SIZE (ocsync-0.90.2.tar.bz2) = 4630185
+SHA256 (ocsync-0.90.4.tar.bz2) = f2146577c977dc82a24e0baf84f3970efc3b004f2730669aae3816f48ff15728
+SIZE (ocsync-0.90.4.tar.bz2) = 4630698
diff --git a/net/owncloud-csync/pkg-plist b/net/owncloud-csync/pkg-plist
index d6dacdb8238d..b272a4771fae 100644
--- a/net/owncloud-csync/pkg-plist
+++ b/net/owncloud-csync/pkg-plist
@@ -15,7 +15,7 @@ lib/libocsync.so.0.2.1
lib/ocsync-0/ocsync_owncloud.so
lib/ocsync-0/ocsync_sftp.so
lib/ocsync-0/ocsync_smb.so
-man/man1/ocsync.1.gz
+%%PORTDOCS%%man/man1/ocsync.1.gz
%%PORTDOCS%%%%DOCSDIR%%/userguide/csync.html
%%PORTDOCS%%%%DOCSDIR%%/userguide/images/icons/README
%%PORTDOCS%%%%DOCSDIR%%/userguide/images/icons/callouts/1.png