aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-01-03 18:12:13 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-01-03 18:12:13 +0000
commitd83ff1e42e0e38fe6e33ab4d29f2bbbb5f16237e (patch)
tree1d4e886062c5321c028bc93a38a1f5524414637f /net
parent08de97af63bd102fac562329128cc3ee8140c375 (diff)
downloadports-d83ff1e42e0e38fe6e33ab4d29f2bbbb5f16237e.tar.gz
ports-d83ff1e42e0e38fe6e33ab4d29f2bbbb5f16237e.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/dgd/Makefile5
-rw-r--r--net/dhcpd/Makefile2
-rw-r--r--net/google-daemon/Makefile2
-rw-r--r--net/google-startup-scripts/Makefile2
-rw-r--r--net/xorp/Makefile2
5 files changed, 6 insertions, 7 deletions
diff --git a/net/dgd/Makefile b/net/dgd/Makefile
index ad4ae8971126..c276abcb8557 100644
--- a/net/dgd/Makefile
+++ b/net/dgd/Makefile
@@ -21,9 +21,8 @@ USE_GITHUB= yes
GH_ACCOUNT= dworkin
DIST_SUBDIR= dgd
-BASE_WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-WRKSRC= ${BASE_WRKSRC}/src
-PATCH_WRKSRC= ${BASE_WRKSRC}
+WRKSRC_SUBDIR= src
+PATCH_WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
ALL_TARGET= install
MAKE_JOBS_UNSAFE= yes
MAKE_ENV+= EXTRA_DEFINES="${EXTRA_DEFINES}"
diff --git a/net/dhcpd/Makefile b/net/dhcpd/Makefile
index f2287de8729d..e1708a10e2f6 100644
--- a/net/dhcpd/Makefile
+++ b/net/dhcpd/Makefile
@@ -9,7 +9,7 @@ COMMENT= OpenBSD dhcp daemon
LICENSE= BSD3CLAUSE
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src/usr.sbin/${PORTNAME}
+WRKSRC_SUBDIR= src/usr.sbin/${PORTNAME}
USE_GITHUB= yes
GH_ACCOUNT= koue
diff --git a/net/google-daemon/Makefile b/net/google-daemon/Makefile
index e60d42dbede9..99581a7fe14f 100644
--- a/net/google-daemon/Makefile
+++ b/net/google-daemon/Makefile
@@ -18,7 +18,7 @@ USE_GITHUB= yes
GH_ACCOUNT= GoogleCloudPlatform
GH_PROJECT= compute-image-packages
USE_RC_SUBR= google-accounts-manager
-WRKSRC= ${WRKDIR}/${GH_PROJECT}-${PORTVERSION}/${PORTNAME}
+WRKSRC_SUBDIR= ${PORTNAME}
SHEBANG_FILES= usr/share/google/google_daemon/accounts.py \
usr/share/google/google_daemon/accounts_manager.py \
diff --git a/net/google-startup-scripts/Makefile b/net/google-startup-scripts/Makefile
index 95ac80f039f8..96ff715a4dac 100644
--- a/net/google-startup-scripts/Makefile
+++ b/net/google-startup-scripts/Makefile
@@ -19,7 +19,7 @@ USE_GITHUB= yes
GH_ACCOUNT= GoogleCloudPlatform
GH_PROJECT= compute-image-packages
USE_RC_SUBR= google-startup
-WRKSRC= ${WRKDIR}/${GH_PROJECT}-${PORTVERSION}/${PORTNAME}
+WRKSRC_SUBDIR= ${PORTNAME}
SHEBANG_FILES= usr/share/google/fetch_script \
usr/share/google/first-boot \
diff --git a/net/xorp/Makefile b/net/xorp/Makefile
index 40b3a920f5a9..ac69978fb54f 100644
--- a/net/xorp/Makefile
+++ b/net/xorp/Makefile
@@ -22,7 +22,7 @@ GH_ACCOUNT= greearb
GH_PROJECT= ${PORTNAME}.ct
SHEBANG_FILES= xrl/scripts/clnt-gen xrl/scripts/tgt-gen
python_OLD_CMD= .*python
-WRKSRC= ${WRKDIR}/${GH_PROJECT}-${DISTVERSIONPREFIX}${DISTVERSION}/${PORTNAME}
+WRKSRC_SUBDIR= ${PORTNAME}
MAKE_ARGS= prefix=${PREFIX} enable_boost=1
SUB_FILES= pkg-message
GROUPS= xorp