aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-06-30 11:03:33 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-06-30 11:03:33 +0000
commit9e6d837e8ea18e2c6f9f3d79f1cf597cc9ea8ecd (patch)
tree84de6e9f255e50e3eb747786e229e02fa8999fa5 /net
parent64cc7cc17af731bb16dc1469d2b962c175f90dfa (diff)
downloadports-9e6d837e8ea18e2c6f9f3d79f1cf597cc9ea8ecd.tar.gz
ports-9e6d837e8ea18e2c6f9f3d79f1cf597cc9ea8ecd.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/openldap23-server/Makefile10
-rw-r--r--net/openldap24-server/Makefile10
2 files changed, 20 insertions, 0 deletions
diff --git a/net/openldap23-server/Makefile b/net/openldap23-server/Makefile
index 585a9193c37a..86c200ad1de9 100644
--- a/net/openldap23-server/Makefile
+++ b/net/openldap23-server/Makefile
@@ -193,6 +193,14 @@ CONFIGURE_ARGS+= --enable-proxycache
CONFIGURE_ARGS+= --enable-aci
.endif
+.if defined(WITH_UNIQUE)
+CONFIGURE_ARGS+= --enable-unique
+.endif
+
+.if defined(WITH_PPOLICY)
+CONFIGURE_ARGS+= --enable-ppolicy
+.endif
+
.if defined(WITHOUT_BDB)
CONFIGURE_ARGS+= --disable-bdb \
--disable-hdb \
@@ -355,6 +363,8 @@ pre-everything::
@${ECHO} "WITH_DYNGROUP with Dynamic Group overlay"
@${ECHO} "WITH_PROXYCACHE with Proxy Cache overlay"
@${ECHO} "WITH_ACI with per-object ACIs (experimental)"
+ @${ECHO} "WITH_UNIQUE with attribute Uniqueness overlay"
+ @${ECHO} "WITH_PPOLICY with Password Policy overlay"
@${ECHO} "WITHOUT_DYNAMIC_BACKENDS build static backends"
.if defined(DFOSVERSION) || ${OSVERSION} >= 500038
@${ECHO} "WITH_RCORDER slapd(1) should start early in the boot process"
diff --git a/net/openldap24-server/Makefile b/net/openldap24-server/Makefile
index 585a9193c37a..86c200ad1de9 100644
--- a/net/openldap24-server/Makefile
+++ b/net/openldap24-server/Makefile
@@ -193,6 +193,14 @@ CONFIGURE_ARGS+= --enable-proxycache
CONFIGURE_ARGS+= --enable-aci
.endif
+.if defined(WITH_UNIQUE)
+CONFIGURE_ARGS+= --enable-unique
+.endif
+
+.if defined(WITH_PPOLICY)
+CONFIGURE_ARGS+= --enable-ppolicy
+.endif
+
.if defined(WITHOUT_BDB)
CONFIGURE_ARGS+= --disable-bdb \
--disable-hdb \
@@ -355,6 +363,8 @@ pre-everything::
@${ECHO} "WITH_DYNGROUP with Dynamic Group overlay"
@${ECHO} "WITH_PROXYCACHE with Proxy Cache overlay"
@${ECHO} "WITH_ACI with per-object ACIs (experimental)"
+ @${ECHO} "WITH_UNIQUE with attribute Uniqueness overlay"
+ @${ECHO} "WITH_PPOLICY with Password Policy overlay"
@${ECHO} "WITHOUT_DYNAMIC_BACKENDS build static backends"
.if defined(DFOSVERSION) || ${OSVERSION} >= 500038
@${ECHO} "WITH_RCORDER slapd(1) should start early in the boot process"