aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2009-02-22 21:49:51 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2009-02-22 21:49:51 +0000
commitf62edf2c38dea42973a418f7d604baa16fb894c0 (patch)
treee2ea77067b37a00c26a52bf7a8ef69c9a311cc0c /net
parenteed55a04f63ba9fd8706a4581e74c08bae15d93e (diff)
downloadports-f62edf2c38dea42973a418f7d604baa16fb894c0.tar.gz
ports-f62edf2c38dea42973a418f7d604baa16fb894c0.zip
Notes
Diffstat (limited to 'net')
-rw-r--r--net/easysoap/Makefile8
-rw-r--r--net/easysoap/distinfo6
-rw-r--r--net/easysoap/files/patch-include::SOAPDispatchHandler.h20
-rw-r--r--net/easysoap/files/patch-include::SOAPHashMap.h92
-rw-r--r--net/easysoap/files/patch-include::SOAPParameter.h11
-rw-r--r--net/easysoap/files/patch-src-Makefile.in10
-rw-r--r--net/easysoap/files/patch-src::XMLParser.cpp62
7 files changed, 15 insertions, 194 deletions
diff --git a/net/easysoap/Makefile b/net/easysoap/Makefile
index eba652439857..a1b9650b8f7c 100644
--- a/net/easysoap/Makefile
+++ b/net/easysoap/Makefile
@@ -6,14 +6,14 @@
#
PORTNAME= easysoap
-PORTVERSION= 0.6
+PORTVERSION= 0.8.0
PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
DISTNAME= EasySoap++-${PORTVERSION}
-MAINTAINER= gabriel_ambuehl@buz.ch
+MAINTAINER= ports@FreeBSD.org
COMMENT= C++ SOAP Library based on expat
LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
@@ -23,15 +23,11 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
USE_LDCONFIG= yes
-USE_GCC= 2.95
post-patch:
@${REINPLACE_CMD} -e 's|echo aout|echo elf|g' \
${WRKSRC}/configure
-pre-configure:
- @${ECHO_MSG} "CPPFLAGS=${CPPFLAGS} CXXFLAGS=${CXXFLAGS}"
-
post-install:
@${RM} -f ${PREFIX}/lib/libeasysoap.la
diff --git a/net/easysoap/distinfo b/net/easysoap/distinfo
index 97840e80d783..7187d62fdda8 100644
--- a/net/easysoap/distinfo
+++ b/net/easysoap/distinfo
@@ -1,3 +1,3 @@
-MD5 (EasySoap++-0.6.tar.gz) = 9b75efcaf71f615266281ff993ae04b6
-SHA256 (EasySoap++-0.6.tar.gz) = 9a17ab2da440914154d0c12a9eff5cb972f6e7e8f90cdf2566d6e26db56dbdf9
-SIZE (EasySoap++-0.6.tar.gz) = 273676
+MD5 (EasySoap++-0.8.0.tar.gz) = d2696c9d6f29ded18765639d02c45fc0
+SHA256 (EasySoap++-0.8.0.tar.gz) = 8d2534c00f35c9bdc90eb2637aafc6190a071383ec184315d3c4061065aa95b6
+SIZE (EasySoap++-0.8.0.tar.gz) = 483296
diff --git a/net/easysoap/files/patch-include::SOAPDispatchHandler.h b/net/easysoap/files/patch-include::SOAPDispatchHandler.h
deleted file mode 100644
index 865f32000bf5..000000000000
--- a/net/easysoap/files/patch-include::SOAPDispatchHandler.h
+++ /dev/null
@@ -1,20 +0,0 @@
---- include/easysoap/SOAPDispatchHandler.h.orig Thu Jun 26 10:06:51 2003
-+++ include/easysoap/SOAPDispatchHandler.h Thu Jun 26 10:07:35 2003
-@@ -56,7 +56,7 @@
- bool ExecuteMethod(const SOAPEnvelope& request, SOAPMethod& response)
- {
- const SOAPMethod& method = request.GetBody().GetMethod();
-- DispatchMap::Iterator i = m_dispatchMap.Find(method.GetName());
-+ typename DispatchMap::Iterator i = m_dispatchMap.Find(method.GetName());
- if (i)
- {
- T *target= GetTarget(request);
-@@ -100,7 +100,7 @@
-
- bool HandleHeader(const SOAPParameter& header, SOAPEnvelope& request, SOAPEnvelope& response)
- {
-- DispatchMap::Iterator i = m_dispatchMap.Find(header.GetName());
-+ typename DispatchMap::Iterator i = m_dispatchMap.Find(header.GetName());
-
- if (i)
- {
diff --git a/net/easysoap/files/patch-include::SOAPHashMap.h b/net/easysoap/files/patch-include::SOAPHashMap.h
deleted file mode 100644
index 7a1365d1afa2..000000000000
--- a/net/easysoap/files/patch-include::SOAPHashMap.h
+++ /dev/null
@@ -1,92 +0,0 @@
---- include/easysoap/SOAPHashMap.h.orig Thu Jun 26 09:58:31 2003
-+++ include/easysoap/SOAPHashMap.h Thu Jun 26 10:05:23 2003
-@@ -117,13 +117,13 @@
- {
- private:
- const SOAPHashMap *m_map;
-- Elements::Iterator m_index;
-+ typename Elements::Iterator m_index;
- HashElement *m_he;
-
- friend class SOAPHashMap<K,I,H,E>;
-
- // private constuctor that can only be called by SOAPHashMap
-- ForwardHashMapIterator(const SOAPHashMap *map, Elements::Iterator index)
-+ ForwardHashMapIterator(const SOAPHashMap *map, typename Elements::Iterator index)
- : m_map(map), m_index(index), m_he(0)
- {
- if (m_map)
-@@ -134,7 +134,7 @@
- }
- }
-
-- ForwardHashMapIterator(const SOAPHashMap *map, Elements::Iterator index, HashElement *he)
-+ ForwardHashMapIterator(const SOAPHashMap *map, typename Elements::Iterator index, HashElement *he)
- : m_map(map), m_index(index), m_he(he)
- {
- }
-@@ -366,8 +366,8 @@
- {
- Clear();
- Resize(r.GetNumBuckets());
-- SOAPHashMap<A,B,C,D>::Iterator e = r.End();
-- for (SOAPHashMap<A,B,C,D>::Iterator it = r.Begin(); it != e; ++it)
-+ typename SOAPHashMap<A,B,C,D>::Iterator e = r.End();
-+ for (typename SOAPHashMap<A,B,C,D>::Iterator it = r.Begin(); it != e; ++it)
- Add(it.Key(), it.Item());
- }
- return *this;
-@@ -397,7 +397,7 @@
- */
- Iterator Begin() const
- {
-- return Iterator(this, (Elements::Iterator)m_elements.Begin());
-+ return Iterator(this, (typename Elements::Iterator)m_elements.Begin());
- }
-
- /**
-@@ -407,7 +407,7 @@
- */
- Iterator End() const
- {
-- return Iterator(this, (Elements::Iterator)m_elements.End());
-+ return Iterator(this, (typename Elements::Iterator)m_elements.End());
- }
-
-
-@@ -491,7 +491,7 @@
- */
- void Clear()
- {
-- for (Elements::Iterator i = m_elements.Begin(); i != m_elements.End(); ++i)
-+ for (typename Elements::Iterator i = m_elements.Begin(); i != m_elements.End(); ++i)
- {
- HashElement *he = *i;
- while (he)
-@@ -512,7 +512,7 @@
- */
- void Empty()
- {
-- Elements::Iterator i;
-+ typename Elements::Iterator i;
- for (i = m_elements.Begin(); i != m_elements.End(); ++i)
- {
- HashElement *he = *i;
-@@ -588,7 +588,7 @@
- while (he)
- {
- if (he->m_hash == hash && equals(he->m_key, key))
-- return Iterator(this, (Elements::Iterator)m_elements.Begin() + index, he);
-+ return Iterator(this, (typename Elements::Iterator)m_elements.Begin() + index, he);
- he = he->m_next;
- }
- }
-@@ -603,7 +603,7 @@
-
- Elements newelements;
- newelements.Resize(newsize);
-- Elements::Iterator i;
-+ typename Elements::Iterator i;
-
- for (i = newelements.Begin(); i != newelements.End(); ++i)
- *i = 0;
diff --git a/net/easysoap/files/patch-include::SOAPParameter.h b/net/easysoap/files/patch-include::SOAPParameter.h
deleted file mode 100644
index 5e504f8c51de..000000000000
--- a/net/easysoap/files/patch-include::SOAPParameter.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- SOAPParameter.h.orig Thu Jun 26 09:18:02 2003
-+++ include/easysoap/SOAPParameter.h Thu Jun 26 09:18:19 2003
-@@ -165,7 +165,7 @@
- Data(const Data&);
- };
-
-- friend Data;
-+ friend class Data;
-
- Pool m_pool;
- SOAPParameter *m_parent;
diff --git a/net/easysoap/files/patch-src-Makefile.in b/net/easysoap/files/patch-src-Makefile.in
new file mode 100644
index 000000000000..390fd3e38d81
--- /dev/null
+++ b/net/easysoap/files/patch-src-Makefile.in
@@ -0,0 +1,10 @@
+--- src/Makefile.in.orig 2006-11-10 18:48:39.000000000 +0100
++++ src/Makefile.in 2009-02-22 13:04:06.000000000 +0100
+@@ -375,6 +375,7 @@
+ @list='$(lib_LIBRARIES)'; for p in $$list; do \
+ if test -f $$p; then \
+ p="`echo $$p | sed -e 's|^.*/||'`"; \
++ chmod u+w $(DESTDIR)$(libdir)/$$p; \
+ echo " $(RANLIB) $(DESTDIR)$(libdir)/$$p"; \
+ $(RANLIB) $(DESTDIR)$(libdir)/$$p; \
+ else :; fi; \
diff --git a/net/easysoap/files/patch-src::XMLParser.cpp b/net/easysoap/files/patch-src::XMLParser.cpp
deleted file mode 100644
index 30255f111562..000000000000
--- a/net/easysoap/files/patch-src::XMLParser.cpp
+++ /dev/null
@@ -1,62 +0,0 @@
---- src/XMLParser.cpp.orig Wed Nov 6 14:04:53 2002
-+++ src/XMLParser.cpp Wed Nov 6 14:11:19 2002
-@@ -46,7 +46,7 @@
- {
- if (m_parser)
- {
-- XML_ParserFree(m_parser);
-+ XML_ParserFree((XML_Parser) m_parser);
- m_parser = 0;
- }
- }
-@@ -56,27 +56,27 @@
- {
- FreeParser();
- m_parser = XML_ParserCreateNS(encoding, '#');
-- XML_SetElementHandler(m_parser,
-+ XML_SetElementHandler((XML_Parser) m_parser,
- XMLParser::_startElement,
- XMLParser::_endElement);
-
-- XML_SetCharacterDataHandler(m_parser,
-+ XML_SetCharacterDataHandler((XML_Parser) m_parser,
- XMLParser::_characterData);
-
-- XML_SetStartNamespaceDeclHandler(m_parser,
-+ XML_SetStartNamespaceDeclHandler((XML_Parser) m_parser,
- XMLParser::_startNamespace);
-
-- XML_SetEndNamespaceDeclHandler(m_parser,
-+ XML_SetEndNamespaceDeclHandler((XML_Parser) m_parser,
- XMLParser::_endNamespace);
-
-- XML_SetUserData(m_parser, this);
-+ XML_SetUserData((XML_Parser) m_parser, this);
- }
-
- void *
- XMLParser::GetParseBuffer(int size)
- {
- if (m_parser)
-- return XML_GetBuffer(m_parser, size);
-+ return XML_GetBuffer((XML_Parser) m_parser, size);
- return 0;
- }
-
-@@ -84,7 +84,7 @@
- XMLParser::ParseBuffer(int size)
- {
- if (m_parser)
-- return XML_ParseBuffer(m_parser, size, size == 0) != 0;
-+ return XML_ParseBuffer((XML_Parser) m_parser, size, size == 0) != 0;
- return false;
- }
-
-@@ -92,7 +92,7 @@
- XMLParser::GetErrorMessage()
- {
- if (m_parser)
-- return XML_ErrorString(XML_GetErrorCode(m_parser));
-+ return XML_ErrorString(XML_GetErrorCode((XML_Parser) m_parser));
- return 0;
- }