aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2015-02-11 13:34:46 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2015-02-11 13:34:46 +0000
commite75dda17548cb1585e4a034e6e0069093e3904c1 (patch)
tree192a2930d82ab5b04878f098926c3f5f4d3fbdf8 /net
parent724c5bbc94eb098829ed52d28483538fb9791b5b (diff)
Notes
Diffstat (limited to 'net')
-rw-r--r--net/py-oauth2/Makefile21
-rw-r--r--net/py-oauth2/files/patch-setup.py3
-rw-r--r--net/py-oauth2/pkg-descr12
3 files changed, 24 insertions, 12 deletions
diff --git a/net/py-oauth2/Makefile b/net/py-oauth2/Makefile
index 21689461f2e4..0c44f743db89 100644
--- a/net/py-oauth2/Makefile
+++ b/net/py-oauth2/Makefile
@@ -3,20 +3,29 @@
PORTNAME= oauth2
PORTVERSION= 1.5.211
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= net python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= python@FreeBSD.org
COMMENT= Python library for OAuth version 1.0
LICENSE= MIT
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}httplib2>0:${PORTSDIR}/www/py-httplib2
-RUN_DEPENDS:= ${BUILD_DEPENDS}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}httplib2>0:${PORTSDIR}/www/py-httplib2
+TEST_DEPENDS:= ${RUN_DEPENDS} \
+ ${PYTHON_PKGNAMEPREFIX}coverage>0:${PORTSDIR}/devel/py-coverage \
+ ${PYTHON_PKGNAMEPREFIX}mock>0:${PORTSDIR}/devel/py-mock
-USES= python
-USE_PYTHON= distutils autoplist
+OPTIONS_DEFINE= TESTS
+TESTS_DESC= Install test suite requirements
+TESTS_BUILD_DEPENDS= ${TEST_DEPENDS}
+
+USES= python:-2.7
+USE_PYTHON= autoplist distutils
+
+regression-test: build
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
.include <bsd.port.mk>
diff --git a/net/py-oauth2/files/patch-setup.py b/net/py-oauth2/files/patch-setup.py
index 7b2ddda7d1d2..cde53c64734c 100644
--- a/net/py-oauth2/files/patch-setup.py
+++ b/net/py-oauth2/files/patch-setup.py
@@ -1,3 +1,6 @@
+# This package installs its 'test' module in site-packages/. Patch it out
+# so tests/ is excluded from installation
+
--- ./setup.py.orig 2014-03-15 23:48:44.604925965 +1100
+++ ./setup.py 2014-03-15 23:49:01.462781884 +1100
@@ -31,7 +31,7 @@
diff --git a/net/py-oauth2/pkg-descr b/net/py-oauth2/pkg-descr
index f4d870fa897d..3ef966ae2803 100644
--- a/net/py-oauth2/pkg-descr
+++ b/net/py-oauth2/pkg-descr
@@ -4,11 +4,11 @@ oauth.py code (see net/py-oauth).
A number of notable differences exist between this code and its
forefathers:
-* 100% unit test coverage.
-* The DataStore object has been completely ripped out.
-* Classes are no longer prefixed with OAuth.
-* The Request class now extends from dict.
-* The library is likely no longer compatible with Python 2.3.
-* The Client class works and extends from httplib2.
+ * 100% unit test coverage.
+ * The DataStore object has been completely ripped out.
+ * Classes are no longer prefixed with OAuth.
+ * The Request class now extends from dict.
+ * The library is likely no longer compatible with Python 2.3.
+ * The Client class works and extends from httplib2.
WWW: http://github.com/simplegeo/python-oauth2