aboutsummaryrefslogtreecommitdiff
path: root/news/c-nocem
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2013-12-01 18:33:26 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2013-12-01 18:33:26 +0000
commit8e450647cbf70db1254aae34fe9274253ffac626 (patch)
tree2d345ba82169235e815e6cc979f836e609fac7fb /news/c-nocem
parent80399d5d1a0b4e74bbe3610afc8d402864a6cf3c (diff)
downloadports-8e450647cbf70db1254aae34fe9274253ffac626.tar.gz
ports-8e450647cbf70db1254aae34fe9274253ffac626.zip
- use STAGEDIR
- USES=gmake
Notes
Notes: svn path=/head/; revision=335424
Diffstat (limited to 'news/c-nocem')
-rw-r--r--news/c-nocem/Makefile14
1 files changed, 10 insertions, 4 deletions
diff --git a/news/c-nocem/Makefile b/news/c-nocem/Makefile
index 5cd230578162..129096840a8b 100644
--- a/news/c-nocem/Makefile
+++ b/news/c-nocem/Makefile
@@ -15,13 +15,12 @@ BUILD_DEPENDS= ${CNEWSWRK}/conf/substitutions:${PORTSDIR}/${CNEWS_PORT}:configur
BUILD_DEPENDS+= ${LOCALBASE}/lib/libcnews.a:${PORTSDIR}/${CNEWS_PORT} \
gpgv:${PORTSDIR}/security/gnupg1
-NO_STAGE= yes
-
-USES= perl5
-USE_GMAKE= yes
+USES= perl5 gmake
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-cnews=${CNEWSWRK}
+CONFIGURE_ENV+= PERL=${PERL}
WRKSRC= ${WRKDIR}/c-nocem
+
PLIST_SUB+= NEWSBIN=${NEWSBIN:S=${PREFIX}/==}
PLIST_FILES= %%NEWSBIN%%/fastcancel %%NEWSBIN%%/c-nocem
@@ -31,4 +30,11 @@ CNEWS_PORT?= news/cnews
CNEWSWRK?= ${WRKDIRPREFIX}${.CURDIR}/../../${CNEWS_PORT}/work
NEWSBIN?= ${PREFIX}/libexec/cnews
+post-patch:
+ ${REINPLACE_CMD} -e 's|@newsbin@|${STAGEDIR}@newsbin@|' \
+ ${WRKSRC}/Makefile.in
+
+pre-install:
+ ${MKDIR} ${STAGEDIR}${NEWSBIN}
+
.include <bsd.port.mk>