aboutsummaryrefslogtreecommitdiff
path: root/news/gup
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1999-06-09 00:35:34 +0000
committerSteve Price <steve@FreeBSD.org>1999-06-09 00:35:34 +0000
commit88448775a3813a03cdfc8ce0af3761df3c84ce45 (patch)
tree0f6e367a41b4b60740507e0d55d76d321b954d20 /news/gup
parent933abeff0eecb51b4c6ae6918a03abac2480cd95 (diff)
downloadports-88448775a3813a03cdfc8ce0af3761df3c84ce45.tar.gz
ports-88448775a3813a03cdfc8ce0af3761df3c84ce45.zip
Initial import of gup version 0.4.
Allows remote sites to change their newsgroup subscriptions. PR: 11602 Submitted by: Denis Shaposhnikov <wizard@vlink.ru>
Notes
Notes: svn path=/head/; revision=19353
Diffstat (limited to 'news/gup')
-rw-r--r--news/gup/Makefile26
-rw-r--r--news/gup/distinfo1
-rw-r--r--news/gup/files/freebsd1
-rw-r--r--news/gup/files/patch-aa36
-rw-r--r--news/gup/files/patch-ab10
-rw-r--r--news/gup/files/patch-ac11
-rw-r--r--news/gup/pkg-comment1
-rw-r--r--news/gup/pkg-descr6
-rw-r--r--news/gup/pkg-plist1
9 files changed, 93 insertions, 0 deletions
diff --git a/news/gup/Makefile b/news/gup/Makefile
new file mode 100644
index 000000000000..533cc2fbf62e
--- /dev/null
+++ b/news/gup/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: gup
+# Version required: 0.4
+# Date created: 22 November 1998
+# Whom: Denis Shaposhnikov <wizard@vlink.ru>
+#
+# $Id$
+#
+
+DISTNAME= gup-0.4
+CATEGORIES= news
+MASTER_SITES= ftp://ftp.isc.org/isc/inn/unoff-contrib/
+
+MAINTAINER= wizard@vlink.ru
+
+WRKSRC= ${WRKDIR}/gup
+
+MAN1= gup.1
+
+do-configure:
+ @${CP} ${FILESDIR}/freebsd ${WRKSRC}/config
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/gup ${PREFIX}/libexec
+ ${INSTALL_MAN} ${WRKSRC}/gup.1 ${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/news/gup/distinfo b/news/gup/distinfo
new file mode 100644
index 000000000000..489913742059
--- /dev/null
+++ b/news/gup/distinfo
@@ -0,0 +1 @@
+MD5 (gup-0.4.tar.gz) = ecf8d543b1db408909f66f6e222b82ad
diff --git a/news/gup/files/freebsd b/news/gup/files/freebsd
new file mode 100644
index 000000000000..083aa901f6df
--- /dev/null
+++ b/news/gup/files/freebsd
@@ -0,0 +1 @@
+P_NO_FLAGS = -DNO_MALLOC_H
diff --git a/news/gup/files/patch-aa b/news/gup/files/patch-aa
new file mode 100644
index 000000000000..7a743430900b
--- /dev/null
+++ b/news/gup/files/patch-aa
@@ -0,0 +1,36 @@
+--- Makefile.orig Sun Nov 22 13:15:39 1998
++++ Makefile Sun Nov 22 13:18:46 1998
+@@ -8,7 +8,7 @@
+ # a working version for your system, please mail a copy back to the
+ # author so that others may benefit from your effort.
+
+-CONFIG = vanilla
++CONFIG = freebsd
+
+ # Destination directories for the executable and man page. Note that
+ # the executable is only used in a .forward so /usr/local/bin may
+@@ -28,20 +28,20 @@
+
+ # ACTIVE_PATH is the full pathname for your news active file. This
+ # file is used to validate newgroup names.
+-ACTIVE_PATH =
++ACTIVE_PATH = /var/db/news/active
+
+
+ # NEWSGROUPS_PATH is the fill pathname for your newsgroups file. This
+ # file is used to provide descriptions for each newsgroup.
+-NEWSGROUPS_PATH =
++NEWSGROUPS_PATH = /var/db/news/newsgroups
+
+ # BACKSTOP_MAILID is used if gup cannot find a FROM: or a REPLY-TO: or
+ # a valid site command, this is where the mail goes to.
+-BACKSTOP_MAILID = news
++BACKSTOP_MAILID = usenet
+
+ # MAIL_COMMAND is the mailer that accepts a mail with rfc822 headers and
+ # body from stdin.
+-MAIL_COMMAND = "/usr/lib/sendmail -t"
++MAIL_COMMAND = "/usr/sbin/sendmail -oi -t"
+
+ # With a command like "include alt.*" the resultant list is, long.
+ # LOG_MATCH_LIMIT, defines the upper bound on the number of pattern
diff --git a/news/gup/files/patch-ab b/news/gup/files/patch-ab
new file mode 100644
index 000000000000..4da3b19ed584
--- /dev/null
+++ b/news/gup/files/patch-ab
@@ -0,0 +1,10 @@
+--- rfc822.h.orig Sun May 9 12:53:24 1999
++++ rfc822.h Sun May 9 12:53:58 1999
+@@ -246,7 +246,6 @@
+ extern int errno;
+ extern int sys_nerr;
+ extern int optind;
+-extern char *sys_errlist[];
+ extern char **environ;
+ extern char *optarg;
+
diff --git a/news/gup/files/patch-ac b/news/gup/files/patch-ac
new file mode 100644
index 000000000000..a451304f8fcd
--- /dev/null
+++ b/news/gup/files/patch-ac
@@ -0,0 +1,11 @@
+--- main.mk.orig Mon Jun 7 23:37:43 1999
++++ main.mk Mon Jun 7 23:38:19 1999
+@@ -17,7 +17,7 @@
+ -DBACKSTOP_MAILID='"$(BACKSTOP_MAILID)"' \
+ -DLOG_MATCH_LIMIT=$(LOG_MATCH_LIMIT) -DUMASK=$(UMASK)
+
+-CFLAGS = $(P_CFLAGS) $(P_NO_FLAGS) $(P_USE_FLAGS) $(P_INCLUDES) \
++CFLAGS += $(P_CFLAGS) $(P_NO_FLAGS) $(P_USE_FLAGS) $(P_INCLUDES) \
+ $(DEFS) -DMAIL_COMMAND='"$(MAIL_COMMAND)"'
+
+ LDFLAGS = $(P_LDFLAGS) $(P_LIBS)
diff --git a/news/gup/pkg-comment b/news/gup/pkg-comment
new file mode 100644
index 000000000000..1579aa62da28
--- /dev/null
+++ b/news/gup/pkg-comment
@@ -0,0 +1 @@
+Allows remote sites to change their newsgroup subscriptions.
diff --git a/news/gup/pkg-descr b/news/gup/pkg-descr
new file mode 100644
index 000000000000..220bf687ad1c
--- /dev/null
+++ b/news/gup/pkg-descr
@@ -0,0 +1,6 @@
+Gup, the Group Update Program is a Unix mail-server that lets a remote
+site change their newsgroups subscription without requiring the
+intervention of the news administrator at the feed site.
+
+-- Denis Shaposhnikov
+wizard@vlink.ru
diff --git a/news/gup/pkg-plist b/news/gup/pkg-plist
new file mode 100644
index 000000000000..d5cc5280edc8
--- /dev/null
+++ b/news/gup/pkg-plist
@@ -0,0 +1 @@
+libexec/gup