aboutsummaryrefslogtreecommitdiff
path: root/news/husky-fidoconf-devel
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-10-26 15:46:18 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-10-26 15:46:18 +0000
commit93aada4d376989a32459c6915582dfe414703160 (patch)
treec05e8d94f4544a2092075674b29261eff7dfef93 /news/husky-fidoconf-devel
parentc88c89aca633b58b2a1d56be6827e979e2f382c2 (diff)
downloadports-93aada4d376989a32459c6915582dfe414703160.tar.gz
ports-93aada4d376989a32459c6915582dfe414703160.zip
Notes
Diffstat (limited to 'news/husky-fidoconf-devel')
-rw-r--r--news/husky-fidoconf-devel/Makefile49
-rw-r--r--news/husky-fidoconf-devel/distinfo2
-rw-r--r--news/husky-fidoconf-devel/files/patch-Makefile49
-rw-r--r--news/husky-fidoconf-devel/files/patch-doc::Makefile31
-rw-r--r--news/husky-fidoconf-devel/files/patch-makefile.inc10
-rw-r--r--news/husky-fidoconf-devel/files/patch-man::Makefile20
-rw-r--r--news/husky-fidoconf-devel/files/patch-man::linkedto.111
-rw-r--r--news/husky-fidoconf-devel/files/patch-tparser.c11
-rw-r--r--news/husky-fidoconf-devel/pkg-descr6
-rw-r--r--news/husky-fidoconf-devel/pkg-plist34
10 files changed, 223 insertions, 0 deletions
diff --git a/news/husky-fidoconf-devel/Makefile b/news/husky-fidoconf-devel/Makefile
new file mode 100644
index 000000000000..9e582ae22624
--- /dev/null
+++ b/news/husky-fidoconf-devel/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: husky-fidoconf-devel
+# Date created: 2005-10-26
+# Whom: Oleg Sharoiko <os@rsu.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fidoconf
+DISTVERSION= 1.4-rc4
+CATEGORIES= news mail
+DISTNAME= ${PORTNAME}-${DISTVERSION}-src
+
+MAINTAINER= os@rsu.ru
+COMMENT= Configuration library for Husky Fidosoft Project. Development version
+
+LIB_DEPENDS= smapi.2:${PORTSDIR}/news/husky-smapi-devel
+RUN_DEPENDS= ${LOCALBASE}/etc/fido/huskymak.cfg:${PORTSDIR}/news/husky-base-devel
+
+CONFLICTS= husky-fidoconf-[0-9]*
+
+INSTALLS_SHLIB= yes
+NO_FILTER_SHLIBS= yes
+INSTALL_TARGET= install install-man
+USE_REINPLACE= yes
+
+MAN1= dumpfcfg.1 fconf2.1 linked.1 linkedto.1 tparser.1
+MLINKS= fconf2.1 fconf2aquaed.1 \
+ fconf2.1 fconf2areasbbs.1 \
+ fconf2.1 fconf2binkd.1 \
+ fconf2.1 fconf2dir.1 \
+ fconf2.1 fconf2fidogate.1 \
+ fconf2.1 fconf2golded.1 \
+ fconf2.1 fconf2msged.1 \
+ fconf2.1 fconf2na.pl.1 \
+ fconf2.1 fconf2squish.1 \
+ fconf2.1 fconf2tornado.1 \
+ fconf2.1 fecfg2fconf.1
+INFO= fidoconfig
+
+post-patch:
+ @${REINPLACE_CMD} -e 's^/fido/etc/config^${PREFIX}/etc/fido/config^' \
+ ${WRKSRC}/man/dumpfcfg.1
+ @${REINPLACE_CMD} -e 's^/etc/fido/config^${PREFIX}/etc/fido/config^' \
+ ${WRKSRC}/man/fconf2.1 \
+ ${WRKSRC}/man/tparser.1
+
+.include <bsd.port.pre.mk>
+.include "${.CURDIR}/../../news/husky-base-devel/Makefile.inc"
+.include <bsd.port.post.mk>
diff --git a/news/husky-fidoconf-devel/distinfo b/news/husky-fidoconf-devel/distinfo
new file mode 100644
index 000000000000..dbdeafa04008
--- /dev/null
+++ b/news/husky-fidoconf-devel/distinfo
@@ -0,0 +1,2 @@
+MD5 (husky/fidoconf-1.4-rc4-src.tar.gz) = 4a3d9780c978b82ccefeffc1b585885f
+SIZE (husky/fidoconf-1.4-rc4-src.tar.gz) = 259197
diff --git a/news/husky-fidoconf-devel/files/patch-Makefile b/news/husky-fidoconf-devel/files/patch-Makefile
new file mode 100644
index 000000000000..9a02987c92ca
--- /dev/null
+++ b/news/husky-fidoconf-devel/files/patch-Makefile
@@ -0,0 +1,49 @@
+--- Makefile.orig Wed Oct 19 20:29:25 2005
++++ Makefile Wed Oct 19 20:32:23 2005
+@@ -87,7 +87,7 @@
+ progs: commonprogs
+
+ ifeq ($(DYNLIBS), 1)
+- all: commonlibs ranlib $(LIBFIDOCONFIG).so.$(VER)
++ all: commonlibs ranlib $(LIBFIDOCONFIG).so.$(VERMAJOR)
+ $(MAKE) progs
+ (cd doc && $(MAKE) all)
+ else
+@@ -105,28 +105,26 @@
+ (cd doc && $(MAKE) distclean)
+
+ ifeq (~$(MKSHARED)~, ~ld~)
+-$(LIBFIDOCONFIG).so.$(VER): $(LOBJS)
+- $(LD) $(LFLAGS) -o $(LIBFIDOCONFIG).so.$(VER) \
++$(LIBFIDOCONFIG).so.$(VERMAJOR): $(LOBJS)
++ $(LD) $(LFLAGS) -o $(LIBFIDOCONFIG).so.$(VERMAJOR) \
+ $(LOBJS) $(LOPT)
+ else
+-$(LIBFIDOCONFIG).so.$(VER): $(LOBJS)
+- $(CC) -shared -Wl,-soname,$(LIBFIDOCONFIG).so.$(VERH) \
+- -o $(LIBFIDOCONFIG).so.$(VER) $(LOBJS) $(LOPT)
++$(LIBFIDOCONFIG).so.$(VERMAJOR): $(LOBJS)
++ $(CC) -shared -Wl,-soname,$(LIBFIDOCONFIG).so.$(VERMAJOR) \
++ -o $(LIBFIDOCONFIG).so.$(VERMAJOR) $(LOBJS) $(LOPT)
+ endif
+- $(LN) $(LNOPT) $(LIBFIDOCONFIG).so.$(VER) $(LIBFIDOCONFIG).so.$(VERH) ;\
+- $(LN) $(LNOPT) $(LIBFIDOCONFIG).so.$(VER) $(LIBFIDOCONFIG).so
++ $(LN) $(LNOPT) $(LIBFIDOCONFIG).so.$(VERMAJOR) $(LIBFIDOCONFIG).so
+
+ %$(OBJ): %.c
+ $(CC) $(CDEFS) $(COPT) $*.c
+
+ ifeq ($(DYNLIBS), 1)
+-instdyn: $(LIBFIDOCONFIG).so.$(VER)
++instdyn: $(LIBFIDOCONFIG).so.$(VERMAJOR)
+ -$(MKDIR) $(MKDIROPT) $(LIBDIR)
+- $(INSTALL) $(ILOPT) $(LIBFIDOCONFIG).so.$(VER) $(LIBDIR)
++ $(INSTALL) $(ILOPT) $(LIBFIDOCONFIG).so.$(VERMAJOR) $(LIBDIR)
+ # Removed path from symlinks.
+ cd $(LIBDIR) ;\
+- $(LN) $(LNOPT) $(LIBFIDOCONFIG).so.$(VER) $(LIBFIDOCONFIG).so.$(VERH) ;\
+- $(LN) $(LNOPT) $(LIBFIDOCONFIG).so.$(VER) $(LIBFIDOCONFIG).so
++ $(LN) $(LNOPT) $(LIBFIDOCONFIG).so.$(VERMAJOR) $(LIBFIDOCONFIG).so
+ ifneq (~$(LDCONFIG)~, ~~)
+ $(LDCONFIG)
+ endif
diff --git a/news/husky-fidoconf-devel/files/patch-doc::Makefile b/news/husky-fidoconf-devel/files/patch-doc::Makefile
new file mode 100644
index 000000000000..49145a202f3c
--- /dev/null
+++ b/news/husky-fidoconf-devel/files/patch-doc::Makefile
@@ -0,0 +1,31 @@
+--- doc/Makefile.orig Sat Jun 4 09:06:32 2005
++++ doc/Makefile Wed Oct 19 16:34:38 2005
+@@ -6,7 +6,7 @@
+ include ../../huskymak.cfg
+ endif
+
+-all: html info dvi
++all: html info
+
+ ifdef HTMLDIR
+ html: fidoconfig.html
+@@ -68,7 +68,7 @@
+ -$(RM) $(RMOPT) fidoconfig.doc
+ -$(RM) $(RMOPT) fidoconfig.info*
+
+-install: info html dvi
++install: info html
+ @echo .
+ ifdef INFODIR
+ -$(MKDIR) $(MKDIROPT) $(INFODIR)
+@@ -78,10 +78,6 @@
+ ifdef HTMLDIR
+ -$(MKDIR) $(MKDIROPT) $(HTMLDIR)
+ $(INSTALL) $(IMOPT) fidoconfig*html $(HTMLDIR)
+-endif
+-ifdef DVIDIR
+- -$(MKDIR) $(MKDIROPT) $(DVIDIR)
+- $(INSTALL) $(IMOPT) fidoconfig.dvi $(DVIDIR)
+ endif
+
+ uninstall:
diff --git a/news/husky-fidoconf-devel/files/patch-makefile.inc b/news/husky-fidoconf-devel/files/patch-makefile.inc
new file mode 100644
index 000000000000..0a8b10d0e9e6
--- /dev/null
+++ b/news/husky-fidoconf-devel/files/patch-makefile.inc
@@ -0,0 +1,10 @@
+--- makefile.inc.orig Tue Apr 13 14:24:40 2004
++++ makefile.inc Wed Oct 19 20:39:32 2005
+@@ -5,6 +5,7 @@
+
+ VER = 1.4.0
+ VERH = 1.4
++VERMAJOR = 1
+
+ include makefile.in1
+
diff --git a/news/husky-fidoconf-devel/files/patch-man::Makefile b/news/husky-fidoconf-devel/files/patch-man::Makefile
new file mode 100644
index 000000000000..1cd2d80c8698
--- /dev/null
+++ b/news/husky-fidoconf-devel/files/patch-man::Makefile
@@ -0,0 +1,20 @@
+--- man/Makefile.orig Wed Feb 5 14:51:47 2003
++++ man/Makefile Wed Oct 19 20:57:40 2005
+@@ -20,7 +20,7 @@
+
+ all:
+
+-install: copy link
++install: copy
+
+ copy:
+ $(MKDIR) $(MKDIROPT) $(MAN1DIR)
+@@ -28,7 +28,7 @@
+
+ link:
+ cd $(MAN1DIR)$(DIRSEP); \
+- for f in $(FCONF2ALIASES) ; do $(LN) -s fconf2.1 $$f ; done
++ for f in $(FCONF2ALIASES) ; $(LN) -s fconf2.1 $$f ; done
+
+ clean:
+
diff --git a/news/husky-fidoconf-devel/files/patch-man::linkedto.1 b/news/husky-fidoconf-devel/files/patch-man::linkedto.1
new file mode 100644
index 000000000000..6889e664cc9d
--- /dev/null
+++ b/news/husky-fidoconf-devel/files/patch-man::linkedto.1
@@ -0,0 +1,11 @@
+--- man/linkedto.1.orig Sat Jan 11 17:52:57 2003
++++ man/linkedto.1 Sat Jan 11 17:53:14 2003
+@@ -19,8 +19,6 @@
+ .br
+ .nf
+ .\" set tabstop to longest possible filename, plus a wee bit
+-.ta \w'/etc/fido/config 'u
+-\fI/etc/fido/config\fR
+ .ta \w'/usr/local/etc/fido/config 'u
+ \fI/usr/local/etc/fido/config\fR Default Fidoconfig.
+ .SH NOTES
diff --git a/news/husky-fidoconf-devel/files/patch-tparser.c b/news/husky-fidoconf-devel/files/patch-tparser.c
new file mode 100644
index 000000000000..00f007565514
--- /dev/null
+++ b/news/husky-fidoconf-devel/files/patch-tparser.c
@@ -0,0 +1,11 @@
+--- tparser.c.orig Wed Oct 19 16:43:38 2005
++++ tparser.c Wed Oct 19 16:43:49 2005
+@@ -1141,7 +1141,7 @@
+
+ const char *smapi_cvs_date(){
+ static
+-#include "../smapi/cvsdate.h"
++#include <smapi/cvsdate.h>
+ return cvs_date;
+ }
+
diff --git a/news/husky-fidoconf-devel/pkg-descr b/news/husky-fidoconf-devel/pkg-descr
new file mode 100644
index 000000000000..e390170e81d1
--- /dev/null
+++ b/news/husky-fidoconf-devel/pkg-descr
@@ -0,0 +1,6 @@
+Configuration library for Husky Fidosoft Project.
+Development version.
+
+Husky is complete freeware suite of Fidonet applications.
+
+WWW: http://husky.sourceforge.net/
diff --git a/news/husky-fidoconf-devel/pkg-plist b/news/husky-fidoconf-devel/pkg-plist
new file mode 100644
index 000000000000..a5cf88961784
--- /dev/null
+++ b/news/husky-fidoconf-devel/pkg-plist
@@ -0,0 +1,34 @@
+share/doc/husky/fidoconfig.html
+lib/libfidoconfig.so.1
+lib/libfidoconfig.so
+lib/libfidoconfig.a
+bin/fconf2aquaed
+bin/fconf2binkd
+bin/fconf2fidogate
+bin/fconf2golded
+bin/fconf2msged
+bin/fconf2na.pl
+bin/fconf2squish
+bin/fconf2tornado
+bin/tparser
+bin/linked
+bin/linkedto
+bin/fconf2areasbbs
+include/fidoconf/adcase.h
+include/fidoconf/afixcmd.h
+include/fidoconf/arealist.h
+include/fidoconf/areatree.h
+include/fidoconf/common.h
+include/fidoconf/crc.h
+include/fidoconf/dirlayer.h
+include/fidoconf/fidoconf.h
+include/fidoconf/fidoconf.pas
+include/fidoconf/findtok.h
+include/fidoconf/log.h
+include/fidoconf/recode.h
+include/fidoconf/temp.h
+include/fidoconf/tree.h
+include/fidoconf/typesize.h
+include/fidoconf/version.h
+include/fidoconf/xstr.h
+@dirrm include/fidoconf