aboutsummaryrefslogtreecommitdiff
path: root/news/ifmail
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2013-12-21 12:53:25 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2013-12-21 12:53:25 +0000
commit4132656f3136b83de66cb151558288c4007fcb46 (patch)
treea703f299ff1f8162b17499d50853cc47191435cc /news/ifmail
parent5beec96978f0f470e74b65f2e2a960ad7eb75f4d (diff)
downloadports-4132656f3136b83de66cb151558288c4007fcb46.tar.gz
ports-4132656f3136b83de66cb151558288c4007fcb46.zip
Notes
Diffstat (limited to 'news/ifmail')
-rw-r--r--news/ifmail/Makefile33
-rw-r--r--news/ifmail/files/patch-CONFIG2
-rw-r--r--news/ifmail/pkg-plist3
3 files changed, 21 insertions, 17 deletions
diff --git a/news/ifmail/Makefile b/news/ifmail/Makefile
index db228169178d..98288620ed1d 100644
--- a/news/ifmail/Makefile
+++ b/news/ifmail/Makefile
@@ -10,7 +10,7 @@ MASTER_SITE_SUBDIR= system/fido
MAINTAINER= dinoex@FreeBSD.org
COMMENT= FidoNet(tm) support package for UN*X platform
-NO_STAGE= yes
+NEED_ROOT= yes
MAN3= parsedate.3
MAN8= ifmail.8 iftoss.8
@@ -19,40 +19,41 @@ PLIST_SUB+= IFMAIL_RUNAS="${IFMAIL_RUNAS}"
# USERS does not work here
#USERS= ifmail
+.include <bsd.port.options.mk>
+
pre-configure:
- @${MV} ${WRKSRC}/CONFIG ${WRKSRC}/CONFIG.sed
- ${SED} -e "s/OWNER = ifmail/OWNER = ${IFMAIL_RUNAS}/" \
- -e "s#CC = gcc#CC = ${CC}#" \
- -e "s#-O2 -Wall#${CFLAGS} -DHAS_STDARG_H -Wall#" \
- ${WRKSRC}/CONFIG.sed > ${WRKSRC}/CONFIG
+ ${REINPLACE_CMD} -e 's|OWNER = ifmail|OWNER = ${IFMAIL_RUNAS}|' \
+ -e 's|CC = gcc|CC = ${CC}|' \
+ -e 's|-O2 -Wall|${CFLAGS} -DHAS_STDARG_H -Wall|' \
+ ${WRKSRC}/CONFIG
pre-install:
if ! pw usershow ${IFMAIL_RUNAS}; then pw useradd ${IFMAIL_RUNAS} -g uucp -u 75 \
-h - -d /nonexistent -s /nonexistent -c "Ifmail Server"; fi
- ${MKDIR} ${PREFIX}/libexec/ifmail
+ ${MKDIR} ${STAGEDIR}${PREFIX}/libexec/ifmail
post-install:
.for i in ${MAN8}
- ${INSTALL_MAN} ${WRKSRC}/ifgate/${i} ${PREFIX}/man/man8
+ ${INSTALL_MAN} ${WRKSRC}/ifgate/${i} ${STAGEDIR}${PREFIX}/man/man8/
.endfor
.for i in ${MAN3}
- ${INSTALL_MAN} ${WRKSRC}/iflib/${i} ${PREFIX}/man/man3
+ ${INSTALL_MAN} ${WRKSRC}/iflib/${i} ${STAGEDIR}${PREFIX}/man/man3/
.endfor
@${ECHO_CMD} "updating ${ROOTDIR}/etc/services"
@${CP} ${ROOTDIR}/etc/services ${ROOTDIR}/etc/services.bak
@(grep -v ^ifcico ${ROOTDIR}/etc/services.bak; \
${ECHO_CMD} "ifcico 60179/tcp #ifcico server (ifmail)") \
> ${ROOTDIR}/etc/services
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}/
.for i in ifcico ifgate iflib
- ${INSTALL_DATA} ${WRKSRC}/${i}/README ${DOCSDIR}/README.${i}
+ ${INSTALL_DATA} ${WRKSRC}/${i}/README ${STAGEDIR}${DOCSDIR}/README.${i}
.endfor
.endif
-.if !defined(NOPORTEXAMPLES)
- ${MKDIR} ${EXAMPLESDIR}
- @${TAR} -C ${WRKSRC}/misc -cf - . | ${TAR} -C ${EXAMPLESDIR} -xf -
+.if ${PORT_OPTIONS:MEXAMPLES}
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ @${TAR} -C ${WRKSRC}/misc -cf - . | ${TAR} -C ${STAGEDIR}${EXAMPLESDIR} -xf -
.endif
.include <bsd.port.mk>
diff --git a/news/ifmail/files/patch-CONFIG b/news/ifmail/files/patch-CONFIG
index 3fc3506d2c24..471e5fa921ed 100644
--- a/news/ifmail/files/patch-CONFIG
+++ b/news/ifmail/files/patch-CONFIG
@@ -73,7 +73,7 @@
# for make install, where to put binaries and what owner to set
-BINDIR = /usr/lib/ifmail
-+BINDIR = ${PREFIX}/libexec/ifmail
++BINDIR = ${DESTDIR}${PREFIX}/libexec/ifmail
OWNER = ifmail
GROUP = uucp
MODE = 0711
diff --git a/news/ifmail/pkg-plist b/news/ifmail/pkg-plist
index 08466019fe06..23c4d894f5a7 100644
--- a/news/ifmail/pkg-plist
+++ b/news/ifmail/pkg-plist
@@ -1,3 +1,6 @@
+man/man3/parsedate.3.gz
+man/man8/ifmail.8.gz
+man/man8/iftoss.8.gz
@exec if ! pw usershow %%IFMAIL_RUNAS%% 2>/dev/null; then pw useradd %%IFMAIL_RUNAS%% -g uucp -u 75 -h - -d /nonexistent -s /nonexistent -c "Ifmail Server"; fi
@unexec if pw usershow %%IFMAIL_RUNAS%% | grep -q 75:66; then pw userdel %%IFMAIL_RUNAS%%; fi
@owner ifmail