aboutsummaryrefslogtreecommitdiff
path: root/news/inn/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-05-07 21:16:16 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-05-07 21:16:16 +0000
commitfde16f49176ce646416b73dd3fb7640dc53e1073 (patch)
tree7e9b646573b240a3148c1634dd5953e5c7b0cf7e /news/inn/Makefile
parent82d113ee079af1ebd581b394ec2c85142c106b5e (diff)
Notes
Diffstat (limited to 'news/inn/Makefile')
-rw-r--r--news/inn/Makefile22
1 files changed, 10 insertions, 12 deletions
diff --git a/news/inn/Makefile b/news/inn/Makefile
index 9d8313500623..9c56789c903e 100644
--- a/news/inn/Makefile
+++ b/news/inn/Makefile
@@ -6,15 +6,16 @@
#
PORTNAME= inn
-PORTVERSION= 2.4.1
-PORTREVISION= 1
+PORTVERSION= 2.4.3
CATEGORIES= news ipv6
MASTER_SITES= ${MASTER_SITE_ISC}
-MASTER_SITE_SUBDIR= inn
+MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= shaun@inerd.com
COMMENT= InterNetNews -- the Internet meets Netnews
+USE_RC_SUBR= innd.sh
+
NO_LATEST_LINK= yes
USE_GMAKE= yes
USE_PERL5= yes
@@ -51,9 +52,9 @@ WITH_BDB_VER= 4
. if (${WITH_BDB_VER} == 3) || (${WITH_BDB_VER} == 4) || (${WITH_BDB_VER} == 41)
LIB_DEPENDS+= db${WITH_BDB_VER}:${PORTSDIR}/databases/db${WITH_BDB_VER}
. elif ${WITH_BDB_VER} == 2
-BROKEN= "Does not compile with db2"
+BROKEN= Does not compile with db2
. else
-BROKEN= "Unknown BerkeleyDB version"
+BROKEN= Unknown BerkeleyDB version
. endif
CONFIGURE_ENV+= DB_VER=db${WITH_BDB_VER}
CONFIGURE_ARGS+= --with-berkeleydb=${LOCALBASE}
@@ -65,7 +66,6 @@ CONFIGURE_ARGS+= --with-python
.endif
.if defined(WITH_TCL)
-USE_REINPLACE= yes
CONFIGURE_ARGS+= --with-tcl=${LOCALBASE}
BUILD_DEPENDS+= ${LOCALBASE}/include/tcl8.3/tcl.h:${PORTSDIR}/lang/tcl83
.endif
@@ -100,7 +100,7 @@ HEADERS= clibrary.h config.h dbz.h libinn.h storage.h
MAN1= convdate.1 fastrm.1 getlist.1 grephistory.1 inews.1 innconfval.1 \
innfeed.1 innmail.1 nntpget.1 pgpverify.1 rnews.1 shlock.1 \
- shrinkfile.1 simpleftp.1 sm.1 startinnfeed.1
+ shrinkfile.1 simpleftp.1 sm.1 startinnfeed.1 pullnews.1
MAN3= clientlib.3 dbz.3 inndcomm.3 libauth.3 libinn.3 libinnhist.3 \
libstorage.3 list.3 parsedate.3 qio.3 tst.3 uwildmat.3
MAN5= active.5 active.times.5 buffindexed.conf.5 control.ctl.5 \
@@ -116,7 +116,7 @@ MAN8= actsync.8 actsyncd.8 archive.8 auth_smb.8 batcher.8 buffchan.8 \
innupgrade.8 innwatch.8 innxbatch.8 innxmit.8 mailpost.8 makedbz.8 \
makehistory.8 mod-active.8 news.daily.8 news2mail.8 ninpaths.8 \
nnrpd.8 nntpsend.8 ovdb_init.8 ovdb_monitor.8 ovdb_server.8 \
- ovdb_stat.8 overchan.8 perl-nocem.8 prunehistory.8 pullnews.8 \
+ ovdb_stat.8 overchan.8 perl-nocem.8 prunehistory.8 \
radius.8 rc.news.8 scanlogs.8 send-nntp.8 send-uucp.8 sendinpaths.8 \
tally.control.8 tdx-util.8 writelog.8
@@ -166,11 +166,9 @@ post-install:
.for FILE in ${HEADERS}
${INSTALL_DATA} ${WRKSRC}/include/${FILE} ${PREFIX}/news/include/
.endfor
- @${SED} <${FILESDIR}/innd.sh >${PREFIX}/etc/rc.d/innd.sh \
- s+!!PREFIX!!+${PREFIX}+g && ${CHMOD} +x ${PREFIX}/etc/rc.d/innd.sh
@${CHOWN} root:news ${PREFIX}/news/bin/auth/passwd/ckpasswd
@${CHMOD} 4755 ${PREFIX}/news/bin/auth/passwd/ckpasswd
- @PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} CHECK-CONF ${ETC_DIR}
+ @${SETENV} "PKG_PREFIX=${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} CHECK-CONF ${ETC_DIR}
@(if [ ! -f ${PREFIX}/news/db/history ] ; then \
${ECHO} 'Creating empty history database...' ; \
cd ${PREFIX}/news/db ; \