aboutsummaryrefslogtreecommitdiff
path: root/news/inn/Makefile
diff options
context:
space:
mode:
authorShaun Amott <shaun@FreeBSD.org>2006-08-03 14:39:44 +0000
committerShaun Amott <shaun@FreeBSD.org>2006-08-03 14:39:44 +0000
commitd6e813c37c3381ccb58ec8d2d07b26cfdf28f348 (patch)
tree6e11c23eee65913c44cd861c01cea60890b13a99 /news/inn/Makefile
parent7648ca6921cdeb9b778d651d10428d9208506d81 (diff)
downloadports-d6e813c37c3381ccb58ec8d2d07b26cfdf28f348.tar.gz
ports-d6e813c37c3381ccb58ec8d2d07b26cfdf28f348.zip
Notes
Diffstat (limited to 'news/inn/Makefile')
-rw-r--r--news/inn/Makefile16
1 files changed, 14 insertions, 2 deletions
diff --git a/news/inn/Makefile b/news/inn/Makefile
index e7675fde5c78..3310415e793d 100644
--- a/news/inn/Makefile
+++ b/news/inn/Makefile
@@ -45,6 +45,18 @@ CONFIGURE_ARGS+= --mandir=${PREFIX}/man \
--enable-ipv6 \
--with-etc-dir=${ETC_DIR}
+# Attempt to avoid failures later on, when
+# makedbz is executed: we need a valid hostname.
+
+.if exists(/bin/echo) && exists(/bin/hostname)
+HOSTNAME!= `/bin/echo /bin/hostname`
+HOSTNAME:= ${HOSTNAME:C/[^\.]//g}
+
+. if ${HOSTNAME} == ""
+IGNORE= requires a fully-qualified hostname in order to build
+. endif
+.endif
+
.if defined(WITH_BERKELEYDB)
CONFIGURE_ARGS+= --with-berkeleydb
. if !defined(WITH_BDB_VER)
@@ -149,7 +161,7 @@ post-patch:
.endif
pre-install:
- @${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
+ @${SETENV} "PKG_PREFIX=${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL
post-install:
.if !defined(WITHOUT_STRIP)
@@ -184,6 +196,6 @@ post-install:
${MV} history.n.$${s} history.$${s} ; \
done ; \
fi)
- @${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL PORTMODE
+ @${SETENV} "PKG_PREFIX=${PREFIX}" ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL PORTMODE
.include <bsd.port.post.mk>