aboutsummaryrefslogtreecommitdiff
path: root/news/newsfetch
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2003-11-20 19:48:11 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2003-11-20 19:48:11 +0000
commitc033222bbe7ab95e04b82a98b923999035c1d880 (patch)
treef8c8ec45b499040810d47d071304373d2ec7cd19 /news/newsfetch
parentff4d6ea8cf35fe297dc89f89a22f2c8dd60824ad (diff)
downloadports-c033222bbe7ab95e04b82a98b923999035c1d880.tar.gz
ports-c033222bbe7ab95e04b82a98b923999035c1d880.zip
Notes
Diffstat (limited to 'news/newsfetch')
-rw-r--r--news/newsfetch/Makefile8
-rw-r--r--news/newsfetch/files/patch-opt.c13
-rw-r--r--news/newsfetch/files/patch-util.c27
3 files changed, 41 insertions, 7 deletions
diff --git a/news/newsfetch/Makefile b/news/newsfetch/Makefile
index d0c3f040535a..0eac93810f6e 100644
--- a/news/newsfetch/Makefile
+++ b/news/newsfetch/Makefile
@@ -20,12 +20,6 @@ MAKE_ENV= BINDIR="${PREFIX}/bin" MANDIR="${PREFIX}/man/man"
MAN1= newsfetch.1
MANCOMPRESSED= maybe
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 501000
-BROKEN= "Does not compile"
-.endif
-
do-configure:
cd ${WRKSRC} && ( \
${ECHO_CMD} "PROG= newsfetch"; \
@@ -33,4 +27,4 @@ do-configure:
${ECHO_CMD} ".include <bsd.prog.mk>"; \
) > Makefile
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/news/newsfetch/files/patch-opt.c b/news/newsfetch/files/patch-opt.c
new file mode 100644
index 000000000000..a07d560b8083
--- /dev/null
+++ b/news/newsfetch/files/patch-opt.c
@@ -0,0 +1,13 @@
+--- opt.c.orig Wed Nov 19 19:01:47 2003
++++ opt.c Wed Nov 19 19:01:47 2003
+@@ -192,8 +192,8 @@
+ {
+
+ char *options=
+-" [-clsyvV] [-d dirname] [-f rcfile] [-t N]
+- [-T timeout] [-w M ] [-pPY filter] [-x command]
++" [-clsyvV] [-d dirname] [-f rcfile] [-t N]\n\
++ [-T timeout] [-w M ] [-pPY filter] [-x command]\n\
+ ";
+ fprintf(stderr,"Usage: %s nntp_server [options]\n", prog_name);
+ fprintf(stderr,"Options:\n%s\n",options);
diff --git a/news/newsfetch/files/patch-util.c b/news/newsfetch/files/patch-util.c
new file mode 100644
index 000000000000..b90dc048e2d9
--- /dev/null
+++ b/news/newsfetch/files/patch-util.c
@@ -0,0 +1,27 @@
+--- util.c.orig Wed Nov 19 19:01:47 2003
++++ util.c Wed Nov 19 19:01:47 2003
+@@ -61,15 +61,15 @@
+ FILE *fp, *fp1, *fp2;
+ char *tmp, buf[200], group[180], filterfile[100], procmailrcfile[100];
+ int i,j;
+-char *title="
+-
+-############### Generated by Newsfetch ##############################
+-# New version of Newsfetch is available from #
+-# #
+-# http://ulf.wep.net/newsfetch.html #
+-# Feedback and Comments to Yusuf Motiwala <yusuf@scientist.com> #
+-######################################################################
+-
++char *title="\n\
++\n\
++############### Generated by Newsfetch ##############################\n\
++# New version of Newsfetch is available from #\n\
++# #\n\
++# http://ulf.wep.net/newsfetch.html #\n\
++# Feedback and Comments to Yusuf Motiwala <yusuf@scientist.com> #\n\
++######################################################################\n\
++\n\
+ ";
+
+ strcpy(filterfile,homedir);