aboutsummaryrefslogtreecommitdiff
path: root/news/newsstar/Makefile
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2015-12-30 15:16:27 +0000
committerMatthias Andree <mandree@FreeBSD.org>2015-12-30 15:16:27 +0000
commit9befeb075e2522c9d25af128dfe226f55a57afb7 (patch)
tree0e18766f10978bf371dc232a8fd1ff9a4f7b771b /news/newsstar/Makefile
parent4d4e2f35e812ee1d7a313ea05f8de765e75da05e (diff)
downloadports-9befeb075e2522c9d25af128dfe226f55a57afb7.tar.gz
ports-9befeb075e2522c9d25af128dfe226f55a57afb7.zip
Notes
Diffstat (limited to 'news/newsstar/Makefile')
-rw-r--r--news/newsstar/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/news/newsstar/Makefile b/news/newsstar/Makefile
index cc9d1c411e18..c09af3a18c13 100644
--- a/news/newsstar/Makefile
+++ b/news/newsstar/Makefile
@@ -75,20 +75,20 @@ post-patch:
${REINPLACE_CMD} -e 's|install-data-local: install-docs|install-data-local:|' ${WRKSRC}/Makefile.in
post-install:
-.if ${PORT_OPTIONS:MEXAMPLES}
- ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${MAKE} -C ${WRKSRC}/src install DESTDIR=${STAGEDIR}
+ ${MAKE} -C ${WRKSRC}/docs install-man DESTDIR=${STAGEDIR}
+ ${MKDIR} ${STAGEDIR}/var/spool/newsstar
+
+post-install-EXAMPLES-on:
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
.for i in ${EX_CONFIGS}
${INSTALL_DATA} ${WRKSRC}/sample_config/${i} ${STAGEDIR}${EXAMPLESDIR}
.endfor
-.endif
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
.endfor
-.else
- ${MAKE} -C ${WRKSRC}/src install DESTDIR=${STAGEDIR}
- ${MAKE} -C ${WRKSRC}/docs install-man DESTDIR=${STAGEDIR}
-.endif
.include <bsd.port.post.mk>