aboutsummaryrefslogtreecommitdiff
path: root/news/newsstar
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2004-08-20 13:04:04 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2004-08-20 13:04:04 +0000
commit82f6a88cb492201f447eac3d92343924d15fd1d9 (patch)
treebb1a3d761714f624e33bb0191447b5b83064b226 /news/newsstar
parentcca4f8e73b64077757cdef22319310a4412a3d19 (diff)
downloadports-82f6a88cb492201f447eac3d92343924d15fd1d9.tar.gz
ports-82f6a88cb492201f447eac3d92343924d15fd1d9.zip
Notes
Diffstat (limited to 'news/newsstar')
-rw-r--r--news/newsstar/Makefile22
-rw-r--r--news/newsstar/distinfo4
-rw-r--r--news/newsstar/files/patch-newsstar.in50
3 files changed, 27 insertions, 49 deletions
diff --git a/news/newsstar/Makefile b/news/newsstar/Makefile
index 00d32e950dc6..e62e2b8cc102 100644
--- a/news/newsstar/Makefile
+++ b/news/newsstar/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= newsstar
-PORTVERSION= 1.1.1
-PORTREVISION= 1
+PORTVERSION= 1.2
CATEGORIES= news
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,18 +14,25 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= anray@inet.ua
COMMENT= Transfer news between a local NNTP server (INN, sn, s-news)
-.if exists(${LOCALBASE}/news/bin/innd)
-WITH_INN=yes
-.endif
-
.if defined(WITHOUT_SSL)
CONFIGURE_ARGS+=--disable-ssl
.else
USE_OPENSSL= yes
.endif
-.if defined(WITH_INN)
-CONFIGURE_ARGS+=--with-inn-path=${PREFIX}/news/bin
+.if exists(/var/spool/s-news)
+CONFIGURE_ARGS+=--with-spool-dir=/var/spool/s-news \
+ --with-snews-outgoing-dir=${LOCALBASE}/etc/s-news/suck
+.endif
+
+.if exists(${LOCALBASE}/sbin/snntpd)
+CONFIGURE_ARGS+=--with-sn-spool-dir=/var/spool/news \
+ --with-sn-articles-dir=/var/spool/news \
+ --with-outgoing-dir=/var/spool/news/.outgoing
+.endif
+
+.if exists(${LOCALBASE}/news/bin/innconfval)
+CONFIGURE_ARGS+=--with-inn-path=${LOCALBASE}/news/bin
.endif
CONFIGURE_ARGS+=--prefix=${PREFIX} \
diff --git a/news/newsstar/distinfo b/news/newsstar/distinfo
index d76e788a52ab..58bbe9404065 100644
--- a/news/newsstar/distinfo
+++ b/news/newsstar/distinfo
@@ -1,2 +1,2 @@
-MD5 (newsstar-1.1.1.tar.gz) = ae56df2413f3d727ef413a7203a43b9b
-SIZE (newsstar-1.1.1.tar.gz) = 257732
+MD5 (newsstar-1.2.tar.gz) = 68c6a01b24a196d289605b323ac9f749
+SIZE (newsstar-1.2.tar.gz) = 262902
diff --git a/news/newsstar/files/patch-newsstar.in b/news/newsstar/files/patch-newsstar.in
index 16a2f053b983..d40fb213307b 100644
--- a/news/newsstar/files/patch-newsstar.in
+++ b/news/newsstar/files/patch-newsstar.in
@@ -1,6 +1,6 @@
---- newsstar.in.orig Sun Jul 4 00:21:24 2004
-+++ newsstar.in Fri Aug 13 13:21:10 2004
-@@ -29,7 +29,6 @@
+--- newsstar.in.orig Tue Aug 17 22:33:53 2004
++++ newsstar.in Thu Aug 19 19:18:38 2004
+@@ -30,7 +30,6 @@
$NEWS_PATH = '@NEWS_PATH@';
$prefix = "@prefix@";
$exec_prefix = "@exec_prefix@";
@@ -8,26 +8,7 @@
$NEWSSTAR_BIN = "@NEWSSTAR_BIN@";
$MAINCF = $CONF_DIR . "/main.cf";
$INCOMING_DIR = "@INCOMING_DIR@";
-@@ -199,7 +198,7 @@
-
- if ($USE_SN)
- {
-- $SPOOL_DIR = "/var/spool/sn" if ($SPOOL_DIR eq "");
-+ $SPOOL_DIR = "/var/spool/news" if ($SPOOL_DIR eq "");
- $OUTGOING_DIR = $SPOOL_DIR . "/.outgoing" if ($OUTGOING_DIR eq "");
- $OUTGOING_NEWSSTAR_DIR = $OUTGOING_DIR . "/.newsstar";
- $ARTICLES_DIR = $SPOOL_DIR if ($ARTICLES_DIR eq "");
-@@ -209,7 +208,8 @@
- $SPOOL_DIR = "/var/spool/news" if ($SPOOL_DIR eq "");
- if ($USE_SNEWS)
- {
-- $OUTGOING_DIR = "/var/lib/news/suck" if ($OUTGOING_DIR eq "");
-+ $ARTICLES_DIR = "/var/spool/s-news" if ($ARTICLES_DIR eq "");
-+ $OUTGOING_DIR = "${prefix}/etc/s-news/suck" if ($OUTGOING_DIR eq "");
- }
- elsif ($OUTGOING_DIR eq "")
- {
-@@ -223,7 +223,17 @@
+@@ -261,7 +260,17 @@
}
}
$OUTGOING_NEWSSTAR_DIR = $OUTGOING_DIR . "/newsstar";
@@ -45,8 +26,8 @@
+ }
if ($ARTICLES_DIR eq "")
{
- if (-d "$SPOOL_DIR/articles")
-@@ -243,21 +253,9 @@
+ if ($USE_SNEWS)
+@@ -292,21 +301,9 @@
{
if ($SNSTORE eq "")
{
@@ -70,36 +51,27 @@
}
else
{
-@@ -274,21 +272,9 @@
+@@ -323,21 +320,9 @@
{
if ($OVERVIEW eq "")
{
- if (-x "/usr/sbin/overview")
- {
-- $overview = "/usr/sbin/overview"
+- $OVERVIEW = "/usr/sbin/overview"
- }
- elsif (-x "/usr/local/sbin/overview")
- {
-- $overview = "/usr/local/sbin/overview"
+- $OVERVIEW = "/usr/local/sbin/overview"
- }
- elsif (-x "/usr/bin/overview")
- {
-- $overview = "/usr/bin/overview"
+- $OVERVIEW = "/usr/bin/overview"
- }
- elsif (-x "/usr/local/bin/overview")
+ if (-x "${prefix}/sbin/overview")
{
-- $overview = "/usr/local/bin/overview"
+- $OVERVIEW = "/usr/local/bin/overview"
+ $OVERVIEW = "${prefix}/sbin/overview"
}
else
{
-@@ -908,7 +894,7 @@
- # $NEWS_USER may also contain group
- my $news_from = $NEWS_USER;
- $news_from =~ s/\..*//;
-- if (!open(SENDMAIL, "|/usr/lib/sendmail -oi -t"))
-+ if (!open(SENDMAIL, "|/usr/sbin/sendmail -oi -t"))
- {
- print STDERR "Can't run sendmail to bounce rejected posting\n";
- return;