aboutsummaryrefslogtreecommitdiff
path: root/news/nntp/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2002-02-20 15:36:33 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2002-02-20 15:36:33 +0000
commit0bcd11754bcb9589b7fbe8f6c3cf70a972ac7850 (patch)
tree88039850342a86912b6b061fba601fa256cf1586 /news/nntp/Makefile
parent3233729ade6a99be0ac29e3438dcbd944703c1e1 (diff)
Notes
Diffstat (limited to 'news/nntp/Makefile')
-rw-r--r--news/nntp/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/news/nntp/Makefile b/news/nntp/Makefile
index c201eb79e3e9..90c4839c9dbe 100644
--- a/news/nntp/Makefile
+++ b/news/nntp/Makefile
@@ -27,6 +27,8 @@ PLIST_SUB+= NEWSBIN=${NEWSBIN:S=${PREFIX}/==}
PLIST_SUB+= NEWSCTL=${NEWSCTL:S=${PREFIX}/==}
MODIFY= conf.h Makefile
+DOCSFILES1= AUTHORIZE CHANGES README README-conf.h SYSLOG doc/rfc977
+DOCSFILES2= server support xfer xmit
NEWSBIN?= ${PREFIX}/news/cnewsbin
NEWSCTL?= ${PREFIX}/news/lib
@@ -53,5 +55,15 @@ pre-configure:
post-install:
${INSTALL_DATA} ${WRKSRC}/overview.fmt ${NEWSCTL}/overview.fmt
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in ${DOCSFILES1}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}/
+.endfor
+.for i in ${DOCSFILES2}
+ ${INSTALL_DATA} ${WRKSRC}/${i}/README ${DOCSDIR}/${i}-README
+.endfor
+.endif
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>