aboutsummaryrefslogtreecommitdiff
path: root/news/nntp/Makefile
diff options
context:
space:
mode:
authorChris Piazza <cpiazza@FreeBSD.org>2000-01-12 05:51:25 +0000
committerChris Piazza <cpiazza@FreeBSD.org>2000-01-12 05:51:25 +0000
commit050486602a06b76cd707185b8c908bad3bfdcf9f (patch)
tree46e0bc2e8ceec84a206ecc0a95e55ac0d810f370 /news/nntp/Makefile
parent62ba44547e273757953b1892c3b962a85cf0528f (diff)
downloadports-050486602a06b76cd707185b8c908bad3bfdcf9f.tar.gz
ports-050486602a06b76cd707185b8c908bad3bfdcf9f.zip
Notes
Diffstat (limited to 'news/nntp/Makefile')
-rw-r--r--news/nntp/Makefile21
1 files changed, 15 insertions, 6 deletions
diff --git a/news/nntp/Makefile b/news/nntp/Makefile
index 0cd37cff6ed3..a1d986745882 100644
--- a/news/nntp/Makefile
+++ b/news/nntp/Makefile
@@ -6,21 +6,25 @@
# $FreeBSD$
#
-DISTNAME= nntp-t5
-PKGNAME= nntp-1.5.11.5
+DISTNAME= nntp.1.5.12.2
+PKGNAME= nntp-1.5.12.2
CATEGORIES= news
-MASTER_SITES= ftp://ftp.abs.net/unix/ \
- ftp://ftp.ww.net/pub/unix/news/nntp/
+MASTER_SITES= ftp://ftp.academ.com/pub/nntp/server/
+
+PATCH_SITES= ftp://ftp.lan-ks.de/pub/c-news/ \
+ ftp://ftp.dinoex.org/pub/c-news/
+PATCHFILES= nntp-patch-y2k
MAINTAINER= adam@veda.is
BUILD_DEPENDS= ${LOCALBASE}/lib/libcnews.a:${PORTSDIR}/news/cnews
+NO_WRKSUBDIR= yes
MAN1= nntpxmit.1
-MAN8= nntpd.8c mkgrdates.8c
+MAN8= nntpd.8c acttimes.8c
PLIST= ${WRKDIR}/.PLIST.sed
-MODIFY= conf.h xfer/Makefile xmit/Makefile
+MODIFY= conf.h Makefile
NEWSBIN?= ${PREFIX}/news/cnewsbin
NEWSCTL?= ${PREFIX}/news/lib
@@ -40,10 +44,15 @@ pre-configure:
-e "s=/var/news/over.view=${NEWSOV}=" \
-e "s=/var/news=${NEWSARTS}=" \
-e "s=/usr/local/bin=${PREFIX}/bin=" \
+ -e "s=/usr/local/sbin=${PREFIX}/sbin=" \
+ -e "s=/usr/local/man=${PREFIX}/man=" \
${WRKSRC}/${i}.sed >${WRKSRC}/${i}
.endfor
@${SED} \
-e "s=news/cnewsbin=${NEWSBIN:S=${PREFIX}/==}=" \
${PKGDIR}/PLIST >${PLIST}
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/overview.fmt ${NEWSCTL}/overview.fmt
+
.include <bsd.port.mk>