aboutsummaryrefslogtreecommitdiff
path: root/news/nntp
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2002-12-09 21:10:30 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2002-12-09 21:10:30 +0000
commitc459689c126d6c187783214bd1a2a73a0254b801 (patch)
treee6dbd781d08301389614516d20e7aa35ea5dce20 /news/nntp
parent0f9e559736e5df69a914996ace912113b9f07262 (diff)
downloadports-c459689c126d6c187783214bd1a2a73a0254b801.tar.gz
ports-c459689c126d6c187783214bd1a2a73a0254b801.zip
Notes
Diffstat (limited to 'news/nntp')
-rw-r--r--news/nntp/Makefile1
-rw-r--r--news/nntp/files/patch-Makefile2
-rw-r--r--news/nntp/files/patch-xfer-nntpxfer.c18
3 files changed, 5 insertions, 16 deletions
diff --git a/news/nntp/Makefile b/news/nntp/Makefile
index c6e7403bf383..3fedd0efc9ed 100644
--- a/news/nntp/Makefile
+++ b/news/nntp/Makefile
@@ -25,7 +25,6 @@ MAN1= nntpxmit.1
MAN8= nntpd.8c acttimes.8c
PLIST_SUB+= NEWSBIN=${NEWSBIN:S=${PREFIX}/==}
PLIST_SUB+= NEWSCTL=${NEWSCTL:S=${PREFIX}/==}
-CFLAGS+= -I${LOCALBASE}/include
MODIFY= conf.h Makefile
DOCSFILES1= AUTHORIZE CHANGES README README-conf.h SYSLOG doc/rfc977
diff --git a/news/nntp/files/patch-Makefile b/news/nntp/files/patch-Makefile
index 2f4ccb5088be..3ff1ab4cc3df 100644
--- a/news/nntp/files/patch-Makefile
+++ b/news/nntp/files/patch-Makefile
@@ -5,7 +5,7 @@
# MAKE=make
# set CFLAGS to be -Ipath/to/special/includes if needed
-CFLAGS= -O
-+#CFLAGS= -O
++CFLAGS+= -I${LOCALBASE}/include
#Uncomment the following for Solaris (and similiar SVR4 systems)
#NETLIBS = -lsocket -lnsl
#Uncomment the following if the previous one does not work
diff --git a/news/nntp/files/patch-xfer-nntpxfer.c b/news/nntp/files/patch-xfer-nntpxfer.c
index 0578f6860768..4eba4a795893 100644
--- a/news/nntp/files/patch-xfer-nntpxfer.c
+++ b/news/nntp/files/patch-xfer-nntpxfer.c
@@ -1,16 +1,6 @@
---- xfer/nntpxfer.c.orig Thu Dec 5 10:04:30 2002
-+++ xfer/nntpxfer.c Thu Dec 5 10:07:22 2002
-@@ -60,6 +60,9 @@
- #include <sys/time.h>
- #endif
-
-+#ifdef BSD_44
-+#define _ANSI_SOURCE
-+#endif
- #include <stdio.h>
- #include <errno.h>
- #include <ctype.h>
-@@ -107,7 +110,11 @@
+--- xfer/nntpxfer.c.orig Fri Dec 6 07:51:46 2002
++++ xfer/nntpxfer.c Fri Dec 6 07:58:39 2002
+@@ -107,7 +107,11 @@
char *rindex();
u_long inet_addr();
@@ -22,7 +12,7 @@
char *artlist[MAX_ARTICLES];
int server; /* stream socket to the nntp server */
FILE * rd_fp, * wr_fp;
-@@ -649,8 +656,10 @@
+@@ -649,8 +653,10 @@
errmsg(code)
int code;
{