aboutsummaryrefslogtreecommitdiff
path: root/news/nntpcache/Makefile
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-07-25 18:52:48 +0000
committerPatrick Li <pat@FreeBSD.org>2002-07-25 18:52:48 +0000
commitd60fc8fe7b47d6fdd244a858ca57dbdd2358839c (patch)
tree83b29f33771137b3c728b3a3f67ba1528957829a /news/nntpcache/Makefile
parent163665320a85b54a46051833571d29bc3c0507ac (diff)
Notes
Diffstat (limited to 'news/nntpcache/Makefile')
-rw-r--r--news/nntpcache/Makefile37
1 files changed, 16 insertions, 21 deletions
diff --git a/news/nntpcache/Makefile b/news/nntpcache/Makefile
index 56c582a1fc55..14a865fcf0dd 100644
--- a/news/nntpcache/Makefile
+++ b/news/nntpcache/Makefile
@@ -6,24 +6,22 @@
#
PORTNAME= nntpcache
-PORTVERSION= 2.4.0b5
+PORTVERSION= 3.0.1
CATEGORIES= news
-MASTER_SITES= ftp://nntpcache.org/pub/nntpcache/ \
+MASTER_SITES= ftp://ftp.nntpcache.org/pub/nntpcache/ \
ftp://ftp.nethelp.no/pub/news/ \
ftp://ftp.netsw.org/net/news/proxy/nntpcache/
MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= automake14:${PORTSDIR}/devel/automake14
-
+BUILD_DEPENDS= automake:${PORTSDIR}/devel/automake
.if defined(WITH_LDAP) && !defined(WITH_LDAP2)
-LIB_DEPENDS+= ldap.1:${PORTSDIR}/net/openldap
-LIB_DEPENDS+= lber.1:${PORTSDIR}/net/openldap
+LIB_DEPENDS+= ldap.1:${PORTSDIR}/net/openldap
+LIB_DEPENDS+= lber.1:${PORTSDIR}/net/openldap
.endif
-
.if defined(WITH_LDAP2)
-LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap2
-LIB_DEPENDS+= lber.2:${PORTSDIR}/net/openldap2
+LIB_DEPENDS+= ldap.2:${PORTSDIR}/net/openldap2
+LIB_DEPENDS+= lber.2:${PORTSDIR}/net/openldap2
.endif
# This may be set interactively at install-time. NNTPCache will
@@ -36,18 +34,19 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --localstatedir=${SPOOLDIR}
-AUTHINFO_EXT= authinfo_pam.ext
+AUTHINFO_EXT= authinfo_pam.ext
.if !defined(WITHOUT_RADIUS)
-CONFIGURE_ARGS+= --with-authinfo-radius
-AUTHINFO_EXT+= authinfo_radius.ext
+CONFIGURE_ARGS+= --with-authinfo-radius
+AUTHINFO_EXT+= authinfo_radius.ext
.endif
.if defined(WITH_LDAP) || defined(WITH_LDAP2)
-CONFIGURE_ARGS+= --with-authinfo-ldap
-CPPFLAGS+= -I${PREFIX}/include -I${LOCALBASE}/include
-LDFLAGS+= -L${PREFIX}/lib -L${LOCALBASE}/lib
-AUTHINFO_EXT+= authinfo_ldap.ext
-CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS+= --with-authinfo-ldap
+CPPFLAGS+= -I${PREFIX}/include -I${LOCALBASE}/include
+LDFLAGS+= -L${PREFIX}/lib -L${LOCALBASE}/lib
+AUTHINFO_EXT+= authinfo_ldap.ext
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
.endif
+CONFIGURE_ARGS+= --program-transform-name=''
NNTPSPOOLDIR?= ${SPOOLDIR}/${PORTNAME}
PLIST_SUB+= SPOOLDIR=${NNTPSPOOLDIR}
@@ -68,10 +67,6 @@ post-fetch:
post-configure:
@cd ${WRKSRC}/src && ${GMAKE} ${AUTHINFO_EXT}
-post-patch:
- @${REINPLACE_CMD} -e 's,AUTOMAKE=automake,AUTOMAKE=automake14,' \
- ${WRKSRC}/configure
-
post-install:
@ ${MKDIR} ${PREFIX}/etc/rc.d
@ ${SED} -e 's#%%PREFIX%%#${PREFIX}#g' ${FILESDIR}/nntpcached.rc \