aboutsummaryrefslogtreecommitdiff
path: root/news/p5-NNML/Makefile
diff options
context:
space:
mode:
authorErwin Lansing <erwin@FreeBSD.org>2006-07-14 15:48:41 +0000
committerErwin Lansing <erwin@FreeBSD.org>2006-07-14 15:48:41 +0000
commit695697c8ce95dfecf1ec31a15c6912f2ee758398 (patch)
treedc4b8b351bc0e7191db3453e66b067845f42aa35 /news/p5-NNML/Makefile
parent63b87c5058559bd227354c5919750aee9b2abb8e (diff)
Notes
Diffstat (limited to 'news/p5-NNML/Makefile')
-rw-r--r--news/p5-NNML/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/news/p5-NNML/Makefile b/news/p5-NNML/Makefile
new file mode 100644
index 000000000000..02e44ec6a812
--- /dev/null
+++ b/news/p5-NNML/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: p5-NNML
+# Date created: 2006-07-14
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= NNML
+PORTVERSION= 1.14
+CATEGORIES= news perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/U/UL/ULPFR
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= A minimal NNTP server
+
+PERL_CONFIGURE= yes
+
+RESTRICTED= License unknown
+
+MAN1= nnmirror.1 nnsync.1 overview.1
+MAN3= NNML::Server.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500702
+BUILD_DEPENDS= ${SITE_PERL}/Net/Cmd.pm:${PORTSDIR}/net/p5-Net
+RUN_DEPENDS= ${BUILD_DEPENDS}
+.endif
+
+.if defined(BATCH)
+CONFIGURE_ARGS+= < /dev/null
+.else
+IS_INTERACTIVE= yes
+.endif
+
+.include <bsd.port.post.mk>