aboutsummaryrefslogtreecommitdiff
path: root/news/pan/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-03-08 10:51:34 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-03-08 10:51:34 +0000
commit7887c684adab042fed1bfcba2e91589ecd17c4a8 (patch)
tree961839899dce7f75292a08c079f548973bdbd40d /news/pan/Makefile
parent85544f2c01be814e0af1ebee1076012e7ed60bb0 (diff)
downloadports-7887c684adab042fed1bfcba2e91589ecd17c4a8.tar.gz
ports-7887c684adab042fed1bfcba2e91589ecd17c4a8.zip
Notes
Diffstat (limited to 'news/pan/Makefile')
-rw-r--r--news/pan/Makefile29
1 files changed, 13 insertions, 16 deletions
diff --git a/news/pan/Makefile b/news/pan/Makefile
index 1795f7669274..9edd9728561e 100644
--- a/news/pan/Makefile
+++ b/news/pan/Makefile
@@ -1,14 +1,9 @@
-# New ports collection makefile for: pan2
-# Date created: 19 August 2002
-# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
-#
+# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/news/pan/Makefile,v 1.7 2008/01/19 22:45:42 mezz Exp $
-#
PORTNAME= pan
-PORTVERSION= 0.135
-PORTREVISION= 3
+PORTVERSION= 0.139
CATEGORIES= news gnome
MASTER_SITES= http://pan.rebelbase.com/download/releases/${PORTVERSION}/source/
DIST_SUBDIR= gnome2
@@ -18,8 +13,8 @@ COMMENT= Threaded GTK+ newsreader based on Agent for Windows
LICENSE= GPLv2
-LIB_DEPENDS= pcre.3:${PORTSDIR}/devel/pcre \
- gmime-2.4.6:${PORTSDIR}/mail/gmime24
+LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre \
+ gmime-2.4:${PORTSDIR}/mail/gmime24
USE_BZIP2= yes
USE_GMAKE= yes
@@ -29,12 +24,14 @@ GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -lgnuregex
-OPTIONS= GTKSPELL "Enable spell checking support (gtk+2 only)" on \
- GTK3 "Build with gtk+3 based UI instead of gtk+2" off
+OPTIONS_DEFINE= GTKSPELL GTK3
+OPTIONS_DEFAULT=GTKSPELL
+GTKSPELL_DESC= Spell checking support (gtk+2 only)
+GTK3_DESC= Use gtk+3 based UI instead of gtk+2
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_GTK3)
+.if ${PORT_OPTIONS:MGTK3}
USE_GNOME+= gtk20
CONFIGURE_ARGS+=--without-gtk3
.else
@@ -42,10 +39,10 @@ USE_GNOME+= gtk30
CONFIGURE_ARGS+=--with-gtk3
.endif
-.if defined(WITHOUT_GTKSPELL) || defined(WITH_GTK3)
+.if !${PORT_OPTIONS:MGTKSPELL} || ${PORT_OPTIONS:MGTK3}
CONFIGURE_ARGS+= --without-gtkspell
.else
-LIB_DEPENDS+= gtkspell.0:${PORTSDIR}/textproc/gtkspell
+LIB_DEPENDS+= gtkspell:${PORTSDIR}/textproc/gtkspell
CONFIGURE_ARGS+= --with-gtkspell
.endif
@@ -53,4 +50,4 @@ post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in"| ${XARGS} ${REINPLACE_CMD} -e \
's|noinst_PROGRAMS = |noinst_PROGRAMS = #|g'
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>