aboutsummaryrefslogtreecommitdiff
path: root/news/sabnzbd
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-03-20 19:56:54 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-03-20 19:56:54 +0000
commitfe68a74e1fdf3d0ae9a73b33756e07f8fd6aef13 (patch)
tree96b815218c7041eca6f44ea71cea915e52337d49 /news/sabnzbd
parent9e78844ca456b9e9806e01feb7efb030724cf03b (diff)
downloadports-fe68a74e1fdf3d0ae9a73b33756e07f8fd6aef13.tar.gz
ports-fe68a74e1fdf3d0ae9a73b33756e07f8fd6aef13.zip
Notes
Diffstat (limited to 'news/sabnzbd')
-rw-r--r--news/sabnzbd/Makefile47
-rw-r--r--news/sabnzbd/distinfo3
-rw-r--r--news/sabnzbd/files/patch-setup.py18
-rw-r--r--news/sabnzbd/files/pkg-message.in6
-rw-r--r--news/sabnzbd/pkg-descr4
-rw-r--r--news/sabnzbd/pkg-plist61
6 files changed, 139 insertions, 0 deletions
diff --git a/news/sabnzbd/Makefile b/news/sabnzbd/Makefile
new file mode 100644
index 000000000000..35ec3ced3d10
--- /dev/null
+++ b/news/sabnzbd/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: sabnzbd
+# Date created: 16 March 2006
+# Whom: Daniel Bretoi
+#
+# $FreeBSD$
+#
+
+PORTNAME= SABnzbd
+PORTVERSION= 0.1.8
+CATEGORIES= news
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= sabnzbd
+
+MAINTAINER= daniel@netwalk.org
+COMMENT= A web-interface based binary newsgrabber in python, with nzb support
+
+BUILD_DEPENDS= ${RUN_DEPENDS}
+RUN_DEPENDS= cheetah:${PORTSDIR}/devel/py-cheetah \
+ ${PYTHON_SITELIBDIR}/cherrypy/__init__.py:${PORTSDIR}/www/py-cherrypy \
+ ${PYTHON_SITELIBDIR}/pythonutils/configobj.py:${PORTSDIR}/devel/py-utils \
+ ${PYTHON_SITELIBDIR}/cElementTree.so:${PORTSDIR}/devel/py-celementtree
+
+USE_PYTHON= 2.4
+USE_PYDISTUTILS=yes
+
+PLIST_SUB= PORTNAME=${PORTNAME}
+SUB_FILES= pkg-message
+
+OPTIONS= PAR2CMDLINE "Required for postprocessing of par files." on \
+ UNRAR "Often required for unpacking many downloads." on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_PAR2CMDLINE)
+RUN_DEPENDS+= par2repair:${PORTSDIR}/archivers/par2cmdline
+.endif
+
+.if !defined(WITHOUT_UNRAR)
+RUN_DEPENDS+= unrar:${PORTSDIR}/archivers/unrar
+.endif
+
+post-install:
+ ${CHMOD} -R go+r ${PREFIX}/share/${PORTNAME}/
+ ${CHMOD} -R go+r ${PREFIX}/share/doc/${PORTNAME}/
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/news/sabnzbd/distinfo b/news/sabnzbd/distinfo
new file mode 100644
index 000000000000..d6b1e1aab51b
--- /dev/null
+++ b/news/sabnzbd/distinfo
@@ -0,0 +1,3 @@
+MD5 (SABnzbd-0.1.8.tar.gz) = 835ddbb6393fc7fa9a8e9cfa5982bc98
+SHA256 (SABnzbd-0.1.8.tar.gz) = 4af2d13742776a79709f9884cfdb61ff1ab87b4d82370be09d1ee19d8e5dd41d
+SIZE (SABnzbd-0.1.8.tar.gz) = 54659
diff --git a/news/sabnzbd/files/patch-setup.py b/news/sabnzbd/files/patch-setup.py
new file mode 100644
index 000000000000..7e5a60e093d6
--- /dev/null
+++ b/news/sabnzbd/files/patch-setup.py
@@ -0,0 +1,18 @@
+*** setup.py.orig Sat Mar 4 13:16:01 2006
+--- setup.py Sat Mar 18 21:59:59 2006
+***************
+*** 15,20 ****
+ license = 'Academic Free License 2.1',
+! data_files = [('/usr/share/doc/SABnzbd-' + sabnzbd.__version__,
+! ['SABnzbd.ini.sample', 'README.txt', 'LICENSE.txt',
+ 'TODO.txt', 'CHANGELOG.txt', 'UPGRADE.txt']),
+! ('/usr/share/doc/SABnzbd-' + sabnzbd.__version__ + '/templates',
+ ['templates/default.css', 'templates/history.tmpl',
+--- 15,21 ----
+ license = 'Academic Free License 2.1',
+! data_files = [('share/doc/SABnzbd',
+! ['README.txt', 'LICENSE.txt',
+ 'TODO.txt', 'CHANGELOG.txt', 'UPGRADE.txt']),
+! ('share/SABnzbd',['SABnzbd.ini.sample']),
+! ('share/SABnzbd' + '/templates',
+ ['templates/default.css', 'templates/history.tmpl',
diff --git a/news/sabnzbd/files/pkg-message.in b/news/sabnzbd/files/pkg-message.in
new file mode 100644
index 000000000000..5bab6ca91f94
--- /dev/null
+++ b/news/sabnzbd/files/pkg-message.in
@@ -0,0 +1,6 @@
+
+****************************************************************************
+Check %%PREFIX%%/share/SABnzbd for SABnzbd.ini.sample and templates
+See %%PREFIX%%/share/doc/SABnzbd for README.txt etc
+****************************************************************************
+
diff --git a/news/sabnzbd/pkg-descr b/news/sabnzbd/pkg-descr
new file mode 100644
index 000000000000..4756c5cfd21a
--- /dev/null
+++ b/news/sabnzbd/pkg-descr
@@ -0,0 +1,4 @@
+A web-interface based standalone binary newsgrabber written in python, supports
+.nzb files
+
+WWW: http://sourceforge.net/projects/sabnzbd
diff --git a/news/sabnzbd/pkg-plist b/news/sabnzbd/pkg-plist
new file mode 100644
index 000000000000..1d3d3f0b5552
--- /dev/null
+++ b/news/sabnzbd/pkg-plist
@@ -0,0 +1,61 @@
+bin/SABnzbd.py
+%%PYTHON_SITELIBDIR%%/sabnzbd/__init__.py
+%%PYTHON_SITELIBDIR%%/sabnzbd/assembler.py
+%%PYTHON_SITELIBDIR%%/sabnzbd/cron.py
+%%PYTHON_SITELIBDIR%%/sabnzbd/downloader.py
+%%PYTHON_SITELIBDIR%%/sabnzbd/interface.py
+%%PYTHON_SITELIBDIR%%/sabnzbd/misc.py
+%%PYTHON_SITELIBDIR%%/sabnzbd/newsunpack.py
+%%PYTHON_SITELIBDIR%%/sabnzbd/newswrapper.py
+%%PYTHON_SITELIBDIR%%/sabnzbd/nzbgrab.py
+%%PYTHON_SITELIBDIR%%/sabnzbd/nzbqueue.py
+%%PYTHON_SITELIBDIR%%/sabnzbd/nzbstuff.py
+%%PYTHON_SITELIBDIR%%/sabnzbd/httpauthfilter_sabnzbd.py
+%%PYTHON_SITELIBDIR%%/sabnzbd/httpauth.py
+%%PYTHON_SITELIBDIR%%/sabnzbd/__init__.pyc
+%%PYTHON_SITELIBDIR%%/sabnzbd/assembler.pyc
+%%PYTHON_SITELIBDIR%%/sabnzbd/cron.pyc
+%%PYTHON_SITELIBDIR%%/sabnzbd/downloader.pyc
+%%PYTHON_SITELIBDIR%%/sabnzbd/interface.pyc
+%%PYTHON_SITELIBDIR%%/sabnzbd/misc.pyc
+%%PYTHON_SITELIBDIR%%/sabnzbd/newsunpack.pyc
+%%PYTHON_SITELIBDIR%%/sabnzbd/newswrapper.pyc
+%%PYTHON_SITELIBDIR%%/sabnzbd/nzbgrab.pyc
+%%PYTHON_SITELIBDIR%%/sabnzbd/nzbqueue.pyc
+%%PYTHON_SITELIBDIR%%/sabnzbd/nzbstuff.pyc
+%%PYTHON_SITELIBDIR%%/sabnzbd/httpauthfilter_sabnzbd.pyc
+%%PYTHON_SITELIBDIR%%/sabnzbd/httpauth.pyc
+%%PYTHON_SITELIBDIR%%/sabnzbd/__init__.pyo
+%%PYTHON_SITELIBDIR%%/sabnzbd/assembler.pyo
+%%PYTHON_SITELIBDIR%%/sabnzbd/cron.pyo
+%%PYTHON_SITELIBDIR%%/sabnzbd/downloader.pyo
+%%PYTHON_SITELIBDIR%%/sabnzbd/interface.pyo
+%%PYTHON_SITELIBDIR%%/sabnzbd/misc.pyo
+%%PYTHON_SITELIBDIR%%/sabnzbd/newsunpack.pyo
+%%PYTHON_SITELIBDIR%%/sabnzbd/newswrapper.pyo
+%%PYTHON_SITELIBDIR%%/sabnzbd/nzbgrab.pyo
+%%PYTHON_SITELIBDIR%%/sabnzbd/nzbqueue.pyo
+%%PYTHON_SITELIBDIR%%/sabnzbd/nzbstuff.pyo
+%%PYTHON_SITELIBDIR%%/sabnzbd/httpauthfilter_sabnzbd.pyo
+%%PYTHON_SITELIBDIR%%/sabnzbd/httpauth.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/sabnzbd
+%%PORTDOCS%%%%DOCSDIR%%/README.txt
+%%PORTDOCS%%%%DOCSDIR%%/LICENSE.txt
+%%PORTDOCS%%%%DOCSDIR%%/TODO.txt
+%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG.txt
+%%PORTDOCS%%%%DOCSDIR%%/UPGRADE.txt
+share/%%PORTNAME%%/SABnzbd.ini.sample
+share/%%PORTNAME%%/templates/default.css
+share/%%PORTNAME%%/templates/history.tmpl
+share/%%PORTNAME%%/templates/main.tmpl
+share/%%PORTNAME%%/templates/connection_info.tmpl
+share/%%PORTNAME%%/templates/config.tmpl
+share/%%PORTNAME%%/templates/queue.tmpl
+share/%%PORTNAME%%/templates/config_directories.tmpl
+share/%%PORTNAME%%/templates/config_general.tmpl
+share/%%PORTNAME%%/templates/config_server.tmpl
+share/%%PORTNAME%%/templates/config_switches.tmpl
+share/%%PORTNAME%%/templates/config_scheduling.tmpl
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm share/%%PORTNAME%%/templates
+@dirrm share/%%PORTNAME%%/