aboutsummaryrefslogtreecommitdiff
path: root/news/sn/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-02-23 16:30:00 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-02-23 16:30:00 +0000
commita856d49c1901463ec2afbacd8f82f61d1ff00769 (patch)
treecdb8b056d60b963a6181533bae36e3b55f20af2f /news/sn/Makefile
parent77928f84a7bab989c92ab68085ab3ec1a01817b9 (diff)
downloadports-a856d49c1901463ec2afbacd8f82f61d1ff00769.tar.gz
ports-a856d49c1901463ec2afbacd8f82f61d1ff00769.zip
Notes
Diffstat (limited to 'news/sn/Makefile')
-rw-r--r--news/sn/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/news/sn/Makefile b/news/sn/Makefile
new file mode 100644
index 000000000000..aea49efeabb7
--- /dev/null
+++ b/news/sn/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: sn
+# Date created: 2004-02-21
+# Whom: Andreas Fehlner <fehlner@gmx.del>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sn
+PORTVERSION= 0.3.6
+CATEGORIES= news
+MASTER_SITES= http://www.infa.abo.fi/~patrik/sn/files/
+EXTRACT_SUFX= .tar.bz2
+
+MAINTAINER= fehlner@gmx.de
+COMMENT= Small news system for small sites serving
+
+DOCS= README CHANGES FAQ INSTALL INTERNALS \
+ THANKS TODO INSTALL.notes INSTALL.notes2 \
+ INSTALL.run INSTALL.upgrade
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_REINPLACE= yes
+
+MAN8= sn.8 sncancel.8 sncat.8 sndelgroup.8 sndumpdb.8 \
+ snexpire.8 snfetch.8 snget.8 sngetd.8 snmail.8 \
+ snnewgroup.8 snntpd.8 snprimedb.8 snscan.8 snsend.8 \
+ snsplit.8 snstore.8
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^PREFIX|#PREFIX|g' ${WRKSRC}/Makefile
+
+pre-install:
+ @${MKDIR} /var/spool/news
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DOCS} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>