aboutsummaryrefslogtreecommitdiff
path: root/news/trn4
diff options
context:
space:
mode:
authorMatthew Hunt <mph@FreeBSD.org>2005-06-15 01:03:08 +0000
committerMatthew Hunt <mph@FreeBSD.org>2005-06-15 01:03:08 +0000
commita044150c7907eb0db9ecc46f4d1cfd642cef2c55 (patch)
tree2786a8c71310575d1266b7e656bceacd878712a2 /news/trn4
parentde9b30b80ad0f4bc21d7a09b6816c3cf493b8286 (diff)
downloadports-a044150c7907eb0db9ecc46f4d1cfd642cef2c55.tar.gz
ports-a044150c7907eb0db9ecc46f4d1cfd642cef2c55.zip
Notes
Diffstat (limited to 'news/trn4')
-rw-r--r--news/trn4/Makefile1
-rw-r--r--news/trn4/files/patch-term.c17
2 files changed, 18 insertions, 0 deletions
diff --git a/news/trn4/Makefile b/news/trn4/Makefile
index 908d48fb12c6..df4e6ab915a8 100644
--- a/news/trn4/Makefile
+++ b/news/trn4/Makefile
@@ -7,6 +7,7 @@
PORTNAME= trn
PORTVERSION= 4.0.b76
+PORTREVISION= 1
CATEGORIES= news
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/news/trn4/files/patch-term.c b/news/trn4/files/patch-term.c
new file mode 100644
index 000000000000..f07ced557c69
--- /dev/null
+++ b/news/trn4/files/patch-term.c
@@ -0,0 +1,17 @@
+
+$FreeBSD$
+
+--- term.c.orig
++++ term.c
+@@ -662,9 +662,9 @@
+ #endif
+ if (check_term) {
+ # ifdef FIONREAD
+- long iocount;
++ int iocount;
+ ioctl(0, FIONREAD, &iocount);
+- return (int)iocount;
++ return iocount;
+ # else /* !FIONREAD */
+ # ifdef HAS_RDCHK
+ return rdchk(0);